Latest upstream (1.1.3)

This commit is contained in:
Pádraig Brady 2017-03-05 19:52:50 -08:00
parent 528feda4ae
commit 94cc3493ac
5 changed files with 57 additions and 30 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/zstd-1.1.0.tar.gz
/zstd-1.1.1.tar.gz
/zstd-1.1.3.tar.gz

44
pzstd-warning.patch Normal file
View File

@ -0,0 +1,44 @@
diff -Naur zstd-1.1.3/contrib/pzstd/Pzstd.cpp zstd-1.1.3.new/contrib/pzstd/Pzstd.cpp
--- zstd-1.1.3/contrib/pzstd/Pzstd.cpp 2017-02-06 17:17:34.000000000 +0000
+++ zstd-1.1.3.new/contrib/pzstd/Pzstd.cpp 2017-03-06 03:10:16.130418128 +0000
@@ -410,7 +410,7 @@
});
// Pass the output queue to the writer thread.
chunks.push(std::move(out));
- state.log(VERBOSE, "Starting a new frame\n");
+ state.log(VERBOSE, "%s\n", "Starting a new frame");
// Fill the input queue for the compression job we just started
status = readData(*in, ZSTD_CStreamInSize(), step, fd, &bytesRead);
}
@@ -547,8 +547,8 @@
if (frameSize == 0) {
// We hit a non SkippableFrame ==> not compressed by pzstd or corrupted
// Pass the rest of the source to this decompression task
- state.log(VERBOSE,
- "Input not in pzstd format, falling back to serial decompression\n");
+ state.log(VERBOSE, "%s\n",
+ "Input not in pzstd format, falling back to serial decompression");
while (status == FileStatus::Continue && !state.errorHolder.hasError()) {
status = readData(*in, chunkSize, chunkSize, fd, &totalBytesRead);
}
diff -Naur zstd-1.1.3/contrib/pzstd/Pzstd.h zstd-1.1.3.new/contrib/pzstd/Pzstd.h
--- zstd-1.1.3/contrib/pzstd/Pzstd.h 2017-02-06 17:17:34.000000000 +0000
+++ zstd-1.1.3.new/contrib/pzstd/Pzstd.h 2017-03-06 03:08:23.019542883 +0000
@@ -41,7 +41,7 @@
auto parameters = options.determineParameters();
cStreamPool.reset(new ResourcePool<ZSTD_CStream>{
[this, parameters]() -> ZSTD_CStream* {
- this->log(VERBOSE, "Creating new ZSTD_CStream\n");
+ this->log(VERBOSE, "%s\n", "Creating new ZSTD_CStream");
auto zcs = ZSTD_createCStream();
if (zcs) {
auto err = ZSTD_initCStream_advanced(
@@ -59,7 +59,7 @@
} else {
dStreamPool.reset(new ResourcePool<ZSTD_DStream>{
[this]() -> ZSTD_DStream* {
- this->log(VERBOSE, "Creating new ZSTD_DStream\n");
+ this->log(VERBOSE, "%s\n", "Creating new ZSTD_DStream");
auto zds = ZSTD_createDStream();
if (zds) {
auto err = ZSTD_initDStream(zds);

View File

@ -1 +1 @@
487cfdc41d7afebb565c171bf3df27a2 zstd-1.1.1.tar.gz
SHA512 (zstd-1.1.3.tar.gz) = 6c025ca3899d0487bf2b4a9b333b47c6e2bb525ae3fc7328cc040f50d6f3c53a1bb9bd17e104352ddbc7b96b240c250c60d5be99e0a980332dbd3c518b2a81e1

View File

@ -1,24 +0,0 @@
diff -Naur zstd-1.1.0.orig/lib/Makefile zstd-1.1.0.new/lib/Makefile
--- zstd-1.1.0.orig/lib/Makefile 2016-09-27 22:15:03.000000000 +0000
+++ zstd-1.1.0.new/lib/Makefile 2016-10-06 10:56:25.612493000 +0000
@@ -57,9 +57,9 @@
.PHONY: default all clean install uninstall
-default: clean libzstd
+default: libzstd
-all: clean libzstd
+all: libzstd
libzstd: $(ZSTD_FILES)
@echo compiling static library
@@ -89,7 +89,7 @@
-e 's|@VERSION@|$(VERSION)|' \
$< >$@
-install: libzstd libzstd.pc
+install: libzstd.pc
@install -d -m 755 $(DESTDIR)$(LIBDIR)/pkgconfig/ $(DESTDIR)$(INCLUDEDIR)/
@install -m 755 libzstd.$(SHARED_EXT_VER) $(DESTDIR)$(LIBDIR)/libzstd.$(SHARED_EXT_VER)
@cp -a libzstd.$(SHARED_EXT_MAJOR) $(DESTDIR)$(LIBDIR)

View File

@ -8,17 +8,16 @@
%endif
Name: zstd
Version: 1.1.1
Release: 2%{?dist}
Version: 1.1.3
Release: 1%{?dist}
Summary: Zstd compression library
License: BSD and MIT
URL: https://github.com/facebook/zstd
Source0: https://github.com/facebook/zstd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
# https://github.com/facebook/zstd/pull/404
Patch0: zstd-lib-no-rebuild.patch
Patch1: pzstd.1.patch
Patch2: pzstd-warning.patch
BuildRequires: gcc gtest-devel
@ -43,9 +42,9 @@ Header files for Zstd library.
%prep
%setup -q
find -name .gitignore -delete
%patch0 -p1
%if 0%{?with_pzstd}
%patch1 -p1
%patch2 -p1
%endif
%build
@ -66,6 +65,10 @@ CFLAGS="%{optflags}" CXXFLAGS="%{optflags} -std=c++11" make -C contrib/pzstd tes
%install
%make_install PREFIX=%{_prefix} LIBDIR=%{_libdir}
# Remove undocumented wrappers of minimal use
rm %{buildroot}/%{_bindir}/%{name}less
rm %{buildroot}/%{_bindir}/%{name}grep
# Don't install the static lib
rm %{buildroot}/%{_libdir}/libzstd.a
%if 0%{?with_pzstd}
install -D -m755 contrib/pzstd/pzstd %{buildroot}/usr/bin/pzstd
@ -102,6 +105,9 @@ install -D -m644 programs/%{name}.1 %{buildroot}/%{_mandir}/man1/p%{name}.1
%postun -n lib%{name} -p /sbin/ldconfig
%changelog
* Mon Mar 06 2017 Pádraig Brady <P@draigBrady.com> - 1.1.3-1
- Latest upstream
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild