63 lines
2.0 KiB
Diff
63 lines
2.0 KiB
Diff
From f5fe371100b44d667065c8bba2c1522b26224c23 Mon Sep 17 00:00:00 2001
|
|
From: David Tardon <dtardon@redhat.com>
|
|
Date: Mon, 15 Feb 2016 19:08:14 +0100
|
|
Subject: [PATCH] cppunit-config no longer exists, use pkg-config
|
|
|
|
---
|
|
src/c/configure.ac | 4 +++-
|
|
src/recipes/lock/src/c/configure.ac | 2 +-
|
|
src/recipes/queue/src/c/configure.ac | 2 +-
|
|
3 files changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/c/configure.ac b/src/c/configure.ac
|
|
index b4ed639..09860d9 100644
|
|
--- a/src/c/configure.ac
|
|
+++ b/src/c/configure.ac
|
|
@@ -25,6 +25,8 @@ DX_INIT_DOXYGEN([zookeeper],[c-doc.Doxyfile],[docs])
|
|
AM_INIT_AUTOMAKE([-Wall foreign])
|
|
AC_CONFIG_HEADER([config.h])
|
|
|
|
+PKG_PROG_PKG_CONFIG
|
|
+
|
|
# Checks for programs.
|
|
AC_ARG_WITH(cppunit,
|
|
[ --without-cppunit do not use CPPUNIT])
|
|
@@ -34,7 +36,7 @@ if test "$with_cppunit" = "no" ; then
|
|
CPPUNIT_INCLUDE=
|
|
CPPUNIT_LIBS=
|
|
else
|
|
- AM_PATH_CPPUNIT(1.10.2)
|
|
+ PKG_CHECK_MODULES([CPPUNIT], [cppunit])
|
|
fi
|
|
|
|
if test "$CALLER" = "ANT" ; then
|
|
diff --git a/src/recipes/lock/src/c/configure.ac b/src/recipes/lock/src/c/configure.ac
|
|
index 3954123..f494058 100644
|
|
--- a/src/recipes/lock/src/c/configure.ac
|
|
+++ b/src/recipes/lock/src/c/configure.ac
|
|
@@ -72,7 +72,7 @@ AC_C_VOLATILE
|
|
AC_PROG_CC
|
|
AC_PROG_LIBTOOL
|
|
#check for cppunit
|
|
-AM_PATH_CPPUNIT(1.10.2)
|
|
+PKG_CHECK_MODULES([CPPUNIT], [cppunit])
|
|
# Checks for library functions.
|
|
AC_FUNC_UTIME_NULL
|
|
AC_CHECK_FUNCS([gettimeofday memset mkdir rmdir strdup strerror strstr strtol strtoul strtoull utime])
|
|
diff --git a/src/recipes/queue/src/c/configure.ac b/src/recipes/queue/src/c/configure.ac
|
|
index a9fb7b1..a2b840d 100644
|
|
--- a/src/recipes/queue/src/c/configure.ac
|
|
+++ b/src/recipes/queue/src/c/configure.ac
|
|
@@ -72,7 +72,7 @@ AC_C_VOLATILE
|
|
AC_PROG_CC
|
|
AC_PROG_LIBTOOL
|
|
#check for cppunit
|
|
-AM_PATH_CPPUNIT(1.10.2)
|
|
+PKG_CHECK_MODULES([CPPUNIT], [cppunit])
|
|
# Checks for library functions.
|
|
AC_FUNC_UTIME_NULL
|
|
AC_CHECK_FUNCS([gettimeofday memset mkdir rmdir strdup strerror strstr strtol strtoul strtoull utime])
|
|
--
|
|
2.5.0
|
|
|