Merge branch 'f20' into f21
Conflicts: zookeeper.spec
This commit is contained in:
commit
a9ea624e7e
20
zookeeper-3.4.6-server.patch
Normal file
20
zookeeper-3.4.6-server.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff --git a/bin/zkServer.sh b/bin/zkServer.sh
|
||||
index 0490982..b4766e5 100755
|
||||
--- a/bin/zkServer.sh
|
||||
+++ b/bin/zkServer.sh
|
||||
@@ -69,14 +69,7 @@ then
|
||||
ZOOCFG="$2"
|
||||
fi
|
||||
|
||||
-if $cygwin
|
||||
-then
|
||||
- ZOOCFG=`cygpath -wp "$ZOOCFG"`
|
||||
- # cygwin has a "kill" in the shell itself, gets confused
|
||||
- KILL=/bin/kill
|
||||
-else
|
||||
- KILL=kill
|
||||
-fi
|
||||
+KILL=kill
|
||||
|
||||
echo "Using config: $ZOOCFG" >&2
|
||||
|
@ -10,8 +10,15 @@ Type=forking
|
||||
User=zookeeper
|
||||
SyslogIdentifier=zookeeper
|
||||
WorkingDirectory=/var/lib/zookeeper
|
||||
ExecStart=/usr/bin/zkServer.sh
|
||||
#ExecStop=
|
||||
ExecStart=/usr/bin/zkServer.sh start zoo.cfg
|
||||
ExecStop=/usr/bin/zkServer.sh stop
|
||||
|
||||
User=root
|
||||
Group=root
|
||||
# TODO: check updated permissions.
|
||||
# Group=zookeeper
|
||||
Restart=always
|
||||
RestartSec=20
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
|
@ -16,7 +16,8 @@ Source3: zkEnv.sh
|
||||
|
||||
Patch1: %{name}-3.4.5-zktreeutil-gcc.patch
|
||||
Patch2: %{name}-3.4.6-ivy-build.patch
|
||||
#Patch3: {name}-3.4.5-add-PIE-and-RELRO.patch
|
||||
Patch3: %{name}-3.4.6-server.patch
|
||||
|
||||
# The native bits don't compile on ARM
|
||||
ExcludeArch: %{arm}
|
||||
|
||||
@ -83,20 +84,21 @@ naming, providing distributed synchronization, and providing group services.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for the %{name} library
|
||||
Requires: %{name}-lib%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Development files for the ZooKeeper C client library.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
BuildArch: noarch
|
||||
|
||||
%description javadoc
|
||||
This package contains javadoc for %{name}.
|
||||
|
||||
%package -n python-%{name}
|
||||
Summary: Python support for %{name}
|
||||
Requires: %{name}-lib%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Provides: zkpython%{?_isa} = %{version}-%{release}
|
||||
Requires: python2
|
||||
|
||||
@ -108,7 +110,7 @@ The python-%{name} package contains Python bindings for %{name}.
|
||||
|
||||
%patch1 -p0
|
||||
%patch2 -p1
|
||||
#%%patch3 -p1
|
||||
%patch3 -p1
|
||||
|
||||
iconv -f iso8859-1 -t utf-8 src/c/ChangeLog > src/c/ChangeLog.conv && mv -f src/c/ChangeLog.conv src/c/ChangeLog
|
||||
sed -i 's/\r//' src/c/ChangeLog
|
||||
@ -143,6 +145,11 @@ popd
|
||||
%endif
|
||||
|
||||
%install
|
||||
|
||||
# the following is used to update zkEnv.sh
|
||||
# find . -name "*.jar" -exec basename {} \; |sort|uniq
|
||||
# remove items that don't belong and update execute build-classpath
|
||||
|
||||
#install the c tools
|
||||
pushd src/c
|
||||
%make_install
|
||||
@ -251,11 +258,11 @@ getent passwd zookeeper >/dev/null || \
|
||||
%attr(0644,root,root) %{_sysconfdir}/zookeeper/zoo_sample.cfg
|
||||
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/zookeeper/log4j.properties
|
||||
|
||||
%attr(0750,zookeeper,zookeeper) %dir %{_localstatedir}/log/zookeeper
|
||||
%attr(0755,zookeeper,zookeeper) %dir %{_localstatedir}/log/zookeeper
|
||||
%attr(0755,root,root) %dir %{_sharedstatedir}/zookeeper
|
||||
%attr(0750,zookeeper,zookeeper) %dir %{_sharedstatedir}/zookeeper/data
|
||||
%attr(0640,zookeeper,zookeeper) %ghost %{_sharedstatedir}/zookeeper/data/myid
|
||||
%attr(0750,zookeeper,zookeeper) %dir %{_sharedstatedir}/zookeeper/log
|
||||
%attr(0755,zookeeper,zookeeper) %dir %{_sharedstatedir}/zookeeper/log
|
||||
%{_unitdir}/zookeeper.service
|
||||
%doc CHANGES.txt LICENSE.txt NOTICE.txt README.txt
|
||||
|
||||
@ -277,6 +284,7 @@ getent passwd zookeeper >/dev/null || \
|
||||
* Wed Oct 8 2014 Timothy St. Clair <tstclair@redhat.com> - 3.4.6-1
|
||||
- Update to latest stable series
|
||||
- Cleanup and overhaul package
|
||||
- Updated system integration
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.5-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
Loading…
x
Reference in New Issue
Block a user