Merge branch 'master' into el5
This commit is contained in:
commit
c7eaa132e0
3
.gitignore
vendored
3
.gitignore
vendored
@ -8,3 +8,6 @@ znc-0.094.tar.gz
|
||||
/znc-0.097.svn2255.tar.bz2
|
||||
/znc-0.097.svn2269.tar.bz2
|
||||
/znc-0.097.svn2272.tar.xz
|
||||
/znc-0.097.svn2277.tar.xz
|
||||
/znc-0.097.tar.xz
|
||||
/znc-0.098-alpha1.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
efc94ac63e6d4e4682a5978f3996da9e znc-0.097.svn2272.tar.xz
|
||||
88b3bf579bdceb763bc7d863049cccf2 znc-0.098-alpha1.tar.gz
|
||||
|
@ -1,23 +0,0 @@
|
||||
--- znc-0.097.svn2213/modules/modpython/compiler.cpp 2010-12-22 08:52:53.106613000 -0600
|
||||
+++ znc-0.097.svn2213-fixed/modules/modpython/compiler.cpp 2010-12-24 22:49:47.076861076 -0600
|
||||
@@ -8,9 +8,18 @@
|
||||
|
||||
#include <Python.h>
|
||||
|
||||
-int main() {
|
||||
+int main(int argc, char** argv) {
|
||||
Py_Initialize();
|
||||
- int res = PyRun_SimpleString("import compileall; print('Optimizing python files for later use...'); compileall.compile_dir('.')");
|
||||
+ int res = PyRun_SimpleString(
|
||||
+ "import compileall\n"
|
||||
+ "print('Optimizing python files for later use...')\n"
|
||||
+ "import sys\n"
|
||||
+ "if sys.version_info < (3, 2):\n"
|
||||
+ " compileall.compile_dir('.')\n"
|
||||
+ "else:\n"
|
||||
+ " compileall.compile_dir('.', legacy=True)\n"
|
||||
+ );
|
||||
Py_Finalize();
|
||||
return res;
|
||||
}
|
||||
+
|
42
znc.spec
42
znc.spec
@ -1,23 +1,24 @@
|
||||
Summary: An advanced IRC bouncer
|
||||
Name: znc
|
||||
Version: 0.097
|
||||
Release: 6.svn2272%{?dist}
|
||||
#Release: 0.1.rc1%{?dist}
|
||||
Version: 0.098
|
||||
#Release: 8.20110215git%{?dist}
|
||||
Release: 0.1.alpha1%{?dist}
|
||||
#Release: 2%{?dist}
|
||||
License: GPLv2 with exceptions
|
||||
Group: System Environment/Daemons
|
||||
URL: http://znc.sf.net/
|
||||
URL: http://znc.in
|
||||
#Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source0: znc-0.097.svn2272.tar.xz
|
||||
# svn export -r 2272 https://znc.svn.sourceforge.net/svnroot/znc/trunk
|
||||
# mv trunk znc-0.097.svn2272
|
||||
# tar Jcvf znc-0.097.svn2272.tar.xz znc-0.097.svn2272/
|
||||
#Source0: znc-0.097.tar.xz
|
||||
Source0: http://people.znc.in/~psychon/znc/releases/znc-0.098-alpha1.tar.gz
|
||||
# git clone https://github.com/znc/znc.git
|
||||
# cd znc
|
||||
# git archive --prefix=znc/ HEAD | xz > ../znc-0.097.tar.xz
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: perl gcc-c++ automake
|
||||
BuildRequires: perl gcc-c++
|
||||
BuildRequires: openssl-devel >= 0.9.8
|
||||
BuildRequires: cyrus-sasl-devel
|
||||
BuildRequires: c-ares-devel python3-devel
|
||||
BuildRequires: cyrus-sasl-devel python3-devel
|
||||
BuildRequires: c-ares-devel automake
|
||||
BuildRequires: perl(ExtUtils::Embed) swig tcl-devel
|
||||
|
||||
%description
|
||||
@ -70,10 +71,9 @@ Requires: python3
|
||||
%description modpython
|
||||
python module for ZNC
|
||||
|
||||
|
||||
%prep
|
||||
#%setup -q
|
||||
%setup -q -n znc-0.097.svn2272
|
||||
%setup -q -n %{name}-%{version}-alpha1
|
||||
%__perl -pi.add_release -e 's|(?<="ZNC \%1\.3f)|-%{release}|' znc.cpp
|
||||
chmod -x modules/q.cpp
|
||||
|
||||
@ -81,8 +81,8 @@ chmod -x modules/q.cpp
|
||||
./autogen.sh
|
||||
%configure \
|
||||
--with-module-prefix=%{_libdir}/znc \
|
||||
--enable-ipv6 --enable-extra --enable-sasl --enable-perl --enable-tcl \
|
||||
--enable-python
|
||||
--enable-ipv6 --enable-extra --enable-sasl --enable-perl \
|
||||
--enable-tcl --enable-python
|
||||
%__make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
@ -94,7 +94,7 @@ chmod -x modules/q.cpp
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc AUTHORS LICENSE LICENSE.OpenSSL README
|
||||
%doc AUTHORS LICENSE LICENSE.OpenSSL README.md
|
||||
%{_bindir}/znc
|
||||
%{_mandir}/man1/*
|
||||
%{_libdir}/znc/admin.so
|
||||
@ -171,6 +171,7 @@ chmod -x modules/q.cpp
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/znc/modperl/
|
||||
%{_libdir}/znc/modperl.so
|
||||
%{_libdir}/znc/perleval.pm
|
||||
|
||||
%files modpython
|
||||
%defattr(-,root,root)
|
||||
@ -178,6 +179,15 @@ chmod -x modules/q.cpp
|
||||
%{_libdir}/znc/modpython.so
|
||||
|
||||
%changelog
|
||||
* Wed Feb 23 2011 Nick Bebout <nb@fedoraproject.org> - 0.098-0.1.alpha1
|
||||
- Update to znc 0.098-alpha1
|
||||
|
||||
* Tue Feb 15 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-8.20110215git
|
||||
- Update to latest git
|
||||
|
||||
* Wed Feb 09 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-7.svn2277
|
||||
- Update to svn2277
|
||||
|
||||
* Mon Jan 24 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-6.svn2272
|
||||
- Update to svn2272
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user