Merge branch 'master' into el6

Conflicts:
	znc.spec
This commit is contained in:
Nick Bebout 2011-02-24 19:55:48 -06:00
commit 7d1112e53c
4 changed files with 12 additions and 29 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@ znc-0.094.tar.gz
/znc-0.097.svn2272.tar.xz
/znc-0.097.svn2277.tar.xz
/znc-0.097.tar.xz
/znc-0.098-alpha1.tar.gz

View File

@ -1 +1 @@
ef4368c196707c6cd93ef8591332bb30 znc-0.097.tar.xz
88b3bf579bdceb763bc7d863049cccf2 znc-0.098-alpha1.tar.gz

View File

@ -1,23 +0,0 @@
--- znc-0.097.svn2213/modules/modpython/compiler.cpp 2010-12-22 08:52:53.106613000 -0600
+++ znc-0.097.svn2213-fixed/modules/modpython/compiler.cpp 2010-12-24 22:49:47.076861076 -0600
@@ -8,9 +8,18 @@
#include <Python.h>
-int main() {
+int main(int argc, char** argv) {
Py_Initialize();
- int res = PyRun_SimpleString("import compileall; print('Optimizing python files for later use...'); compileall.compile_dir('.')");
+ int res = PyRun_SimpleString(
+ "import compileall\n"
+ "print('Optimizing python files for later use...')\n"
+ "import sys\n"
+ "if sys.version_info < (3, 2):\n"
+ " compileall.compile_dir('.')\n"
+ "else:\n"
+ " compileall.compile_dir('.', legacy=True)\n"
+ );
Py_Finalize();
return res;
}
+

View File

@ -1,14 +1,15 @@
Summary: An advanced IRC bouncer
Name: znc
Version: 0.097
Release: 8.20110215git%{?dist}
#Release: 0.1.rc1%{?dist}
Version: 0.098
#Release: 8.20110215git%{?dist}
Release: 0.1.alpha1%{?dist}
#Release: 2%{?dist}
License: GPLv2 with exceptions
Group: System Environment/Daemons
URL: http://znc.in
#Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
Source0: znc-0.097.tar.xz
#Source0: znc-0.097.tar.xz
Source0: http://people.znc.in/~psychon/znc/releases/znc-0.098-alpha1.tar.gz
# git clone https://github.com/znc/znc.git
# cd znc
# git archive --prefix=znc/ HEAD | xz > ../znc-0.097.tar.xz
@ -63,7 +64,7 @@ perl module for ZNC
%prep
#%setup -q
%setup -q -n %{name}
%setup -q -n %{name}-%{version}-alpha1
%__perl -pi.add_release -e 's|(?<="ZNC \%1\.3f)|-%{release}|' znc.cpp
chmod -x modules/q.cpp
@ -160,8 +161,12 @@ chmod -x modules/q.cpp
%defattr(-,root,root)
%{_libdir}/znc/modperl/
%{_libdir}/znc/modperl.so
%{_libdir}/znc/perleval.pm
%changelog
* Wed Feb 23 2011 Nick Bebout <nb@fedoraproject.org> - 0.098-0.1.alpha1
- Update to znc 0.098-alpha1
* Tue Feb 15 2011 Nick Bebout <nb@fedoraproject.org> - 0.097-8.20110215git
- Update to latest git