Added patch with rpath remove.

This commit is contained in:
Vitaly Zaitsev 2019-04-10 14:32:52 +02:00
parent d4a49b5dd3
commit 6e37d3cc82
No known key found for this signature in database
GPG Key ID: BF99FC6DD45AB90A
2 changed files with 28 additions and 2 deletions

26
zimlib-no-rpath.patch Normal file
View File

@ -0,0 +1,26 @@
From dd7e0ec915e4ad782328b496677bf7b122282560 Mon Sep 17 00:00:00 2001
From: Vitaly Zaitsev <vitaly@easycoding.org>
Date: Wed, 10 Apr 2019 14:31:32 +0200
Subject: [PATCH] Removed Rpath build.
---
src/meson.build | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/src/meson.build b/src/meson.build
index 671a23f..003047d 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -71,8 +71,6 @@ libzim = library('zim',
link_args : extra_link_args,
cpp_args : extra_cpp_args,
version: meson.project_version(),
- install : true,
- build_rpath : join_paths(get_option('prefix'), get_option('libdir')),
- install_rpath: '$ORIGIN')
+ install : true)
libzim_dep = declare_dependency(link_with: libzim,
include_directories: include_directory)
--
2.20.1

View File

@ -9,6 +9,7 @@ Summary: Reference implementation of the ZIM specification
URL: https://github.com/openzim/%{appname}
Source0: %{url}/archive/%{version}.tar.gz
Patch0: %{name}-no-rpath.patch
BuildRequires: xapian-core-devel
BuildRequires: libicu-devel
@ -33,8 +34,7 @@ Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
%{summary}.
%prep
%autosetup -n %{appname}-%{version}
sed -e '/rpath/d' -i src/meson.build
%autosetup -n %{appname}-%{version} -p1
%build
%meson