zhcon/zhcon-0.2.6-path.patch

68 lines
2.5 KiB
Diff

diff -ru zhcon-0.2.5/doc/Makefile.am zhcon-0.2.6/doc/Makefile.am
--- zhcon-0.2.5/doc/Makefile.am 2006-05-03 01:57:18.000000000 +0800
+++ zhcon-0.2.6/doc/Makefile.am 2007-02-12 17:46:12.000000000 +0800
@@ -3,8 +3,8 @@
EXTRA_DIST = zhcon.1.in poem.big5 poem.gb poem.gb.utf8 bpsf.txt manual.tex manual.dvi manual.ps README.html default.css html.tar.gz
install-data-local:
- $(mkinstalldirs) $(mandir)/man1/
- $(INSTALL_DATA) $(top_builddir)/doc/zhcon.1 $(mandir)/man1/zhcon.1
+ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1/
+ $(INSTALL_DATA) $(top_builddir)/doc/zhcon.1 $(DESTDIR)$(mandir)/man1/zhcon.1
uninstall-local:
- -rm -f $(mandir)/man1/zhcon.1
+ -rm -f $(DESTDIR)$(mandir)/man1/zhcon.1
diff -ru zhcon-0.2.5/font/Makefile.am zhcon-0.2.6/font/Makefile.am
--- zhcon-0.2.5/font/Makefile.am 2006-04-25 00:39:04.000000000 +0800
+++ zhcon-0.2.6/font/Makefile.am 2007-02-12 17:47:32.000000000 +0800
@@ -1,8 +1,8 @@
EXTRA_DIST = *.bpsf
install-data-local:
- $(mkinstalldirs) $(libdir)/zhcon/font/
- $(INSTALL_DATA) $(srcdir)/*.bpsf $(libdir)/zhcon/font/
+ $(mkinstalldirs) $(DESTDIR)$(libdir)/zhcon/font/
+ $(INSTALL_DATA) $(srcdir)/*.bpsf $(DESTDIR)$(libdir)/zhcon/font/
uninstall-local:
- -rm -f $(libdir)/zhcon/font/*.bpsf
+ -rm -f $(DESTDIR)$(libdir)/zhcon/font/*.bpsf
diff -ru zhcon-0.2.5/input/Makefile.am zhcon-0.2.6/input/Makefile.am
--- zhcon-0.2.5/input/Makefile.am 2006-04-25 00:38:44.000000000 +0800
+++ zhcon-0.2.6/input/Makefile.am 2007-02-12 17:48:22.000000000 +0800
@@ -1,8 +1,8 @@
EXTRA_DIST = *.mb
install-data-local:
- $(mkinstalldirs) $(libdir)/zhcon/input/
- $(INSTALL_DATA) $(srcdir)/*.mb $(libdir)/zhcon/input/
+ $(mkinstalldirs) $(DESTDIR)$(libdir)/zhcon/input/
+ $(INSTALL_DATA) $(srcdir)/*.mb $(DESTDIR)$(libdir)/zhcon/input/
uninstall-local:
- -rm -f $(libdir)/zhcon/input/*.mb
+ -rm -f $(DESTDIR)$(libdir)/zhcon/input/*.mb
diff -ru zhcon-0.2.5/src/Makefile.am zhcon-0.2.6/src/Makefile.am
--- zhcon-0.2.5/src/Makefile.am 2006-05-03 01:12:41.000000000 +0800
+++ zhcon-0.2.6/src/Makefile.am 2007-02-12 17:45:59.000000000 +0800
@@ -8,14 +8,14 @@
SUBDIRS = display
install-exec-local:
- chmod 4755 $(bindir)/zhcon
+ chmod 4755 $(DESTDIR)$(bindir)/zhcon
install-data-local:
- $(mkinstalldirs) $(prefix)/etc
- $(INSTALL_DATA) $(srcdir)/zhcon.conf $(prefix)/etc/zhcon.conf
+ $(mkinstalldirs) $(DESTDIR)$(prefix)/etc
+ $(INSTALL_DATA) $(srcdir)/zhcon.conf $(DESTDIR)$(prefix)/etc/zhcon.conf
uninstall-local:
- -rm -f $(prefix)/etc/zhcon.conf
+ -rm -f $(DESTDIR)$(prefix)/etc/zhcon.conf
# set the include path found by configure
INCLUDES= $(all_includes)