Apply Debian patch
This commit is contained in:
parent
c17efec8a4
commit
85cac5eebd
@ -1,2 +1,2 @@
|
||||
zhcon_0.2.6-4.1.diff.gz
|
||||
zhcon_0.2.6.orig.tar.gz
|
||||
zhcon_0.2.6-5.2.diff.gz
|
||||
|
@ -1,2 +1,3 @@
|
||||
zhcon-0_2_6-9_el5:HEAD:zhcon-0.2.6-9.el5.src.rpm:1216096288
|
||||
zhcon-0_2_6-10_fc9:HEAD:zhcon-0.2.6-10.fc9.src.rpm:1217222754
|
||||
zhcon-0_2_6-11_fc9:HEAD:zhcon-0.2.6-11.fc9.src.rpm:1227579222
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
0357d334637fc2fecf042eb9043f8b69 zhcon_0.2.6-4.1.diff.gz
|
||||
0f765cbe444776c9051a2b7c213737eb zhcon_0.2.6.orig.tar.gz
|
||||
e7f30d5ecc493ff8e090192fda0116b5 zhcon_0.2.6-5.2.diff.gz
|
||||
|
@ -214,17 +214,17 @@ diff -up ./src/iconv_string.c.gcc43 ./src/iconv_string.c
|
||||
size_t insize = end-start;
|
||||
char* outptr = result;
|
||||
size_t outsize = length;
|
||||
diff -up ./src/inputclient.cpp.gcc43 ./src/inputclient.cpp
|
||||
--- ./src/inputclient.cpp.gcc43 2006-04-25 02:38:27.000000000 +1000
|
||||
+++ ./src/inputclient.cpp 2008-07-15 12:31:16.000000000 +1000
|
||||
@@ -16,6 +16,7 @@
|
||||
* *
|
||||
***************************************************************************/
|
||||
diff -up src/inputmanager.h.gcc43 src/inputmanager.h
|
||||
--- src/inputmanager.h.gcc43 2008-11-21 17:18:50.000000000 +1000
|
||||
+++ src/inputmanager.h 2008-11-21 17:20:28.000000000 +1000
|
||||
@@ -27,6 +27,7 @@ using namespace std;
|
||||
#include <cassert>
|
||||
#include <vector>
|
||||
#include <sys/types.h>
|
||||
+#include <sys/select.h>
|
||||
|
||||
+#include <stdlib.h>
|
||||
#include "inputclient.h"
|
||||
|
||||
Console* InputClient::mpCon = NULL;
|
||||
#include "mouse.h"
|
||||
#if defined(__FreeBSD__)
|
||||
diff -up ./src/inputmanager.cpp.gcc43 ./src/inputmanager.cpp
|
||||
--- ./src/inputmanager.cpp.gcc43 2006-05-03 03:18:39.000000000 +1000
|
||||
+++ ./src/inputmanager.cpp 2008-07-15 12:31:16.000000000 +1000
|
||||
@ -236,16 +236,6 @@ diff -up ./src/inputmanager.cpp.gcc43 ./src/inputmanager.cpp
|
||||
|
||||
#include "global.h"
|
||||
#include "debug.h"
|
||||
--- ./src/inputmanager.h.gcc43 2006-04-25 02:38:26.000000000 +1000
|
||||
+++ ./src/inputmanager.h 2008-07-15 12:31:16.000000000 +1000
|
||||
@@ -26,6 +26,7 @@
|
||||
using namespace std;
|
||||
#include <cassert>
|
||||
#include <vector>
|
||||
+#include <sys/select.h>
|
||||
|
||||
#include "mouse.h"
|
||||
#if defined(__FreeBSD__)
|
||||
--- ./src/nativeinputserver.h.gcc43 2006-04-25 02:38:26.000000000 +1000
|
||||
+++ ./src/nativeinputserver.h 2008-07-15 12:31:16.000000000 +1000
|
||||
@@ -62,7 +62,7 @@ class NativeInputServer : public InputSe
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -ru zhcon-0.2.6.orig/src/display/lrmi.c zhcon-0.2.6/src/display/lrmi.c
|
||||
--- zhcon-0.2.6.orig/src/display/lrmi.c 2008-07-29 10:38:13.000000000 +0100
|
||||
+++ zhcon-0.2.6/src/display/lrmi.c 2008-07-29 10:39:51.000000000 +0100
|
||||
@@ -176,7 +176,7 @@
|
||||
}
|
||||
|
||||
|
||||
-#define DEFAULT_VM86_FLAGS (IF_MASK | IOPL_MASK)
|
||||
+#define DEFAULT_VM86_FLAGS (X86_EFLAGS_IF | X86_EFLAGS_IOPL)
|
||||
#define DEFAULT_STACK_SIZE 0x1000
|
||||
#define RETURN_TO_32_INT 255
|
||||
|
||||
@@ -790,7 +790,7 @@
|
||||
|
||||
context.vm.regs.cs = get_int_seg(v);
|
||||
context.vm.regs.eip = get_int_off(v);
|
||||
- context.vm.regs.eflags &= ~(VIF_MASK | TF_MASK);
|
||||
+ context.vm.regs.eflags &= ~(X86_EFLAGS_VIF | X86_EFLAGS_TF);
|
||||
|
||||
continue;
|
||||
}
|
37
zhcon-0.2.6-xf86int10.patch
Normal file
37
zhcon-0.2.6-xf86int10.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff -up ./src/display/lrmi.c.xf86int10 ./src/display/lrmi.c
|
||||
--- ./src/display/lrmi.c.xf86int10 2006-04-25 02:38:23.000000000 +1000
|
||||
+++ ./src/display/lrmi.c 2008-11-24 17:01:19.000000000 +1000
|
||||
@@ -13,6 +13,15 @@ This software has NO WARRANTY. Use it a
|
||||
#ifdef HAVE_CONFIG_H
|
||||
#include <config.h>
|
||||
#endif
|
||||
+#define X86_TF_MASK 0x00000100
|
||||
+#define X86_IF_MASK 0x00000200
|
||||
+#define X86_IOPL_MASK 0x00003000
|
||||
+#define X86_NT_MASK 0x00004000
|
||||
+#define X86_VM_MASK 0x00020000
|
||||
+#define X86_AC_MASK 0x00040000
|
||||
+#define X86_VIF_MASK 0x00080000 /* virtual interrupt flag */
|
||||
+#define X86_VIP_MASK 0x00100000 /* virtual interrupt pending */
|
||||
+#define X86_ID_MASK 0x00200000
|
||||
|
||||
#ifdef USING_VGA
|
||||
#if defined(linux)
|
||||
@@ -176,7 +185,7 @@ LRMI_free_real(void *m)
|
||||
}
|
||||
|
||||
|
||||
-#define DEFAULT_VM86_FLAGS (IF_MASK | IOPL_MASK)
|
||||
+#define DEFAULT_VM86_FLAGS (X86_IF_MASK | X86_IOPL_MASK)
|
||||
#define DEFAULT_STACK_SIZE 0x1000
|
||||
#define RETURN_TO_32_INT 255
|
||||
|
||||
@@ -790,7 +799,7 @@ run_vm86(void)
|
||||
|
||||
context.vm.regs.cs = get_int_seg(v);
|
||||
context.vm.regs.eip = get_int_off(v);
|
||||
- context.vm.regs.eflags &= ~(VIF_MASK | TF_MASK);
|
||||
+ context.vm.regs.eflags &= ~(X86_VIF_MASK | X86_TF_MASK);
|
||||
|
||||
continue;
|
||||
}
|
14
zhcon.spec
14
zhcon.spec
@ -4,15 +4,15 @@ Version: 0.2.6
|
||||
Release: 11%{?dist}
|
||||
Group: Applications/System
|
||||
License: GPLv2+
|
||||
URL: http://www.sourceforge.net/projects/%{name}/
|
||||
URL: http://zhcon.sourceforge.net/
|
||||
Source0: http://ftp.debian.org/debian/pool/main/z/zhcon/%{name}_%{version}.orig.tar.gz
|
||||
Patch0: http://ftp.debian.org/debian/pool/main/z/zhcon/%{name}_%{version}-4.1.diff.gz
|
||||
Patch0: http://ftp.debian.org/debian/pool/main/z/zhcon/%{name}_%{version}-5.2.diff.gz
|
||||
Patch1: %{name}-%{version}-flags.patch
|
||||
Patch2: %{name}-%{version}-path-define.patch
|
||||
Patch3: %{name}-%{version}-gcc43.patch
|
||||
Patch4: %{name}-%{version}-locale.patch
|
||||
Patch5: %{name}-%{version}-keyswitch.patch
|
||||
Patch6: %{name}-%{version}-processor-flags.patch
|
||||
Patch6: %{name}-%{version}-xf86int10.patch
|
||||
Summary: A fast Linux Console Chinese System that supports framebuffer
|
||||
Summary(zh_CN): Zhcon 是一个支持 Framebuffer 的 Linux 中日韩文控制台
|
||||
Summary(zh_TW): Zhcon 是一個支援 Framebuffer 及多內碼 Linux 中日韓文主控台
|
||||
@ -47,13 +47,13 @@ zhcon 是一個支援 Framebuffer 與多内碼的 Linux 中日韓文主控台。
|
||||
現支援的內碼有: UTF8, GB2312, GBK, BIG5, JIS 及 KSC。
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .4-1
|
||||
%patch0 -p1 -b .5-2
|
||||
%patch1 -p1 -b .flags
|
||||
%patch2 -p0 -b .path-define
|
||||
%patch3 -p0 -b .gcc43
|
||||
%patch4 -p0 -b .locale
|
||||
%patch5 -p0 -b .keyswitch
|
||||
%patch6 -p1 -b .processor-flags
|
||||
%patch6 -p0 -b .xf86int10
|
||||
iconv -f GB2312 -t UTF-8 ChangeLog -o ChangeLog.utf && mv -f ChangeLog.utf ChangeLog
|
||||
( cd doc; tar -zxf html.tar.gz; chmod 755 manual)
|
||||
|
||||
@ -85,8 +85,8 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_datadir}/%{name}/
|
||||
|
||||
%changelog
|
||||
* Tue Jul 29 2008 Caolán McNamara <caolanm@redhat.com> - 0.2.6-11
|
||||
- add zhcon-0.2.6-processor-flags.patch to build on rawhide
|
||||
* Tue Nov 25 2008 Ding-Yi Chen <dchen at redhat dot com> - 0.2.6-11
|
||||
- Debian provide patch of zhcon_0.2.6-5.2.diff.gz
|
||||
|
||||
* Mon Jul 15 2008 Ding-Yi Chen <dchen at redhat dot com> - 0.2.6-10
|
||||
- Address the dependence in RHEL5 and Fedora <= 8 which do not have ncurses-libs.
|
||||
|
Loading…
Reference in New Issue
Block a user