Version 4.12.2

This commit is contained in:
Jerry James 2023-05-15 08:44:33 -06:00
parent 0c0af7bf22
commit ee66c97a95
3 changed files with 34 additions and 3 deletions

View File

@ -1 +1 @@
SHA512 (z3-4.12.1.tar.gz) = 031fba9cc000a8da0025f95fa3f1c7519071d1b7775b377ff3192c505bb4c7e3d267da246c9ae68c940224e055a3c30571d2c0d7fbb042ec9a3d5849543a385c
SHA512 (z3-4.12.2.tar.gz) = 375477cbbc9837b44e752c89916409d07bf6a73830b52878aab4f376f08b37dd5ab485da225744d394ab15f2a7e1014edc3be5eb9962934c440a8d55259317e2

25
z3-stdint.patch Normal file
View File

@ -0,0 +1,25 @@
Fixes errors such as these:
In file included from /builddir/build/BUILD/z3-z3-4.12.2/src/util/region.cpp:53:
/builddir/build/BUILD/z3-z3-4.12.2/src/util/region.cpp: In member function void* region::allocate(size_t):
/builddir/build/BUILD/z3-z3-4.12.2/src/util/tptr.h:29:62: error: uintptr_t does not name a type
29 | #define ALIGN(T, PTR) reinterpret_cast<T>(((reinterpret_cast<uintptr_t>(PTR) >> PTR_ALIGNMENT) + \
| ^~~~~~~~~
/builddir/build/BUILD/z3-z3-4.12.2/src/util/region.cpp:82:22: note: in expansion of macro ALIGN
82 | m_curr_ptr = ALIGN(char *, new_curr_ptr);
| ^~~~~
/builddir/build/BUILD/z3-z3-4.12.2/src/util/region.cpp:57:1: note: uintptr_t is defined in header <cstdint>; did you forget to #include <cstdint>?
56 | #include "util/page.h"
+++ |+#include <cstdint>
57 |
--- z3-z3-4.12.2/src/util/tptr.h.orig 2023-05-12 13:59:04.000000000 -0600
+++ z3-z3-4.12.2/src/util/tptr.h 2023-05-13 07:04:48.389716628 -0600
@@ -19,6 +19,7 @@ Revision History:
#pragma once
+#include <cstdint>
#include "util/machine.h"
#define TAG_SHIFT PTR_ALIGNMENT

10
z3.spec
View File

@ -15,8 +15,8 @@
%bcond_with test
Name: z3
Version: 4.12.1
Release: 2%{?dist}
Version: 4.12.2
Release: 1%{?dist}
Summary: Satisfiability Modulo Theories (SMT) solver
License: MIT
@ -24,6 +24,9 @@ URL: https://github.com/Z3Prover/z3
Source0: https://github.com/Z3Prover/z3/archive/%{name}-%{version}.tar.gz
# Change the way python finds the shared object; see bz 1910923
Patch0: %{name}-python.patch
# Add a missing include of cstdint
# https://github.com/Z3Prover/z3/pull/6720
Patch1: %{name}-stdint.patch
BuildRequires: cmake
BuildRequires: doxygen
@ -290,6 +293,9 @@ cd -
%{python3_sitelib}/z3/
%changelog
* Mon May 15 2023 Jerry James <loganjerry@gmail.com> - 4.12.2-1
- Version 4.12.2
* Tue Jan 24 2023 Richard W.M. Jones <rjones@redhat.com> - 4.12.1-2
- Rebuild OCaml packages for F38