New upstream version.
Add -ocamldoc patch to fix documentation build failure.
This commit is contained in:
parent
42ae6f3f75
commit
bc5419f37d
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (z3-4.8.6.tar.gz) = d338413274a3d11a9e9287202989df9da4c31e095c14428a418d4019e9f86c0e2b681c519d2d0bcbb4cd99a722a2539006f5c86ade568b1ee208545b142369f1
|
||||
SHA512 (z3-4.8.7.tar.gz) = 145e2b2f1fa4edd0917107c7e1d54d779c7ed85c48af2ce6def4c90d1c4db05f74c9657e173cedf48770589fbe484c97fa1923295271cd3792523ffc4f67ed0c
|
||||
|
13
z3-ocamldoc.patch
Normal file
13
z3-ocamldoc.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/doc/mk_api_doc.py b/doc/mk_api_doc.py
|
||||
index bfe865e06..7bcc1c017 100644
|
||||
--- a/doc/mk_api_doc.py
|
||||
+++ b/doc/mk_api_doc.py
|
||||
@@ -317,7 +317,7 @@ try:
|
||||
if ML_ENABLED:
|
||||
ml_output_dir = os.path.join(OUTPUT_DIRECTORY, 'html', 'ml')
|
||||
mk_dir(ml_output_dir)
|
||||
- if subprocess.call(['ocamldoc', '-html', '-d', ml_output_dir, '-sort', '-hide', 'Z3', '-I', '%s/api/ml' % BUILD_DIR, '%s/api/ml/z3enums.mli' % BUILD_DIR, '%s/api/ml/z3.mli' % BUILD_DIR]) != 0:
|
||||
+ if subprocess.call(['ocamldoc', '-html', '-d', ml_output_dir, '-sort', '-hide', 'Z3', '-I', '+zarith', '-I', '%s/api/ml' % BUILD_DIR, '%s/api/ml/z3enums.mli' % BUILD_DIR, '%s/api/ml/z3.mli' % BUILD_DIR]) != 0:
|
||||
print("ERROR: ocamldoc failed.")
|
||||
exit(1)
|
||||
print("Generated ML/OCaml documentation.")
|
25
z3.rpmlintrc
Normal file
25
z3.rpmlintrc
Normal file
@ -0,0 +1,25 @@
|
||||
# THIS FILE IS FOR WHITELISTING RPMLINT ERRORS AND WARNINGS IN TASKOTRON
|
||||
# https://fedoraproject.org/wiki/Taskotron/Tasks/dist.rpmlint#Whitelisting_errors
|
||||
|
||||
# The dictionary is missing some technical terms
|
||||
addFilter(r'W: spelling-error .* ((S|s)atisfiability|datatypes)')
|
||||
|
||||
# Shared objects in the python arch directory are not devel files
|
||||
addFilter(r'python3-z3\.[^:]+: W: devel-file-in-non-devel-package .*libz3\.so')
|
||||
|
||||
# The documentation is in the -doc subpackage
|
||||
addFilter(r'W: no-documentation')
|
||||
|
||||
# Oh yes, we have no manual page
|
||||
addFilter(r'W: no-manual-page-for-binary z3')
|
||||
|
||||
# The configure script is not an autotools-generated script
|
||||
addFilter(r'z3\.spec:[^:]*: W: configure-without-libdir-spec')
|
||||
|
||||
# The spec file moves the shared object from /usr/lib to /usr/lib64 on 64-bit
|
||||
# systems, the opposite of the problem this warning is intended to catch.
|
||||
addFilter(r'z3\.spec:[^:]+: E: hardcoded-library-path in %{_prefix}/lib/libz3\.so\*')
|
||||
|
||||
# This is where JAR files are supposed to go when there is a binary interface.
|
||||
addFilter(r'z3\.spec:[^:]+: E: hardcoded-library-path in %{_prefix}/lib/\*\.jar')
|
||||
addFilter(r'z3\.spec:[^:]+: E: hardcoded-library-path in %{_prefix}/lib/lib%{name}java\.so')
|
21
z3.spec
21
z3.spec
@ -1,7 +1,7 @@
|
||||
%global medtag 78ed71b8de7d
|
||||
%global medtag 30e7c225cd51
|
||||
|
||||
Name: z3
|
||||
Version: 4.8.6
|
||||
Version: 4.8.7
|
||||
Release: 1%{?dist}
|
||||
Summary: Satisfiability Modulo Theories (SMT) solver
|
||||
|
||||
@ -9,17 +9,20 @@ License: MIT
|
||||
URL: https://github.com/Z3Prover/z3
|
||||
Source0: https://github.com/Z3Prover/z3/archive/%{name}-%{version}.tar.gz
|
||||
|
||||
# https://github.com/Z3Prover/z3/pull/2730
|
||||
Patch0: %{name}-ocamldoc.patch
|
||||
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gmp-devel
|
||||
BuildRequires: graphviz
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: javapackages-tools
|
||||
BuildRequires: ocaml
|
||||
BuildRequires: ocaml-findlib
|
||||
BuildRequires: ocaml-ocamldoc
|
||||
BuildRequires: ocaml-num-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: ocaml-zarith-devel
|
||||
BuildRequires: pkgconfig(python3)
|
||||
BuildRequires: python3dist(setuptools)
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
@ -56,7 +59,7 @@ API documentation for Z3.
|
||||
Summary: Java interface to z3
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: java
|
||||
Requires: jpackage-utils
|
||||
Requires: javapackages-tools
|
||||
|
||||
%description -n java-%{name}
|
||||
Java interface to z3.
|
||||
@ -88,7 +91,7 @@ Provides: python2-%{name} = 4.8
|
||||
Python 3 interface to z3.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{name}-%{version}
|
||||
%autosetup -p1 -n %{name}-%{name}-%{version}
|
||||
|
||||
# Install python objects into the right place, enable verbose builds, use
|
||||
# Fedora CFLAGS, preserve timestamps when installing, include the entire
|
||||
@ -217,6 +220,10 @@ mv %{buildroot}%{_prefix}/lib/lib%{name}java.so %{buildroot}%{_libdir}/%{name}
|
||||
%{python3_sitearch}/%{name}/
|
||||
|
||||
%changelog
|
||||
* Thu Nov 21 2019 Jerry James <loganjerry@gmail.com> - 4.8.7-1
|
||||
- New upstream version
|
||||
- Add -ocamldoc patch to fix documentation build failure
|
||||
|
||||
* Fri Sep 20 2019 Jerry James <loganjerry@gmail.com> - 4.8.6-1
|
||||
- New upstream version
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user