New upstream version.
This commit is contained in:
parent
e0c54db4a3
commit
a020e58b53
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
/Z3Prover-z3-29606b5.tar.gz
|
||||
/z3-4.4.0.tar.gz
|
||||
/z3-4.4.1.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
2bcbb0381cc1572cace99aac8af08990 z3-4.4.0.tar.gz
|
||||
4336a9df24f090e711c6d42fd4e2b1fc z3-4.4.1.tar.gz
|
||||
|
1761
z3-export.patch
1761
z3-export.patch
File diff suppressed because it is too large
Load Diff
@ -1,7 +1,7 @@
|
||||
--- ./src/util/hwf.cpp.orig 2015-04-29 08:40:46.000000000 -0600
|
||||
+++ ./src/util/hwf.cpp 2015-05-27 21:40:59.984496739 -0600
|
||||
@@ -31,7 +31,7 @@ Revision History:
|
||||
#include <fenv.h>
|
||||
--- ./src/util/hwf.cpp.orig 2015-10-05 06:07:19.000000000 -0600
|
||||
+++ ./src/util/hwf.cpp 2015-10-08 19:57:59.046584973 -0600
|
||||
@@ -29,7 +29,7 @@ Revision History:
|
||||
#include<fenv.h>
|
||||
#endif
|
||||
|
||||
-#ifndef _M_IA64
|
||||
@ -9,7 +9,7 @@
|
||||
#define USE_INTRINSICS
|
||||
#endif
|
||||
|
||||
@@ -51,7 +51,7 @@ Revision History:
|
||||
@@ -47,7 +47,7 @@ Revision History:
|
||||
// Luckily, these are kind of standardized, at least for Windows/Linux/OSX.
|
||||
#ifdef __clang__
|
||||
#undef USE_INTRINSICS
|
||||
|
25
z3.spec
25
z3.spec
@ -4,11 +4,11 @@
|
||||
# and submit the results upstream, I'm sure many people would be grateful.
|
||||
|
||||
%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
|
||||
%global medtag 7f6ef0b6c081
|
||||
%global medtag 95c9ccb2959a
|
||||
|
||||
Name: z3
|
||||
Version: 4.4.0
|
||||
Release: 4%{?dist}
|
||||
Version: 4.4.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Satisfiability Modulo Theories (SMT) solver
|
||||
|
||||
License: MIT
|
||||
@ -16,8 +16,6 @@ URL: https://github.com/Z3Prover/z3
|
||||
Source0: https://github.com/Z3Prover/z3/archive/%{name}-%{version}.tar.gz
|
||||
# Do not try to build with SSE2 on non-x86_64 arches
|
||||
Patch0: %{name}-sse2.patch
|
||||
# Export symbols needed by the z3 binary; problem started with 4.4.0 release
|
||||
Patch1: %{name}-export.patch
|
||||
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: gmp-devel
|
||||
@ -92,12 +90,12 @@ Python 2 interface to z3.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{name}-%{version}
|
||||
%patch0
|
||||
%patch1
|
||||
|
||||
# Install python objects into the right place, enable verbose builds, use
|
||||
# Fedora CFLAGS, preserve timestamps when installing, include the entire
|
||||
# contents of the archives in the library, link the library with the correct
|
||||
# flags, build the library with -fPIC on all arches, and use an soname.
|
||||
# flags, don't hide library symbols needed by the executable, and use an
|
||||
# soname.
|
||||
sed -e "s|^\(PYTHON_PACKAGE_DIR=\).*|\1'%{python2_sitearch}/z3'|" \
|
||||
-e "s|\(PYTHON_PACKAGE_DIR = \).*|\1'%{buildroot}%{python2_sitearch}/z3'|" \
|
||||
-e 's/@$(CXX)/$(CXX)/' \
|
||||
@ -106,20 +104,18 @@ sed -e "s|^\(PYTHON_PACKAGE_DIR=\).*|\1'%{python2_sitearch}/z3'|" \
|
||||
-e "s/\(SLIBEXTRAFLAGS = '\)'/\1-Wl,--no-whole-archive -Wl,--as-needed'/" \
|
||||
-e "s|-shared|& $RPM_LD_FLAGS -Wl,--whole-archive|" \
|
||||
-e 's/\(libz3$(SO_EXT)\)\(\\n\)/\1 -Wl,--no-whole-archive\2/' \
|
||||
-e '/fPIC/d;' \
|
||||
-e "s/'tstomp\.cpp',/& '-fPIC',/" \
|
||||
-e 's/ -fvisibility=hidden//' \
|
||||
-e 's/-shared/& -Wl,-h,lib%{name}.so.0/' \
|
||||
-i scripts/mk_util.py
|
||||
|
||||
# Do not try to build with SSE2 support on non-x86_64 arches.
|
||||
%ifnarch x86_64
|
||||
sed -i '/msse2/d;s/ -mfpmath=sse//' scripts/mk_util.py
|
||||
sed -i 's/exec_compiler_cmd.*-msse.*:/false:/' scripts/mk_util.py
|
||||
%endif
|
||||
|
||||
# Comply with the Java packaging guidelines
|
||||
sed -e "s/\(System\.load\)Library/\1/" \
|
||||
-e "s,get_component('java')\.dll_name.*,'%{_libdir}/z3/libz3java.so')," \
|
||||
-i scripts/update_api.py
|
||||
sed -i "s/\(System\.load\)Library/\1/" scripts/update_api.py
|
||||
|
||||
# Fix character encoding
|
||||
iconv -f iso8859-1 -t utf-8 RELEASE_NOTES > RELEASE_NOTES.utf8
|
||||
@ -136,7 +132,7 @@ sed -i 's,api\\html\\ml,api/html/ml,' doc/mk_api_doc.py
|
||||
|
||||
%build
|
||||
export CXXFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||
export LDFLAGS="$RPM_LD_FLAGS -Wl,--as-needed"
|
||||
export LDFLAGS="$RPM_LD_FLAGS -Wl,--as-needed -lgmp"
|
||||
export LANG="en_US.UTF-8"
|
||||
export PYTHON="%{__python2}"
|
||||
|
||||
@ -259,6 +255,9 @@ chmod 0755 %{buildroot}%{_bindir}/* %{buildroot}%{_libdir}/*.so.0.0.0 \
|
||||
%{python2_sitearch}/%{name}/
|
||||
|
||||
%changelog
|
||||
* Thu Oct 8 2015 Jerry James <loganjerry@gmail.com> - 4.4.1-1
|
||||
- New upstream version
|
||||
|
||||
* Tue Jul 28 2015 Richard W.M. Jones <rjones@redhat.com> - 4.4.0-4
|
||||
- OCaml 4.02.3 rebuild.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user