Fix FTBFS due to a vector access.
This commit is contained in:
parent
25167ae5c7
commit
801e577186
11
z3-vector.patch
Normal file
11
z3-vector.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/util/lp/permutation_matrix.h.orig 2017-12-18 07:18:30.000000000 -0700
|
||||
+++ src/util/lp/permutation_matrix.h 2018-02-13 20:45:39.712845059 -0700
|
||||
@@ -132,7 +132,7 @@ class permutation_matrix : public tail_m
|
||||
|
||||
unsigned size() const { return static_cast<unsigned>(m_rev.size()); }
|
||||
|
||||
- unsigned * values() const { return m_permutation; }
|
||||
+ unsigned * values() const { return m_permutation.c_ptr(); }
|
||||
|
||||
void resize(unsigned size) {
|
||||
unsigned old_size = m_permutation.size();
|
7
z3.spec
7
z3.spec
@ -10,6 +10,8 @@ URL: https://github.com/Z3Prover/z3
|
||||
Source0: https://github.com/Z3Prover/z3/archive/%{name}-%{version}.tar.gz
|
||||
# Do not try to build with SSE2 on non-x86_64 arches
|
||||
Patch0: %{name}-sse2.patch
|
||||
# Fix a vector access
|
||||
Patch1: %{name}-vector.patch
|
||||
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: gcc-c++
|
||||
@ -98,6 +100,7 @@ Python 3 interface to z3.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{name}-%{version}
|
||||
%patch0
|
||||
%patch1
|
||||
|
||||
# Install python objects into the right place, enable verbose builds, use
|
||||
# Fedora CFLAGS, preserve timestamps when installing, include the entire
|
||||
@ -219,9 +222,7 @@ mv %{buildroot}%{_prefix}/lib/lib%{name}java.so %{buildroot}%{_libdir}/%{name}
|
||||
#./test-z3 /a
|
||||
#popd
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
%postun libs -p /sbin/ldconfig
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%doc README.md RELEASE_NOTES
|
||||
|
Loading…
Reference in New Issue
Block a user