Build with SSE2 support on 32-bit x86.

This commit is contained in:
Jerry James 2018-09-07 18:27:48 -06:00
parent e6a17e9e23
commit 4c5d018dee
2 changed files with 8 additions and 20 deletions

View File

@ -1,12 +0,0 @@
--- src/util/hwf.cpp.orig 2017-12-19 21:13:53.225563733 -0700
+++ src/util/hwf.cpp 2017-12-19 21:15:00.345290291 -0700
@@ -29,8 +29,7 @@ Revision History:
#include<fenv.h>
#endif
-#if defined(__x86_64__) || defined(_M_X64) || \
- defined(__i386) || defined(_M_IX86)
+#if defined(__x86_64__) || defined(_M_X64)
#define USE_INTRINSICS
#endif

16
z3.spec
View File

@ -2,14 +2,12 @@
Name: z3
Version: 4.7.1
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Satisfiability Modulo Theories (SMT) solver
License: MIT
URL: https://github.com/Z3Prover/z3
Source0: https://github.com/Z3Prover/z3/archive/%{name}-%{version}.tar.gz
# Do not try to build with SSE2 on non-x86_64 arches
Patch0: %{name}-sse2.patch
BuildRequires: doxygen
BuildRequires: gcc-c++
@ -22,9 +20,9 @@ BuildRequires: ocaml-findlib
BuildRequires: ocaml-ocamldoc
BuildRequires: ocaml-num-devel
BuildRequires: python2-devel
BuildRequires: python2-setuptools
BuildRequires: python2dist(setuptools)
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3dist(setuptools)
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
@ -97,7 +95,6 @@ Python 3 interface to z3.
%prep
%setup -q -n %{name}-%{name}-%{version}
%patch0
# Install python objects into the right place, enable verbose builds, use
# Fedora CFLAGS, preserve timestamps when installing, include the entire
@ -117,8 +114,8 @@ sed -e "s|^\(PYTHON_PACKAGE_DIR=\).*|\1'%{python2_sitearch}'|" \
-e "s/OCAML_FLAGS = ''/OCAML_FLAGS = '-g'/" \
-i scripts/mk_util.py
# Do not try to build with SSE2 support on non-x86_64 arches.
%ifnarch x86_64
# Do not try to build with SSE2 support on non-x86 arches.
%ifnarch %{ix86} x86_64
sed -i 's/exec_compiler_cmd.*-msse.*:/None:/' scripts/mk_util.py
%endif
@ -259,6 +256,9 @@ mv %{buildroot}%{_prefix}/lib/lib%{name}java.so %{buildroot}%{_libdir}/%{name}
%{python3_sitearch}/%{name}/
%changelog
* Fri Sep 7 2018 Jerry James <loganjerry@gmail.com> - 4.7.1-5
- Build with SSE2 support on 32-bit x86
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.7.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild