New upstream version (bz 1581516). Drop upstreamed -vector patch.

This commit is contained in:
Jerry James 2018-05-22 21:32:35 -06:00
parent 801e577186
commit 43e43e0b63
4 changed files with 9 additions and 23 deletions

3
.gitignore vendored
View File

@ -1,2 +1 @@
/z3-4.5.0.tar.gz
/z3-4.6.0.tar.gz
/z3-*.tar.gz

View File

@ -1 +1 @@
SHA512 (z3-4.6.0.tar.gz) = 92a87292db17ceb4a90e45bce4f6237fe0437a7a5e147b4b63a2cb793e2d59fc04a6aa579ddb904280eac08b4a85c600df092d4c2fa99239199514b9c0363243
SHA512 (z3-4.7.1.tar.gz) = 4c8c856691134298c4b5e465d6fadfe446532dfcd8c92aed7c9a6bbfc8557074a45cd7316dbfa5045824e2504db159afeb8ff676d4bfc942496623cf31d11aa0

View File

@ -1,11 +0,0 @@
--- src/util/lp/permutation_matrix.h.orig 2017-12-18 07:18:30.000000000 -0700
+++ src/util/lp/permutation_matrix.h 2018-02-13 20:45:39.712845059 -0700
@@ -132,7 +132,7 @@ class permutation_matrix : public tail_m
unsigned size() const { return static_cast<unsigned>(m_rev.size()); }
- unsigned * values() const { return m_permutation; }
+ unsigned * values() const { return m_permutation.c_ptr(); }
void resize(unsigned size) {
unsigned old_size = m_permutation.size();

16
z3.spec
View File

@ -1,8 +1,8 @@
%global medtag b0aaa4c6d7a7
%global medtag 3b1b82bef05a
Name: z3
Version: 4.6.0
Release: 2%{?dist}
Version: 4.7.1
Release: 1%{?dist}
Summary: Satisfiability Modulo Theories (SMT) solver
License: MIT
@ -10,8 +10,6 @@ URL: https://github.com/Z3Prover/z3
Source0: https://github.com/Z3Prover/z3/archive/%{name}-%{version}.tar.gz
# Do not try to build with SSE2 on non-x86_64 arches
Patch0: %{name}-sse2.patch
# Fix a vector access
Patch1: %{name}-vector.patch
BuildRequires: doxygen
BuildRequires: gcc-c++
@ -100,7 +98,6 @@ Python 3 interface to z3.
%prep
%setup -q -n %{name}-%{name}-%{version}
%patch0
%patch1
# Install python objects into the right place, enable verbose builds, use
# Fedora CFLAGS, preserve timestamps when installing, include the entire
@ -138,9 +135,6 @@ mv -f RELEASE_NOTES.utf8 RELEASE_NOTES
find -O3 src -type f -perm /0111 \( -name \*.cpp -o -name \*.h \) \
-exec chmod 0644 {} +
# Fix ocaml documentation generation (broken in 4.4.0)
sed -i 's,z3enums\.mli,z3enums.ml,' doc/mk_api_doc.py
%build
export CXXFLAGS="$RPM_OPT_FLAGS -fPIC"
export LDFLAGS="$RPM_LD_FLAGS -Wl,--as-needed -lgmp"
@ -265,6 +259,10 @@ mv %{buildroot}%{_prefix}/lib/lib%{name}java.so %{buildroot}%{_libdir}/%{name}
%{python3_sitearch}/%{name}/
%changelog
* Tue May 22 2018 Jerry James <loganjerry@gmail.com> - 4.7.1-1
- New upstream version (bz 1581516)
- Drop upstreamed -vector patch
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild