Mon Aug 27 2001 Florian La Roche <Florian.LaRoche@redhat.de> - set domainname if it is not yet set #52514
263 lines
7.4 KiB
RPMSpec
263 lines
7.4 KiB
RPMSpec
%define initdir /etc/rc.d/init.d
|
|
|
|
Summary: The NIS (Network Information Service) server.
|
|
Url: http://www.suse.de/~kukuk
|
|
Name: ypserv
|
|
Version: 1.3.12
|
|
Release: 2
|
|
Copyright: GNU
|
|
Group: System Environment/Daemons
|
|
Source0: ftp://ftp.kernel.org/pub/linux/utils/net/NIS/ypserv-%{version}.tar.gz
|
|
Source1: ypserv-ypserv.init
|
|
Source2: ypserv-yppasswdd.init
|
|
Source3: ypserv-ypxfrd.init
|
|
Requires: make, portmap, bash >= 2.0
|
|
Prereq: /sbin/chkconfig /sbin/service
|
|
Patch0: ypserv-1.3.11-redhat.patch
|
|
Patch1: ypserv-1.3.9-ndbmkey.patch
|
|
Patch3: ypserv-syslog.patch
|
|
Obsoletes: yppasswd
|
|
BuildRequires: gdbm-devel
|
|
Buildroot: %{_tmppath}/%{name}-root
|
|
|
|
%description
|
|
The Network Information Service (NIS) is a system that provides
|
|
network information (login names, passwords, home directories, group
|
|
information) to all of the machines on a network. NIS can allow users
|
|
to log in on any machine on the network, as long as the machine has
|
|
the NIS client programs running and the user's password is recorded in
|
|
the NIS passwd database. NIS was formerly known as Sun Yellow Pages
|
|
(YP).
|
|
|
|
This package provides the NIS server, which will need to be running on
|
|
your network. NIS clients do not need to be running the server.
|
|
|
|
Install ypserv if you need an NIS server for your network. You also
|
|
need to install the yp-tools and ypbind packages on any NIS client
|
|
machines.
|
|
|
|
%prep
|
|
%setup -q
|
|
%patch0 -p1
|
|
%patch1 -p1
|
|
%patch3 -p1
|
|
|
|
%build
|
|
cp etc/README etc/README.etc
|
|
%configure --enable-checkroot --enable-fqdn --enable-yppasswd --libexecdir=%{_libdir}/yp
|
|
make
|
|
|
|
%install
|
|
rm -rf $RPM_BUILD_ROOT
|
|
|
|
make install ROOT=$RPM_BUILD_ROOT
|
|
mkdir -p $RPM_BUILD_ROOT%{initdir}
|
|
install -m644 etc/ypserv.conf $RPM_BUILD_ROOT%{_sysconfdir}
|
|
install -m755 $RPM_SOURCE_DIR/ypserv-ypserv.init $RPM_BUILD_ROOT%{initdir}/ypserv
|
|
install -m755 $RPM_SOURCE_DIR/ypserv-yppasswdd.init $RPM_BUILD_ROOT%{initdir}/yppasswdd
|
|
install -m755 $RPM_SOURCE_DIR/ypserv-ypxfrd.init $RPM_BUILD_ROOT%{initdir}/ypxfrd
|
|
|
|
%clean
|
|
rm -rf $RPM_BUILD_ROOT
|
|
|
|
%post
|
|
/sbin/chkconfig --add ypserv
|
|
/sbin/chkconfig --add yppasswdd
|
|
/sbin/chkconfig --add ypxfrd
|
|
|
|
%triggerpostun -- ypserv <= ypserv-1.3.0-2
|
|
/sbin/chkconfig --add ypserv
|
|
|
|
%triggerpostun -- yppasswd
|
|
/sbin/chkconfig --add yppasswdd
|
|
|
|
%preun
|
|
if [ $1 = 0 ]; then
|
|
/sbin/service ypserv stop > /dev/null 2>&1
|
|
/sbin/chkconfig --del ypserv
|
|
/sbin/service yppasswdd stop > /dev/null 2>&1
|
|
/sbin/chkconfig --del yppasswdd
|
|
/sbin/service ypxfrd stop > /dev/null 2>&1
|
|
/sbin/chkconfig --del ypxfrd
|
|
fi
|
|
|
|
%postun
|
|
if [ "$1" -ge "1" ]; then
|
|
/sbin/service ypserv condrestart > /dev/null 2>&1
|
|
/sbin/service yppasswdd condrestart > /dev/null 2>&1
|
|
/sbin/service ypxfrd condrestart > /dev/null 2>&1
|
|
fi
|
|
exit 0
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%doc README README.secure INSTALL ChangeLog TODO BUGS NEWS
|
|
%doc etc/ypserv.conf etc/securenets etc/README.etc
|
|
%config %{_sysconfdir}/ypserv.conf
|
|
%config /var/yp/*
|
|
%dir /var/yp
|
|
%config %{initdir}/*
|
|
%{_libdir}/yp
|
|
%{_sbindir}/*
|
|
%{_mandir}/*/*
|
|
%{_includedir}/*/*
|
|
|
|
%changelog
|
|
* Mon Aug 27 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
|
- set domainname if it is not yet set #52514
|
|
|
|
* Tue Jul 24 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
|
- add gdbm-devel BuildReq #49767
|
|
- add ypxfrd init script #44845
|
|
- fix #44805
|
|
- fix #20042, adding option to yppasswdd startup
|
|
- own /var/yp
|
|
|
|
* Mon Jul 9 2001 Tim Powers <timp@redhat.com>
|
|
- added reload entry to initscript (same as restart)
|
|
|
|
* Fri Jun 29 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
|
- update to 1.3.12
|
|
|
|
* Wed Mar 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
|
- do not require tcp_wrappers anymore
|
|
|
|
* Thu Mar 15 2001 Philipp Knirsch <pknirsch@redhat.com>
|
|
- Added missing make requirement
|
|
|
|
* Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
|
|
- don't own dir /var/yp
|
|
|
|
* Wed Jan 24 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
|
- prepare for startup script translation
|
|
|
|
* Thu Jan 11 2001 Bernhard Rosenkraenzer <bero@redhat.com>
|
|
- Start after netfs (#23527)
|
|
|
|
* Wed Aug 16 2000 Than Ngo <than@redhat.com>
|
|
- fix typo in startup script (Bug #15999)
|
|
|
|
* Wed Jul 19 2000 Than Ngo <than@redhat.de>
|
|
- inits back to rc.d/init.d, using service
|
|
- fix initscript again
|
|
|
|
* Mon Jul 17 2000 Bill Nottingham <notting@redhat.com>
|
|
- move initscript back
|
|
- fix format syslog bug
|
|
|
|
* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
|
|
- automatic rebuild
|
|
|
|
* Fri Jul 7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
|
|
- prereq /etc/init.d
|
|
|
|
* Tue Jun 27 2000 Than Ngo <than@redhat.de>
|
|
- /etc/rc.d/init.d -> /etc/init.d
|
|
- fix initscript
|
|
|
|
* Sun Jun 18 2000 Than Ngo <than@redhat.de>
|
|
- FHS fixes,
|
|
- fix docdir
|
|
|
|
* Fri May 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
|
|
- disable "netgrp" target in default all: (/var/yp/Makefile)
|
|
|
|
* Thu May 18 2000 Florian La Roche <Florian.LaRoche@redhat.com>
|
|
- update to 1.3.11
|
|
|
|
* Mon Mar 06 2000 Cristian Gafton <gafton@redhat.com>
|
|
- add patch to avoid potential deadlock on the server (fix #9968)
|
|
|
|
* Wed Feb 2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
|
|
- fix typo in %triggerpostun
|
|
|
|
* Mon Oct 25 1999 Bill Nottingham <notting@redhat.com>
|
|
- update to 1.3.9
|
|
- use gdbm, move back to /usr/sbin
|
|
|
|
* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
|
|
- initscript munging
|
|
- ypserv goes on root partition
|
|
|
|
* Fri Aug 13 1999 Cristian Gafton <gafton@redhat.com>
|
|
- version 1.3.7
|
|
|
|
* Thu Jul 1 1999 Bill Nottingham <notting@redhat.com>
|
|
- start after network FS
|
|
|
|
* Tue Jun 1 1999 Jeff Johnson <jbj@redhat.com>
|
|
- update to 1.3.6.94.
|
|
|
|
* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
|
|
- improved daemonization.
|
|
|
|
* Sat May 29 1999 Jeff Johnson <jbj@redhat.com>
|
|
- fix buffer overflow in rpc.yppasswd (#3126).
|
|
|
|
* Fri May 28 1999 Jeff Johnson <jbj@redhat.com>
|
|
- update to 1.3.6.92.
|
|
|
|
* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
|
|
- version 1.3.6.91
|
|
|
|
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
|
- auto rebuild in the new build environment (release 4)
|
|
|
|
* Mon Feb 8 1999 Bill Nottingham <notting@redhat.com>
|
|
- move to start before ypbind
|
|
|
|
* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
|
|
- build for glibc 2.1
|
|
- upgraded to 1.3.5
|
|
|
|
* Tue Aug 4 1998 Jeff Johnson <jbj@redhat.com>
|
|
- yppasswd.init: lock file must have same name as init.d script, not daemon
|
|
|
|
* Sat Jul 11 1998 Cristian Gafton <gafton@redhat.com>
|
|
- upgraded to 1.3.4
|
|
- fixed the fubared Makefile
|
|
- link against gdbm instead of ndbm (it seems to work better)
|
|
|
|
* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
|
|
- upgraded to 1.3.1
|
|
- enhanced init scripts
|
|
|
|
* Fri May 01 1998 Jeff Johnson <jbj@redhat.com>
|
|
- added triggerpostun
|
|
- Use libdb fro dbp_*().
|
|
|
|
* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
|
|
- translations modified for de, fr, tr
|
|
|
|
* Mon Apr 13 1998 Cristian Gafton <gafton@redhat.com>
|
|
- updated to 1.3.0
|
|
|
|
* Wed Dec 03 1997 Cristian Gafton <gafton@redhat.com>
|
|
- updated to 1.2.5
|
|
- added buildroot; updated spec file
|
|
- added yppasswdd init file
|
|
|
|
* Tue Nov 04 1997 Erik Troan <ewt@redhat.com>
|
|
- init script shouldn't set the domain name
|
|
|
|
* Tue Oct 14 1997 Erik Troan <ewt@redhat.com>
|
|
- supports chkconfig
|
|
- updated initscript for status and restart
|
|
- turned off in all runlevels, by default
|
|
- removed postinstall script which didn't do anything
|
|
|
|
* Thu Oct 09 1997 Erik Troan <ewt@redhat.com>
|
|
- added patch to build against later glibc
|
|
|
|
* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
|
|
- built against glibc
|
|
|
|
* Wed Apr 23 1997 Erik Troan <ewt@redhat.com>
|
|
- updated to 1.1.7.
|
|
|
|
* Fri Mar 14 1997 Erik Troan <ewt@redhat.com>
|
|
- Updated to ypserv 1.1.5, ported to Alpha (glibc).
|
|
|
|
* Fri Mar 07 1997 Erik Troan <ewt@redhat.com>
|
|
- Removed -pedantic which confuses the SPARC :-(
|