added the patches
This commit is contained in:
parent
6e17bd10db
commit
30b5fab8d9
21
ypserv-2.13-nonedomain.patch
Normal file
21
ypserv-2.13-nonedomain.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- ypserv-2.13/scripts/ypMakefile.in.nonedomain 2006-10-13 17:27:48.000000000 -0500
|
||||
+++ ypserv-2.13/scripts/ypMakefile.in 2006-10-13 17:36:22.000000000 -0500
|
||||
@@ -98,10 +98,18 @@ NETMASKS = $(YPSRCDIR)/netmasks
|
||||
YPSERVERS = $(YPDIR)/ypservers # List of all NIS servers for a domain
|
||||
|
||||
target: Makefile
|
||||
+ifeq ($(shell /bin/domainname), (none))
|
||||
+ @echo "Domain name cannot be (none)"
|
||||
+else
|
||||
+ ifeq ($(shell /bin/domainname), )
|
||||
+ @echo "Domain name must be set"
|
||||
+ else
|
||||
@test ! -d $(LOCALDOMAIN) && mkdir $(LOCALDOMAIN) ; \
|
||||
cd $(LOCALDOMAIN) ; \
|
||||
$(NOPUSH) || $(MAKE) -f ../Makefile ypservers; \
|
||||
$(MAKE) -f ../Makefile all
|
||||
+ endif
|
||||
+endif
|
||||
|
||||
# If you don't want some of these maps built, feel free to comment
|
||||
# them out from this list.
|
13
ypserv-2.19-quieter.patch
Normal file
13
ypserv-2.19-quieter.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- ypserv-2.19/lib/access.c.orig 2006-12-22 11:48:28.080930000 -0500
|
||||
+++ ypserv-2.19/lib/access.c 2006-12-22 11:49:35.560015000 -0500
|
||||
@@ -201,8 +201,8 @@ is_valid (struct svc_req *rqstp, const c
|
||||
}
|
||||
else
|
||||
{
|
||||
- if (status < 1 && ((sin->sin_addr.s_addr != oldaddr)
|
||||
- || (status != oldstatus)))
|
||||
+ if ((status < 1 && status != -4) &&
|
||||
+ ((sin->sin_addr.s_addr != oldaddr) || (status != oldstatus)))
|
||||
syslog (LOG_WARNING,
|
||||
"refused connect from %s:%d to procedure %s (%s,%s;%d)\n",
|
||||
inet_ntoa (sin->sin_addr), ntohs (sin->sin_port),
|
Loading…
Reference in New Issue
Block a user