Update to new version 1.37.1

This commit is contained in:
Honza Horák 2013-05-06 22:23:25 +02:00
parent 8dbed4e7a6
commit 777a854757
12 changed files with 14 additions and 430 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@ ypbind-mt-1.32.tar.bz2
/ypbind-mt-1.33.tar.bz2
/ypbind-mt-1.35.tar.bz2
/ypbind-mt-1.36.tar.bz2
/ypbind-mt-1.37.1.tar.bz2

View File

@ -1 +1 @@
135834db97d78ff6d79fdee2810b4056 ypbind-mt-1.36.tar.bz2
8af8d35e7b9a7fcc3a1576697a04bd82 ypbind-mt-1.37.1.tar.bz2

View File

@ -1,5 +1,6 @@
--- ypbind-mt-1.11/po/Makevars.fixit Tue Jun 11 07:19:05 2002
+++ ypbind-mt-1.11/po/Makevars Tue Jun 11 07:19:07 2002
diff -up ./po/Makevars.gettextdomain ./po/Makevars
--- ./po/Makevars.gettextdomain 2004-01-14 20:25:25.000000000 +0100
+++ ./po/Makevars 2013-05-06 19:07:24.961484803 +0200
@@ -1,7 +1,7 @@
# Makefile variables for PO directory in any package using GNU gettext.

View File

@ -1,12 +0,0 @@
diff -up ypbind-mt-1.32/src/serv_list.c.typo ypbind-mt-1.32/src/serv_list.c
--- ypbind-mt-1.32/src/serv_list.c.typo 2010-11-29 11:28:51.701891385 +0100
+++ ypbind-mt-1.32/src/serv_list.c 2010-11-29 11:30:29.682891306 +0100
@@ -830,7 +830,7 @@ ping_all (struct binding *list)
if (s_in.sin_port == 0)
{
if (verbose_flag && list->active == i)
- log_msg (LOG_NOTICE, "NIS server '%s' not repsonding "
+ log_msg (LOG_NOTICE, "NIS server '%s' not responding "
"for domain '%s'", list->server[i].host, list->domain);
if (debug_flag)

View File

@ -1,42 +0,0 @@
diff -up ypbind-mt-1.32/man/ypbind.8.typo2 ypbind-mt-1.32/man/ypbind.8
--- ypbind-mt-1.32/man/ypbind.8.typo2 2011-03-18 13:13:11.263707644 +0100
+++ ypbind-mt-1.32/man/ypbind.8 2011-03-18 13:16:59.170866034 +0100
@@ -313,7 +313,7 @@ versions\&.
\fBypbind\fR
will not check if the binding is alive\&. This option is for use with dialup connections to prevent
\fBypbind\fR
-from keeping the connection unnecessarily open or causing autodials\&.
+from keeping the connection unnecessarily open or causing auto-dials\&.
.RE
.PP
\fB\-f\fR configfile
@@ -335,7 +335,7 @@ will only bind to the loopback device an
.RS 4
The default value for
\fBypbind\fR
-to check, if a NIS server is still reacheable, is 20 seconds\&. With this options another frequency in seconds can be specified\&.
+to check, if a NIS server is still reachable, is 20 seconds\&. With this options another frequency in seconds can be specified\&.
.RE
.PP
\fB\-no\-dbus\fR
diff -up ypbind-mt-1.32/man/ypbind.8.xml.typo2 ypbind-mt-1.32/man/ypbind.8.xml
--- ypbind-mt-1.32/man/ypbind.8.xml.typo2 2011-03-18 13:18:01.643651666 +0100
+++ ypbind-mt-1.32/man/ypbind.8.xml 2011-03-18 13:19:03.137658398 +0100
@@ -234,7 +234,7 @@ versions.</para>
will not check if the binding is alive. This option is for use with
dialup connections to prevent
<command>ypbind</command>
-from keeping the connection unnecessarily open or causing autodials.</para>
+from keeping the connection unnecessarily open or causing auto-dials.</para>
</listitem>
</varlistentry>
<varlistentry>
@@ -260,7 +260,7 @@ a remote network.</para>
<listitem>
<para>The default value for
<command>ypbind</command>
-to check, if a NIS server is still reacheable, is 20 seconds.
+to check, if a NIS server is still reachable, is 20 seconds.
With this options another frequency in seconds can be specified.</para>
</listitem>
</varlistentry>

View File

@ -1,30 +0,0 @@
diff -up ypbind-mt-1.35/src/ypbind_dbus_nm.c.nmsignal ypbind-mt-1.35/src/ypbind_dbus_nm.c
--- ypbind-mt-1.35/src/ypbind_dbus_nm.c.nmsignal 2012-03-23 13:48:21.000000000 +0100
+++ ypbind-mt-1.35/src/ypbind_dbus_nm.c 2012-04-18 14:40:50.574569893 +0200
@@ -32,6 +32,9 @@
#include <dbus/dbus-glib-lowlevel.h>
#include <dbus/dbus-glib.h>
+/* We have our own constant, NM uses directly "StateChanged" string */
+#define NM_DBUS_SIGNAL_STATE_CHANGED "StateChanged"
+
#ifdef HAVE_NETWORKMANAGER_NETWORKMANAGER_H
#include <NetworkManager/NetworkManager.h>
#include <NetworkManager/NetworkManagerVPN.h>
@@ -39,7 +42,6 @@
#define NM_DBUS_INTERFACE "org.freedesktop.NetworkManager"
#define NM_DBUS_SERVICE "org.freedesktop.NetworkManager"
#define NM_DBUS_PATH "/org/freedesktop/NetworkManager"
-#define NM_DBUS_VPN_SIGNAL_STATE_CHANGE "StateChange"
typedef enum NMState {
NM_STATE_UNKNOWN = 0,
@@ -160,7 +162,7 @@ dbus_filter (DBusConnection *connection,
handled = DBUS_HANDLER_RESULT_HANDLED;
}
else if (dbus_message_is_signal (message, NM_DBUS_INTERFACE,
- NM_DBUS_VPN_SIGNAL_STATE_CHANGE))
+ NM_DBUS_SIGNAL_STATE_CHANGED))
{
NMState state = NM_STATE_UNKNOWN;

View File

@ -1,7 +1,7 @@
diff -up ypbind-mt-1.36/man/ypbind.8.nistimeout ypbind-mt-1.36/man/ypbind.8
--- ypbind-mt-1.36/man/ypbind.8.nistimeout 2012-08-23 13:55:01.296453226 +0200
+++ ypbind-mt-1.36/man/ypbind.8 2012-08-23 15:11:23.900115478 +0200
@@ -248,6 +248,31 @@ will behave as usual and assumes there i
diff -up ./man/ypbind.8.nistimeout ./man/ypbind.8
--- ./man/ypbind.8.nistimeout 2013-04-09 14:31:04.000000000 +0200
+++ ./man/ypbind.8 2013-05-06 19:11:20.509665809 +0200
@@ -104,6 +104,31 @@ will behave as usual and assumes there i
will reread all configuration files, registers at the local portmapper and try to search NIS servers\&. If NetworkManager drops a connection,
\fBypbind\fR
will unregister from portmapper\&.

View File

@ -1,114 +0,0 @@
diff -up ypbind-mt-1.35/src/local.h.nmlocal ypbind-mt-1.35/src/local.h
--- ypbind-mt-1.35/src/local.h.nmlocal 2009-03-30 14:24:40.000000000 +0200
+++ ypbind-mt-1.35/src/local.h 2012-06-11 19:31:42.297661066 +0200
@@ -7,6 +7,7 @@ extern int broken_server;
extern int port;
extern int ping_interval;
extern int use_broadcast;
+extern int localhost_used;
extern char *domain;
extern void find_domain (const char *domain, ypbind_resp *result);
diff -up ypbind-mt-1.35/src/serv_list.c.nmlocal ypbind-mt-1.35/src/serv_list.c
--- ypbind-mt-1.35/src/serv_list.c.nmlocal 2012-06-11 19:31:41.970660463 +0200
+++ ypbind-mt-1.35/src/serv_list.c 2012-06-11 19:39:15.177987490 +0200
@@ -108,6 +108,28 @@ static pthread_mutex_t search_lock = PTH
static void do_broadcast (struct binding *list);
static int ping_all (struct binding *list);
+/* We have localhost defined in one of the domains.
+ * If so, we don't need to be connected to outer network. */
+void
+check_localhost()
+{
+ int i, s;
+ localhost_used = 0;
+ for (i = 0; i < max_domains; ++i)
+ {
+ for (s = 0; s < _MAXSERVER; ++s)
+ {
+ if (domainlist[i].server[s].host == NULL)
+ break;
+ if (strncmp(inet_ntoa(domainlist[i].server[s].addr), "127", 3) == 0)
+ {
+ localhost_used = 1;
+ return;
+ }
+ }
+ }
+}
+
static void
remove_bindingfile (struct binding *entry)
{
@@ -220,6 +242,7 @@ update_bindingfile (struct binding *entr
}
else
log_msg (LOG_ERR, "open(%s): %s", path2, strerror (errno));
+ check_localhost();
}
/* this is called from the RPC thread (ypset). */
@@ -562,6 +585,7 @@ add_server (const char *domain, const ch
If there is none, use the first one. */
memcpy (&entry->server[active].addr, hent->h_addr_list[0],
hent->h_length);
+ check_localhost();
res = 1;
}
@@ -1105,7 +1129,7 @@ test_bindings (void *param __attribute__
int lastcheck = 0;
#ifdef USE_DBUS_NM
- if (is_online)
+ if (is_online || localhost_used)
#endif
do_binding ();
@@ -1125,7 +1149,7 @@ test_bindings (void *param __attribute__
lastcheck = 0;
#if USE_DBUS_NM
- if (is_online)
+ if (is_online || localhost_used)
#endif
lastcheck = test_bindings_once (lastcheck, NULL);
diff -up ypbind-mt-1.35/src/ypbind_dbus_nm.c.nmlocal ypbind-mt-1.35/src/ypbind_dbus_nm.c
--- ypbind-mt-1.35/src/ypbind_dbus_nm.c.nmlocal 2012-06-11 19:31:42.296661064 +0200
+++ ypbind-mt-1.35/src/ypbind_dbus_nm.c 2012-06-11 19:31:42.300661070 +0200
@@ -92,8 +92,11 @@ go_offline (void)
if (debug_flag)
log_msg (LOG_DEBUG, _("Switch to offline mode"));
is_online = 0;
- portmapper_disconnect ();
- clear_server ();
+ if (!localhost_used)
+ {
+ portmapper_disconnect ();
+ clear_server ();
+ }
}
static void
diff -up ypbind-mt-1.35/src/ypbind-mt.c.nmlocal ypbind-mt-1.35/src/ypbind-mt.c
--- ypbind-mt-1.35/src/ypbind-mt.c.nmlocal 2011-08-31 15:21:11.000000000 +0200
+++ ypbind-mt-1.35/src/ypbind-mt.c 2012-06-11 19:40:02.419996267 +0200
@@ -74,6 +74,7 @@ int broken_server = 0;
int foreground_flag = 0;
int ping_interval = 20;
int local_only = 0;
+int localhost_used = 1;
int port = -1;
static int lock_fd;
static int pid_is_written = 0;
@@ -945,7 +946,7 @@ main (int argc, char **argv)
}
#ifdef USE_DBUS_NM
- if (!is_online)
+ if (!is_online && !localhost_used)
portmapper_disconnect ();
#endif

View File

@ -1,121 +0,0 @@
diff -up ypbind-mt-1.36/man/ypbind.8.rebind ypbind-mt-1.36/man/ypbind.8
--- ypbind-mt-1.36/man/ypbind.8.rebind 2013-01-29 14:02:15.806838768 +0100
+++ ypbind-mt-1.36/man/ypbind.8 2013-01-29 14:02:15.810838767 +0100
@@ -171,7 +171,7 @@ ypbind \- NIS binding process
.SH "Synopsis"
.fam C
.HP \w'\fBypbind\fR\ 'u
-\fBypbind\fR [\-c] [\-d | \-debug] [\-verbose] [\-n | \-forground] [\-broadcast] [\-broken\-server] [\-ypset] [\-ypsetme] [\-no\-ping] [\-f\ \fIconfigfile\fR] [\-local\-only] [\-ping\-interval\ \fIping\-interval\fR] [\-no\-dbus]
+\fBypbind\fR [\-c] [\-d | \-debug] [\-verbose] [\-n | \-forground] [\-broadcast] [\-broken\-server] [\-ypset] [\-ypsetme] [\-no\-ping] [\-f\ \fIconfigfile\fR] [\-local\-only] [\-ping\-interval\ \fIping\-interval\fR] [\-rebind\-interval\fR] [\-no\-dbus]
.fam
.fam C
.HP \w'\fBypbind\fR\ 'u
@@ -370,6 +370,13 @@ The default value for
to check, if a NIS server is still reachable, is 20 seconds\&. With this options another frequency in seconds can be specified\&.
.RE
.PP
+\fB\-rebind\-interval\fR
+.RS 4
+The default value for
+\fBypbind\fR
+to search for the fastest NIS server is 900 seconds (15 minutes)\&. With this options another frequency in seconds can be specified\&.
+.RE
+.PP
\fB\-no\-dbus\fR
.RS 4
Disables DBUS support if compiled in\&.
diff -up ypbind-mt-1.36/man/ypbind.8.xml.rebind ypbind-mt-1.36/man/ypbind.8.xml
--- ypbind-mt-1.36/man/ypbind.8.xml.rebind 2013-01-29 14:02:15.802838768 +0100
+++ ypbind-mt-1.36/man/ypbind.8.xml 2013-01-29 14:02:15.810838767 +0100
@@ -51,6 +51,7 @@
<arg choice='opt'>-f <replaceable>configfile</replaceable></arg>
<arg choice='opt'>-local-only </arg>
<arg choice='opt'>-ping-interval <replaceable>ping-interval</replaceable></arg>
+ <arg choice='opt'>-rebind-interval</arg>
<arg choice='opt'>-no-dbus </arg>
</cmdsynopsis>
<cmdsynopsis>
@@ -273,6 +274,15 @@ to check, if a NIS server is still reach
With this options another frequency in seconds can be specified.</para>
</listitem>
</varlistentry>
+ <varlistentry>
+ <term><option>-rebind-interval</option></term>
+ <listitem>
+<para>The default value for
+<command>ypbind</command>
+to search for the fastest NIS server is 900 seconds (15 minutes).
+With this options another frequency in seconds can be specified.</para>
+ </listitem>
+ </varlistentry>
<varlistentry>
<term><option>-no-dbus</option></term>
<listitem>
diff -up ypbind-mt-1.36/src/local.h.rebind ypbind-mt-1.36/src/local.h
--- ypbind-mt-1.36/src/local.h.rebind 2012-07-11 14:02:46.000000000 +0200
+++ ypbind-mt-1.36/src/local.h 2013-01-29 14:02:15.810838767 +0100
@@ -9,6 +9,7 @@ extern int ping_interval;
extern int use_broadcast;
extern int localhost_used;
extern char *domain;
+extern int rebind_interval;
extern void find_domain (const char *domain, ypbind_resp *result);
extern void clear_server (void);
diff -up ypbind-mt-1.36/src/serv_list.c.rebind ypbind-mt-1.36/src/serv_list.c
--- ypbind-mt-1.36/src/serv_list.c.rebind 2013-01-29 14:02:15.799838768 +0100
+++ ypbind-mt-1.36/src/serv_list.c 2013-01-29 14:02:15.810838767 +0100
@@ -1145,7 +1145,7 @@ test_bindings (void *param __attribute__
pthread_exit (&success);
lastcheck += ping_interval;
- if (lastcheck >= 900) /* 900 = 15min. */
+ if (lastcheck >= rebind_interval) /* default 900 = 15min. */
lastcheck = 0;
#if USE_DBUS_NM
diff -up ypbind-mt-1.36/src/ypbind-mt.c.rebind ypbind-mt-1.36/src/ypbind-mt.c
--- ypbind-mt-1.36/src/ypbind-mt.c.rebind 2013-01-29 14:02:15.808838768 +0100
+++ ypbind-mt-1.36/src/ypbind-mt.c 2013-01-29 14:02:15.811838767 +0100
@@ -79,6 +79,7 @@ int ping_interval = 20;
int local_only = 0;
int localhost_used = 1;
int port = -1;
+int rebind_interval = 900; /* 900 = 15min. */
static int lock_fd;
static int pid_is_written = 0;
static pthread_mutex_t mutex_pid = PTHREAD_MUTEX_INITIALIZER;
@@ -512,7 +513,7 @@ usage (int ret)
output = stdout;
fputs (_("Usage:\n"), output);
- fputs (_("\typbind [-broadcast | -ypset | -ypsetme] [-f configfile]\n\t [-no-ping] [-broken-server] [-local-only] [-i ping-interval] [-debug]\n\t [-verbose] [-n | -foreground]\n"), output);
+ fputs (_("\typbind [-broadcast | -ypset | -ypsetme] [-f configfile]\n\t [-no-ping] [-broken-server] [-local-only] [-i ping-interval]\n\t [-r rebind-interval] [-debug] [-verbose] [-n | -foreground]\n"), output);
#ifdef USE_DBUS_NM
fputs (_("\t [-no-dbus]\n"), output);
#endif
@@ -750,6 +751,16 @@ main (int argc, char **argv)
else if (strcmp ("-no-dbus", argv[i]) == 0)
disable_dbus = 1;
#endif
+ else if (strcmp ("-rebind-interval", argv[i]) == 0 ||
+ strcmp ("-r", argv[i]) == 0)
+ {
+ if (i+1 == argc || argv[i+1][0] == '-')
+ usage (1);
+ ++i;
+ rebind_interval = atoi (argv[i]);
+ if (rebind_interval < 1)
+ usage (1);
+ }
else if (strcmp ("--help", argv[i]) == 0)
usage (0);
else
@@ -841,6 +852,7 @@ main (int argc, char **argv)
{
log_msg (LOG_DEBUG, "[Welcome to ypbind-mt, version %s]\n", VERSION);
log_msg (LOG_DEBUG, "ping interval is %d seconds\n", ping_interval);
+ log_msg (LOG_DEBUG, "rebind interval is %d seconds\n", rebind_interval);
}
else if (! foreground_flag)
{

View File

@ -1,81 +0,0 @@
diff -up ypbind-mt-1.36/configure.in.sdnotify ypbind-mt-1.36/configure.in
--- ypbind-mt-1.36/configure.in.sdnotify 2012-07-09 16:41:36.000000000 +0200
+++ ypbind-mt-1.36/configure.in 2012-07-12 13:28:25.221031367 +0200
@@ -103,6 +103,18 @@ JH_CHECK_XML_CATALOG([http://docbook.sou
[DocBook XSL Stylesheets], [], enable_man=no)
AM_CONDITIONAL(ENABLE_REGENERATE_MAN, test x$enable_man != xno)
+USE_SD_NOTIFY=0
+AC_SUBST(USE_SD_NOTIFY)
+AC_CHECK_LIB(systemd-daemon,sd_notify,LIBSYSTEMD_DAEMON="-lsystemd-daemon",
+ LIBSYSTEMD_DAEMON="")
+if test -n "$LIBSYSTEMD_DAEMON" ; then
+ AC_CHECK_HEADERS(systemd/sd-daemon.h)
+ if test "$ac_cv_header_systemd_sd_notify_h" = yes; then
+ USE_SD_NOTIFY=1
+ fi
+fi
+AC_SUBST(USE_SD_NOTIFY)
+AC_SUBST(LIBSYSTEMD_DAEMON)
dnl internationalization macros
AM_GNU_GETTEXT_VERSION
diff -up ypbind-mt-1.36/src/Makefile.am.sdnotify ypbind-mt-1.36/src/Makefile.am
--- ypbind-mt-1.36/src/Makefile.am.sdnotify 2009-06-15 16:30:45.000000000 +0200
+++ ypbind-mt-1.36/src/Makefile.am 2012-07-12 13:28:25.288029189 +0200
@@ -8,8 +8,9 @@ localedir = $(datadir)/locale
WARNFLAGS = @WARNFLAGS@
AM_CFLAGS = -D_REENTRANT=1 $(WARNFLAGS) -DUSE_BROADCAST=@USE_BROADCAST@ \
- -DLOCALEDIR=\"$(localedir)\" @DBUS_CFLAGS@ @GLIB_CFLAGS@
-ypbind_LDADD = ../lib/libcompat.a @LIBINTL@ @SLP_LIBS@ @DBUS_LIBS@ @GLIB_LIBS@
+ -DLOCALEDIR=\"$(localedir)\" @DBUS_CFLAGS@ @GLIB_CFLAGS@ -DUSE_SD_NOTIFY=@USE_SD_NOTIFY@
+ypbind_LDADD = ../lib/libcompat.a @LIBINTL@ @SLP_LIBS@ @DBUS_LIBS@ @GLIB_LIBS@ \
+ $(LIBSYSTEMD_DAEMON)
CLEANFILES = *~
diff -up ypbind-mt-1.36/src/ypbind-mt.c.sdnotify ypbind-mt-1.36/src/ypbind-mt.c
--- ypbind-mt-1.36/src/ypbind-mt.c.sdnotify 2012-07-11 14:02:46.000000000 +0200
+++ ypbind-mt-1.36/src/ypbind-mt.c 2012-07-12 13:57:52.479549892 +0200
@@ -49,6 +49,9 @@
#if defined(HAVE_NSS_H)
#include <nss.h>
#endif
+#if defined(HAVE_SYSTEMD_SD_DAEMON_H)
+#include <systemd/sd-daemon.h>
+#endif
#include "ypbind.h"
#include "log_msg.h"
@@ -952,6 +955,30 @@ main (int argc, char **argv)
pthread_create (&ping_thread, NULL, &test_bindings, NULL);
+#ifdef USE_SD_NOTIFY
+ {
+ /*
+ * If we use systemd as an init process we may want to give it
+ * a message, that ypbind daemon is ready to accept connections.
+ * At this time, sockets for receiving connections are already
+ * created, so we can say we're ready now.
+ */
+ int result;
+ result = sd_notifyf(0, "READY=1\n"
+ "STATUS=Processing requests...\n"
+ "MAINPID=%lu", (unsigned long) getpid());
+
+ /*
+ * Return code from sd_notifyf can be ignored, as per sd_notifyf(3).
+ * However, if we use systemd's native unit file, we need to send
+ * this message to let systemd know that daemon is ready.
+ * Thus, we want to know that the call had some issues.
+ */
+ if (result < 0)
+ log_msg ("sd_notifyf failed: %s\n", strerror(-result));
+ }
+#endif
+
svc_run ();
log_msg (LOG_ERR, _("svc_run returned."));
unlink (_YPBIND_PIDFILE);

View File

@ -1,11 +0,0 @@
diff -up ypbind-mt-1.36/src/ypbind-mt.c.sigpipe ypbind-mt-1.36/src/ypbind-mt.c
--- ypbind-mt-1.36/src/ypbind-mt.c.sigpipe 2012-07-23 10:02:12.275896834 +0200
+++ ypbind-mt-1.36/src/ypbind-mt.c 2012-07-23 10:02:47.430632798 +0200
@@ -432,6 +432,7 @@ sig_handler (void *v_param __attribute_
sigaddset (&sigs_to_catch, SIGQUIT);
sigaddset (&sigs_to_catch, SIGSEGV);
sigaddset (&sigs_to_catch, SIGHUP);
+ sigaddset (&sigs_to_catch, SIGPIPE);
while (1)
{

View File

@ -1,7 +1,7 @@
Summary: The NIS daemon which binds NIS clients to an NIS domain
Name: ypbind
Version: 1.36
Release: 10%{?dist}
Version: 1.37.1
Release: 1%{?dist}
License: GPLv2
Group: System Environment/Daemons
Source0: http://www.linux-nis.org/download/ypbind-mt/ypbind-mt-%{version}.tar.bz2
@ -15,12 +15,7 @@ Source5: ypbind-post-waitbind
# 'ypbind-mt' would allow us to drop it.
Patch1: ypbind-1.11-gettextdomain.patch
# Not sent to upstream.
Patch2: ypbind-mt-1.32-typo.patch
Patch3: ypbind-mt-1.32-typo2.patch
Patch4: ypbind-sigpipe.patch
Patch5: ypbind-mt-1.36-nistimeout.patch
Patch6: ypbind-sdnotify.patch
Patch7: ypbind-rebind.patch
# This is for /bin/systemctl
Requires(post): systemd-units
Requires(preun): systemd-units
@ -53,12 +48,7 @@ also need to install the ypserv package to a machine on your network.
%prep
%setup -q -n ypbind-mt-%{version}
%patch1 -p1 -b .gettextdomain
%patch2 -p1 -b .typo
%patch3 -p1 -b .typo2
%patch4 -p1 -b .sigpipe
%patch5 -p1 -b .nistimeout
%patch6 -p1 -b .sdnotify
%patch7 -p1 -b .rebind
autoreconf
@ -141,6 +131,9 @@ install -m 755 %{SOURCE5} $RPM_BUILD_ROOT%{_libexecdir}/ypbind-post-waitbind
%doc README NEWS COPYING
%changelog
* Mon May 06 2013 Honza Horak <hhorak@redhat.com> - 3:1.37.1-1
- Update to new version 1.37.1
* Tue Jan 29 2013 Honza Horak <hhorak@redhat.com> - 3:1.36-10
- Make re-bind interval a tune-able option
- Fixed bogus dates in changelog