New upstream version 2.14

This commit is contained in:
Honza Horák 2013-05-06 22:43:43 +02:00
parent 029be6a36f
commit 0ce13aa758
7 changed files with 10 additions and 69 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
yp-tools-2.11.tar.bz2
/yp-tools-2.12.tar.bz2
/yp-tools-2.14.tar.bz2

View File

@ -1 +1 @@
ce1e06d86caa285fa8cd76fdf103f51e yp-tools-2.12.tar.bz2
ba1f121c17e3ad65368be173b977cd13 yp-tools-2.14.tar.bz2

View File

@ -1,6 +1,6 @@
diff -up yp-tools-2.11/src/yppasswd.c.shadow yp-tools-2.11/src/yppasswd.c
--- yp-tools-2.11/src/yppasswd.c.shadow 2010-04-20 15:31:59.000000000 +0200
+++ yp-tools-2.11/src/yppasswd.c 2010-11-19 18:37:14.931766315 +0100
diff -up ./src/yppasswd.c.shadow ./src/yppasswd.c
--- ./src/yppasswd.c.shadow 2010-04-21 11:24:15.000000000 +0200
+++ ./src/yppasswd.c 2013-05-06 22:31:39.984229577 +0200
@@ -449,6 +449,7 @@ verifypassword (struct passwd *pwd, char
passwdlen = get_passwd_len (pwd->pw_passwd);

View File

@ -1,33 +0,0 @@
diff -up yp-tools-2.12/src/yppoll.c.gethost yp-tools-2.12/src/yppoll.c
--- yp-tools-2.12/src/yppoll.c.gethost 2001-12-08 20:59:10.000000000 +0100
+++ yp-tools-2.12/src/yppoll.c 2011-05-04 16:18:08.371772310 +0200
@@ -218,7 +218,10 @@ main (int argc, char **argv)
hent = gethostbyaddr ((char *)&clnt_saddr.sin_addr.s_addr,
sizeof (clnt_saddr.sin_addr.s_addr), AF_INET);
- hostname = strdup (hent->h_name);
+ if (hent)
+ {
+ hostname = strdup (hent->h_name);
+ }
}
else
{
@@ -261,7 +264,7 @@ main (int argc, char **argv)
&clnt_sock);
if (client == NULL)
{
- fprintf (stderr, _("Can't create connection to %s.\n"), hostname);
+ fprintf (stderr, _("Can't create connection to %s.\n"), hostname ? hostname : "unknown");
return 1;
}
@@ -279,7 +282,7 @@ main (int argc, char **argv)
if (clnt_res != TRUE)
{
fprintf (stdout, _("Domain %s is not supported by %s.\n"), domainname,
- hostname);
+ hostname ? hostname : "unknown");
return 1;
}

View File

@ -1,12 +0,0 @@
diff -up yp-tools-2.12/man/ypmatch.1.in.typo yp-tools-2.12/man/ypmatch.1.in
--- yp-tools-2.12/man/ypmatch.1.in.typo 2011-03-18 13:43:29.462662847 +0100
+++ yp-tools-2.12/man/ypmatch.1.in 2011-03-18 13:44:26.498770766 +0100
@@ -5,7 +5,7 @@
.\"
.\" This program is free software; you can redistribute it and/or modify
.\" it under the terms of the GNU General Public License version 2 as
-.\" published bythe Free Software Foundation.
+.\" published by the Free Software Foundation.
.\"
.\" This program is distributed in the hope that it will be useful,
.\" but WITHOUT ANY WARRANTY; without even the implied warranty of

View File

@ -1,12 +0,0 @@
diff -up yp-tools-2.12/configure.in.aarch2 yp-tools-2.12/configure.in
--- yp-tools-2.12/configure.in.aarch2 2010-04-21 11:57:29.000000000 +0200
+++ yp-tools-2.12/configure.in 2013-03-25 16:56:59.131501212 +0100
@@ -108,7 +108,7 @@ else
fi
dnl internationalization macros
-AM_GNU_GETTEXT_VERSION
+AM_GNU_GETTEXT_VERSION(0.18)
AM_GNU_GETTEXT([external])
AC_OUTPUT([Makefile lib/Makefile src/Makefile man/Makefile

View File

@ -1,18 +1,15 @@
Summary: NIS (or YP) client programs
Name: yp-tools
Version: 2.12
Release: 13%{?dist}
Version: 2.14
Release: 1%{?dist}
License: GPLv2
Group: System Environment/Base
Source: http://www.linux-nis.org/download/yp-tools/yp-tools-%{version}.tar.bz2
# Not sent to upstream
Patch0: yp-tools-2.11-shadow.patch
Patch1: yp-tools-2.12-typo.patch
Patch2: yp-tools-2.12-gethost.patch
Patch3: yp-tools-2.12-hash.patch
Patch4: yp-tools-2.12-crypt.patch
Patch5: yp-tools-2.12-adjunct.patch
Patch6: yp-tools-gettext.patch
Url: http://www.linux-nis.org/nis/yp-tools/index.html
BuildRequires: autoconf, automake, gettext-devel
Requires: ypbind
@ -40,12 +37,9 @@ you'll need to install the ypserv package on one machine on the network.
%prep
%setup -q
%patch0 -p1 -b .shadow
%patch1 -p1 -b .typo
%patch2 -p1 -b .gethost
%patch3 -p1 -b .hash
%patch4 -p1 -b .crypt
%patch5 -p1 -b .adjunct
%patch6 -p1 -b .gettext
autoreconf -i -f
%build
@ -66,6 +60,9 @@ make DESTDIR="$RPM_BUILD_ROOT" INSTALL_PROGRAM=install install
/var/yp/nicknames
%changelog
* Mon May 06 2013 Honza Horak <hhorak@redhat.com> - 2.14-1
- New upstream version 2.14
* Mon Mar 25 2013 Honza Horak <hhorak@redhat.com> - 2.12-13
- Fix build for aarch64