yast2-devtools/yast2-devtools-3.1.31_replace_obsolete_AC_PROG_LIBTOOL.patch
Björn Esser a07281e395 fix AutoTools: Obsoleted m4s found: AC_PROG_LIBTOOL (#1220036)
add Patch0: use new `AC_INIT()`-syntax with args in square braces
add Patch1: replace obsolete `A[CM]_PROG_LIBTOOL` with `LT_INIT()`
2015-05-09 13:51:57 +02:00

60 lines
1.8 KiB
Diff

From 015df9c12f30caccaa46286c06e11999d7216ab8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <bjoern.esser@gmail.com>
Date: Sat, 9 May 2015 13:14:55 +0200
Subject: [PATCH] replace obsolete `A[CM]_PROG_LIBTOOL` with `LT_INIT()`
---
build-tools/Makefile.am.toplevel | 5 +++++
build-tools/scripts/y2autoconf | 6 +++---
configure.in.in | 3 ++-
3 files changed, 10 insertions(+), 4 deletions(-)
diff --git a/build-tools/Makefile.am.toplevel b/build-tools/Makefile.am.toplevel
index be3b526..4afc869 100644
--- a/build-tools/Makefile.am.toplevel
+++ b/build-tools/Makefile.am.toplevel
@@ -72,6 +72,11 @@ endif
EXTRA_DIST += $(RPMNAME).pc.in
endif
+LIBTOOL_DEPS = @LIBTOOL_DEPS@
+
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status libtool
+
pot:
$(Y2TOOL) y2makepot -s $(srcdir)
diff --git a/build-tools/scripts/y2autoconf b/build-tools/scripts/y2autoconf
index 944c2b3..14c2459 100755
--- a/build-tools/scripts/y2autoconf
+++ b/build-tools/scripts/y2autoconf
@@ -281,9 +281,9 @@ CXXFLAGS="${CXXFLAGS} ${Y2CORE_CFLAGS} -Wall -Wformat=2"
: ${AGENT_LIBADD:=\'-L$(libdir) -lscr -ly2util -lycpvalues\'}
AC_SUBST(AGENT_LIBADD)
-AC_DISABLE_STATIC
-AC_PROG_LIBTOOL
-AM_PROG_LIBTOOL dnl for libraries
+dnl for libraries
+LT_INIT([disable-static])
+AC_SUBST([LIBTOOL_DEPS])
dnl generate the config header
AC_CONFIG_HEADERS([config.h]) dnl at the distribution this done
diff --git a/configure.in.in b/configure.in.in
index 38e401b..8e6881b 100644
--- a/configure.in.in
+++ b/configure.in.in
@@ -18,8 +18,9 @@ CREATE_PKGCONFIG=noarch
# don't take all the garbage of YaST2-CHECKS-PROGRAM
# this is anyway necessary only because autoreconf
# gets confused by Makefile.am in skeletons
-AC_PROG_LIBTOOL
AC_PROG_CXX
+LT_INIT([disable-static])
+AC_SUBST([LIBTOOL_DEPS])
# perl checks
AC_CHECK_PROG(PERL, perl, perl, no)