new upstream release

add `-Wobsolete`-flag to autoreconf
remove Patch0 and Patch1, since they are merged into upstream
use conditional and more elaborate test-invocation
This commit is contained in:
Björn Esser 2015-05-11 14:26:15 +02:00
parent a07281e395
commit 0d248db0ab
4 changed files with 14 additions and 94 deletions

View File

@ -1 +1 @@
cf7d450c28b776d5fbda66e793419edd yast2-devtools-3.1.31.tar.gz
a624f6ac900a7470a06e1f3de54fdd36 yast2-devtools-3.1.32.tar.gz

View File

@ -1,59 +0,0 @@
From 015df9c12f30caccaa46286c06e11999d7216ab8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <bjoern.esser@gmail.com>
Date: Sat, 9 May 2015 13:14:55 +0200
Subject: [PATCH] replace obsolete `A[CM]_PROG_LIBTOOL` with `LT_INIT()`
---
build-tools/Makefile.am.toplevel | 5 +++++
build-tools/scripts/y2autoconf | 6 +++---
configure.in.in | 3 ++-
3 files changed, 10 insertions(+), 4 deletions(-)
diff --git a/build-tools/Makefile.am.toplevel b/build-tools/Makefile.am.toplevel
index be3b526..4afc869 100644
--- a/build-tools/Makefile.am.toplevel
+++ b/build-tools/Makefile.am.toplevel
@@ -72,6 +72,11 @@ endif
EXTRA_DIST += $(RPMNAME).pc.in
endif
+LIBTOOL_DEPS = @LIBTOOL_DEPS@
+
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status libtool
+
pot:
$(Y2TOOL) y2makepot -s $(srcdir)
diff --git a/build-tools/scripts/y2autoconf b/build-tools/scripts/y2autoconf
index 944c2b3..14c2459 100755
--- a/build-tools/scripts/y2autoconf
+++ b/build-tools/scripts/y2autoconf
@@ -281,9 +281,9 @@ CXXFLAGS="${CXXFLAGS} ${Y2CORE_CFLAGS} -Wall -Wformat=2"
: ${AGENT_LIBADD:=\'-L$(libdir) -lscr -ly2util -lycpvalues\'}
AC_SUBST(AGENT_LIBADD)
-AC_DISABLE_STATIC
-AC_PROG_LIBTOOL
-AM_PROG_LIBTOOL dnl for libraries
+dnl for libraries
+LT_INIT([disable-static])
+AC_SUBST([LIBTOOL_DEPS])
dnl generate the config header
AC_CONFIG_HEADERS([config.h]) dnl at the distribution this done
diff --git a/configure.in.in b/configure.in.in
index 38e401b..8e6881b 100644
--- a/configure.in.in
+++ b/configure.in.in
@@ -18,8 +18,9 @@ CREATE_PKGCONFIG=noarch
# don't take all the garbage of YaST2-CHECKS-PROGRAM
# this is anyway necessary only because autoreconf
# gets confused by Makefile.am in skeletons
-AC_PROG_LIBTOOL
AC_PROG_CXX
+LT_INIT([disable-static])
+AC_SUBST([LIBTOOL_DEPS])
# perl checks
AC_CHECK_PROG(PERL, perl, perl, no)

View File

@ -1,22 +0,0 @@
From 55faf823b8802c7c3db05d1e3d13a4e1ae8ecc0f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <bjoern.esser@gmail.com>
Date: Sat, 9 May 2015 13:11:57 +0200
Subject: [PATCH] use new `AC_INIT()`-syntax with args in square braces
---
build-tools/scripts/y2autoconf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/build-tools/scripts/y2autoconf b/build-tools/scripts/y2autoconf
index 4218d4c..944c2b3 100755
--- a/build-tools/scripts/y2autoconf
+++ b/build-tools/scripts/y2autoconf
@@ -87,7 +87,7 @@ $OUTPUT = join ("\n", map { "$_/Makefile" } @SUBDIRS);
# init: common stuff
'@YAST2-INIT-COMMON@' =>
-"AC_INIT($RPMNAME, $VERSION, http://bugs.opensuse.org/, $RPMNAME)
+"AC_INIT([$RPMNAME],[$VERSION],[http://bugs.opensuse.org/],[$RPMNAME])
dnl Check for presence of file 'RPMNAME'
AC_CONFIG_SRCDIR([RPMNAME])

View File

@ -36,8 +36,8 @@
%global src_url https://github.com/%{suite_name}/%{repo_name}
Name: %{suite_name}2-%{name_suffix}
Version: 3.1.31
Release: 2%{?gitrel}%{?dist}
Version: 3.1.32
Release: 1%{?gitrel}%{?dist}
Summary: YaST Development Tools
License: GPLv2+
@ -47,10 +47,6 @@ URL: https://en.opensuse.org/Portal:YaST
# Sources for snapshot-builds.
%{!?rel_build:Source0: %{src_url}/archive/%{commit}.tar.gz#/%{gittar}}
# Patches cherry-picked from PR to upstream. See:
# https://github.com/yast/yast-devtools/pull/85
Patch0: https://github.com/besser82/yast-devtools/commit/55faf823b8802c7c3db05d1e3d13a4e1ae8ecc0f.patch#/yast2-devtools-3.1.31_use_new_AC_INIT_syntax.patch
Patch1: https://github.com/besser82/yast-devtools/commit/015df9c12f30caccaa46286c06e11999d7216ab8.patch#/yast2-devtools-3.1.31_replace_obsolete_AC_PROG_LIBTOOL.patch
BuildArch: noarch
BuildRequires: automake
@ -91,15 +87,11 @@ and building YaST2 modules and components.
%prep
%setup -qn %{repo_name}-%{?rel_build:%{repo_name}-master-%{version}}%{!?rel_build:%{commit}}
# Apply patches.
%patch0 -p1 -b .AC_INIT_syntax
%patch1 -p1 -b .use_LT_INIT
# Bootstrap autosh*t.
./build-tools/scripts/y2autoconf --bootstrap ./build-tools/
./build-tools/scripts/y2automake --bootstrap ./build-tools/
%{__cat} ./build-tools/aclocal/*.m4 > acinclude.m4
%{_bindir}/autoreconf -fiv
%{_bindir}/autoreconf -fiv -Wobsolete
# Fix-up hashbangs.
for _file in $(%{__grep} -Rle '#![ \t]*/usr/bin/env' .)
@ -156,7 +148,10 @@ done
%check
%{__make} check
if [ ! -f "%{yast_ydatadir}/devtools/NO_MAKE_CHECK" ]; then
%{__make} check VERBOSE=1 Y2DIR="%{buildroot}/%{yast_dir}" \
DESTDIR="%{buildroot}"
fi
%files
@ -176,6 +171,12 @@ done
%changelog
* Mon May 11 2015 Björn Esser <bjoern.esser@gmail.com> - 3.1.32-1
- new upstream release
- add `-Wobsolete`-flag to autoreconf
- remove Patch0 and Patch1, since they are merged into upstream
- use conditional and more elaborate test-invocation
* Sat May 09 2015 Björn Esser <bjoern.esser@gmail.com> - 3.1.31-2
- fix AutoTools: Obsoleted m4s found: AC_PROG_LIBTOOL (#1220036)
- add Patch0: use new `AC_INIT()`-syntax with args in square braces