xviewer/Remove_obsolete_gnome-deskt...

58 lines
1.7 KiB
Diff

From 0e7749ba0bfac7e72c19841afcbebb10851533b4 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Fri, 14 Jul 2017 11:41:38 +0200
Subject: [PATCH] thumbnail: Remove use of obsolete gnome-desktop-thumbnail
helper
gnome_desktop_thumbnail_scale_down_pixbuf() is obsolete now that
gdk-pixbuf doesn't have the same bugs when shrinking images by large
factors.
https://bugzilla.gnome.org/show_bug.cgi?id=784942
---
configure.ac | 2 +-
src/xviewer-thumbnail.c | 9 +++++----
2 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/configure.ac b/configure.ac
index e991fd035..763fef2dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,7 +88,7 @@
GTK_REQUIRED=3.10.0
GLIB_REQUIRED=2.38.0
GNOME_DESKTOP_REQUIRED=2.91.2
-GDKPIXBUF_REQUIRED=2.4.0
+GDKPIXBUF_REQUIRED=2.36.5
GTK_PRINT_REQUIRED=3.5.4
SHARED_MIME_INFO_REQUIRED=0.20
EXEMPI_REQUIRED=1.99.5
diff --git a/src/xviewer-thumbnail.c b/src/xviewer-thumbnail.c
index 2e9fdd02c..2cc6fdf07 100644
--- a/src/xviewer-thumbnail.c
+++ b/src/xviewer-thumbnail.c
@@ -123,9 +123,10 @@ create_thumbnail_from_pixbuf (EogThumbData *data,
perc = CLAMP (128.0/(MAX (width, height)), 0, 1);
- thumb = gnome_desktop_thumbnail_scale_down_pixbuf (pixbuf,
- width*perc,
- height*perc);
+ thumb = gdk_pixbuf_scale_simple (pixbuf,
+ width*perc,
+ height*perc,
+ GDK_INTERP_HYPER);
return thumb;
}
@@ -444,7 +445,7 @@ eog_thumbnail_fit_to_size (GdkPixbuf *thumbnail, gint dimension)
width = MAX (width * factor, 1);
height = MAX (height * factor, 1);
- result_pixbuf = gnome_desktop_thumbnail_scale_down_pixbuf (thumbnail, width, height);
+ result_pixbuf = gdk_pixbuf_scale_simple (thumbnail, width, height, GDK_INTERP_HYPER);
return result_pixbuf;
}