New upstream release
This commit is contained in:
parent
b390fb4cbf
commit
bd5d6ff3b3
@ -1,57 +0,0 @@
|
||||
From 0e7749ba0bfac7e72c19841afcbebb10851533b4 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Fri, 14 Jul 2017 11:41:38 +0200
|
||||
Subject: [PATCH] thumbnail: Remove use of obsolete gnome-desktop-thumbnail
|
||||
helper
|
||||
|
||||
gnome_desktop_thumbnail_scale_down_pixbuf() is obsolete now that
|
||||
gdk-pixbuf doesn't have the same bugs when shrinking images by large
|
||||
factors.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=784942
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
src/xviewer-thumbnail.c | 9 +++++----
|
||||
2 files changed, 6 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index e991fd035..763fef2dd 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -88,7 +88,7 @@
|
||||
GTK_REQUIRED=3.10.0
|
||||
GLIB_REQUIRED=2.38.0
|
||||
GNOME_DESKTOP_REQUIRED=2.91.2
|
||||
-GDKPIXBUF_REQUIRED=2.4.0
|
||||
+GDKPIXBUF_REQUIRED=2.36.5
|
||||
GTK_PRINT_REQUIRED=3.5.4
|
||||
SHARED_MIME_INFO_REQUIRED=0.20
|
||||
EXEMPI_REQUIRED=1.99.5
|
||||
|
||||
diff --git a/src/xviewer-thumbnail.c b/src/xviewer-thumbnail.c
|
||||
index 2e9fdd02c..2cc6fdf07 100644
|
||||
--- a/src/xviewer-thumbnail.c
|
||||
+++ b/src/xviewer-thumbnail.c
|
||||
@@ -123,9 +123,10 @@ create_thumbnail_from_pixbuf (EogThumbData *data,
|
||||
|
||||
perc = CLAMP (128.0/(MAX (width, height)), 0, 1);
|
||||
|
||||
- thumb = gnome_desktop_thumbnail_scale_down_pixbuf (pixbuf,
|
||||
- width*perc,
|
||||
- height*perc);
|
||||
+ thumb = gdk_pixbuf_scale_simple (pixbuf,
|
||||
+ width*perc,
|
||||
+ height*perc,
|
||||
+ GDK_INTERP_HYPER);
|
||||
|
||||
return thumb;
|
||||
}
|
||||
@@ -444,7 +445,7 @@ eog_thumbnail_fit_to_size (GdkPixbuf *thumbnail, gint dimension)
|
||||
width = MAX (width * factor, 1);
|
||||
height = MAX (height * factor, 1);
|
||||
|
||||
- result_pixbuf = gnome_desktop_thumbnail_scale_down_pixbuf (thumbnail, width, height);
|
||||
+ result_pixbuf = gdk_pixbuf_scale_simple (thumbnail, width, height, GDK_INTERP_HYPER);
|
||||
|
||||
return result_pixbuf;
|
||||
}
|
@ -1,84 +0,0 @@
|
||||
From 61a2da998bf447c0e9aea9d5d0c1a7472715b1df Mon Sep 17 00:00:00 2001
|
||||
From: Michael Webster <miketwebster@gmail.com>
|
||||
Date: Sat, 10 Mar 2018 00:39:37 -0500
|
||||
Subject: [PATCH] build: Use cinnamon-desktop instead of gnome-desktop.
|
||||
|
||||
---
|
||||
configure.ac | 6 ++----
|
||||
debian/control | 3 +--
|
||||
src/xviewer-file-chooser.c | 2 +-
|
||||
src/xviewer-thumbnail.c | 2 +-
|
||||
4 files changed, 5 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3b168dd..f0f8bc7 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -87,12 +87,11 @@ YELP_HELP_INIT
|
||||
|
||||
GTK_REQUIRED=3.10.0
|
||||
GLIB_REQUIRED=2.38.0
|
||||
-GNOME_DESKTOP_REQUIRED=2.91.2
|
||||
+CINNAMON_DESKTOP_REQUIRED=3.2.0
|
||||
GDKPIXBUF_REQUIRED=2.4.0
|
||||
GTK_PRINT_REQUIRED=3.5.4
|
||||
SHARED_MIME_INFO_REQUIRED=0.20
|
||||
EXEMPI_REQUIRED=1.99.5
|
||||
-DESKTOP_SCHEMAS_REQUIRED=2.91.92
|
||||
LIBPEAS_REQUIRED=0.7.4
|
||||
LIBPEAS_GTK_REQUIRED=0.7.4
|
||||
|
||||
@@ -100,11 +99,10 @@ XVIEWER_MODULES="gtk+-3.0 >= $GTK_REQUIRED \
|
||||
glib-2.0 >= $GLIB_REQUIRED \
|
||||
gio-2.0 >= $GLIB_REQUIRED \
|
||||
gio-unix-2.0 >= $GLIB_REQUIRED \
|
||||
- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED \
|
||||
+ cinnamon-desktop >= $CINNAMON_DESKTOP_REQUIRED \
|
||||
gdk-pixbuf-2.0 >= $GDKPIXBUF_REQUIRED \
|
||||
gtk+-unix-print-3.0 >= $GTK_PRINT_REQUIRED \
|
||||
shared-mime-info >= $SHARED_MIME_INFO_REQUIRED \
|
||||
- gsettings-desktop-schemas >= $DESKTOP_SCHEMAS_REQUIRED \
|
||||
libpeas-1.0 >= $LIBPEAS_REQUIRED \
|
||||
libpeas-gtk-1.0 >= $LIBPEAS_GTK_REQUIRED"
|
||||
|
||||
diff --git a/debian/control b/debian/control
|
||||
index 601b98a..ab53292 100644
|
||||
--- a/debian/control
|
||||
+++ b/debian/control
|
||||
@@ -15,9 +15,8 @@ Build-Depends: cdbs (>= 0.4.41),
|
||||
libgtk-3-dev,
|
||||
libgdk-pixbuf2.0-dev (>= 2.19.1),
|
||||
libglib2.0-dev (>= 2.38.0),
|
||||
- libgnome-desktop-3-dev (>= 2.91.2),
|
||||
+ libcinnamon-desktop-dev (>=3.2.0),
|
||||
shared-mime-info (>= 0.20),
|
||||
- gsettings-desktop-schemas-dev (>= 2.91.92),
|
||||
libpeas-dev (>= 0.7.4),
|
||||
yelp-tools,
|
||||
zlib1g-dev,
|
||||
diff --git a/src/xviewer-file-chooser.c b/src/xviewer-file-chooser.c
|
||||
index adaee1d..f9c952d 100644
|
||||
--- a/src/xviewer-file-chooser.c
|
||||
+++ b/src/xviewer-file-chooser.c
|
||||
@@ -33,7 +33,7 @@
|
||||
#ifndef GNOME_DESKTOP_USE_UNSTABLE_API
|
||||
#define GNOME_DESKTOP_USE_UNSTABLE_API
|
||||
#endif
|
||||
-#include <libgnome-desktop/gnome-desktop-thumbnail.h>
|
||||
+#include <libcinnamon-desktop/gnome-desktop-thumbnail.h>
|
||||
|
||||
static char *last_dir[] = { NULL, NULL, NULL, NULL };
|
||||
|
||||
diff --git a/src/xviewer-thumbnail.c b/src/xviewer-thumbnail.c
|
||||
index 26ee6a0..db42124 100644
|
||||
--- a/src/xviewer-thumbnail.c
|
||||
+++ b/src/xviewer-thumbnail.c
|
||||
@@ -31,7 +31,7 @@
|
||||
#ifndef GNOME_DESKTOP_USE_UNSTABLE_API
|
||||
#define GNOME_DESKTOP_USE_UNSTABLE_API
|
||||
#endif
|
||||
-#include <libgnome-desktop/gnome-desktop-thumbnail.h>
|
||||
+#include <libcinnamon-desktop/gnome-desktop-thumbnail.h>
|
||||
|
||||
#include "xviewer-thumbnail.h"
|
||||
#include "xviewer-list-store.h"
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (xviewer-1.6.1.tar.gz) = 255f35e7a08550c0f079b1475799f7d5efa7219aacc187119d13cdd1bf77c05dc5f450eb57b8f39291098e27ab2487c7b514e6ee33f1a7869e0ebf7c89964281
|
||||
SHA512 (xviewer-1.8.0.tar.gz) = 1eff03462978747fd1c40b3a0af9dbb355b0d74d3bde459227ac179123ce6d3b23da08152d9d4c464dbefabf185307a03dc890cdd3152cc76ffcb45445f6e73c
|
||||
|
37
xviewer.spec
37
xviewer.spec
@ -6,14 +6,13 @@
|
||||
|
||||
|
||||
Name: xviewer
|
||||
Version: 1.6.1
|
||||
Version: 1.8.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Fast and functional graphics viewer
|
||||
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Url: https://github.com/linuxmint/%{name}
|
||||
Source: %{url}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
Patch0: %{url}/commit/61a2da998bf447c0e9aea9d5d0c1a7472715b1df.patch#/free_xviewer_gnome_dep.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: libappstream-glib
|
||||
@ -63,14 +62,14 @@ compliance.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}%{?_isa} == %{version}-%{release}
|
||||
Requires: %{name}%{?_isa} == %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
This package contains the development files to developt plugins for %{name}.
|
||||
This package contains the development files to develop plugins for %{name}.
|
||||
|
||||
|
||||
%package doc
|
||||
Summary: Documentation files for %{name}
|
||||
Summary: Documentation files for %{name}
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: gtk-doc
|
||||
@ -83,6 +82,8 @@ This package contains the documentation files for %{name}.
|
||||
%autosetup -p 1
|
||||
NOCONFIGURE=1 %{_bindir}/gnome-autogen.sh
|
||||
|
||||
# Remove zero length file
|
||||
%{__rm} ChangeLog
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -98,19 +99,18 @@ NOCONFIGURE=1 %{_bindir}/gnome-autogen.sh
|
||||
%{buildroot}%{_libdir}/%{name}/plugins \
|
||||
%{buildroot}%{_mandir}/man1
|
||||
%{__install} -pm 0644 debian/%{name}.1 %{buildroot}%{_mandir}/man1
|
||||
%{_bindir}/find %{buildroot} -type f -name '*.a' -print -delete
|
||||
%{_bindir}/find %{buildroot} -type f -name '*.la' -print -delete
|
||||
%{_bindir}/find %{buildroot} -type f -name '*.la' -or -name '*.a' -print -delete
|
||||
%find_lang %{name}
|
||||
|
||||
|
||||
%check
|
||||
# Validate desktop-files.
|
||||
%{_bindir}/desktop-file-validate \
|
||||
%{buildroot}%{_datadir}/applications/*.desktop
|
||||
%{buildroot}%{_datadir}/applications/*.desktop
|
||||
|
||||
# Validate AppData-files.
|
||||
%{_bindir}/appstream-util validate-relax --nonet \
|
||||
%{buildroot}%{_datadir}/appdata/*.appdata.xml
|
||||
%{buildroot}%{_datadir}/appdata/*.appdata.xml
|
||||
|
||||
|
||||
%if (0%{?rhel} && 0%{?rhel <= 7})
|
||||
@ -133,9 +133,7 @@ fi
|
||||
|
||||
|
||||
%files -f %{name}.lang
|
||||
%dir %{_datadir}/%{name}/plugins
|
||||
%dir %{_libdir}/%{name}/plugins
|
||||
%doc ChangeLog README THANKS debian/changelog
|
||||
%doc README THANKS debian/changelog
|
||||
%license AUTHORS COPYING debian/copyright
|
||||
%exclude %{_datadir}/%{name}/gir-1.0/
|
||||
%{_bindir}/%{name}
|
||||
@ -143,26 +141,29 @@ fi
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/GConf/gsettings/%{name}.convert
|
||||
%{_datadir}/glib-2.0/schemas/*.xml
|
||||
%{_datadir}/help/*/%{name}
|
||||
%{_datadir}/help/*/%{name}/
|
||||
%{_datadir}/icons/hicolor/*/apps/%{name}.*
|
||||
%{_datadir}/%{name}
|
||||
%{_libdir}/%{name}
|
||||
%{_datadir}/%{name}/
|
||||
%{_libdir}/%{name}/
|
||||
%{_mandir}/man1/%{name}.1*
|
||||
|
||||
|
||||
%files devel
|
||||
%{_datadir}/%{name}/gir-1.0
|
||||
%{_includedir}/%{name}-3.0
|
||||
%{_datadir}/%{name}/gir-1.0/
|
||||
%{_includedir}/%{name}-3.0/
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
|
||||
|
||||
%files doc
|
||||
%license %{_datadir}/licenses/%{name}*
|
||||
%doc %{_datadir}/doc/%{name}*
|
||||
%doc %{_datadir}/gtk-doc
|
||||
%license %{_datadir}/licenses/%{name}*
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Apr 29 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.8.0-1
|
||||
- New upstream release
|
||||
|
||||
* Sun Mar 11 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.6.1-1
|
||||
- Free xview from gnome-desktop requirement
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user