add xmobar-0.13-default-fonts.patch to use xft:mono-12 font by default; add ppc64
This commit is contained in:
parent
aa58ec79f6
commit
d2806e020f
39
xmobar-0.13-default-fonts.patch
Normal file
39
xmobar-0.13-default-fonts.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- a/samples/xmobar.config 2010-12-24 05:12:22.000000000 +0300
|
||||||
|
+++ b/samples/xmobar.config 2011-05-28 17:57:04.141822660 +0400
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-Config { font = "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||||
|
+Config { font = "xft:mono-12"
|
||||||
|
, bgColor = "black"
|
||||||
|
, fgColor = "grey"
|
||||||
|
, position = Top
|
||||||
|
--- a/src/XUtil.hsc 2011-05-28 18:03:01.226823112 +0400
|
||||||
|
+++ b/src/XUtil.hsc 2011-05-28 18:03:16.017823085 +0400
|
||||||
|
@@ -99,7 +99,7 @@
|
||||||
|
addFinalizer f (freeFont d f)
|
||||||
|
return f
|
||||||
|
where getIt = loadQueryFont d s
|
||||||
|
- fallBack = const $ loadQueryFont d "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||||
|
+ fallBack = const $ loadQueryFont d "-misc-fixed-*-*-*-*-13-*-*-*-*-*-*-*"
|
||||||
|
|
||||||
|
-- | Given a fontname returns the font structure. If the font name is
|
||||||
|
-- not valid the default font will be loaded and returned.
|
||||||
|
@@ -110,7 +110,7 @@
|
||||||
|
addFinalizer f (freeFontSet d f)
|
||||||
|
return f
|
||||||
|
where getIt = createFontSet d s
|
||||||
|
- fallBack = const $ createFontSet d "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||||
|
+ fallBack = const $ createFontSet d "-misc-fixed-*-*-*-*-13-*-*-*-*-*-*-*"
|
||||||
|
|
||||||
|
#ifdef XFT
|
||||||
|
initXftFont :: Display -> String -> IO XftFont
|
||||||
|
--- a/src/Config.hs 2011-05-28 18:03:39.371822760 +0400
|
||||||
|
+++ b/src/Config.hs 2011-05-28 18:04:52.909823071 +0400
|
||||||
|
@@ -83,7 +83,7 @@
|
||||||
|
-- | The default configuration values
|
||||||
|
defaultConfig :: Config
|
||||||
|
defaultConfig =
|
||||||
|
- Config { font = "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||||
|
+ Config { font = "xft:mono-12"
|
||||||
|
, bgColor = "#000000"
|
||||||
|
, fgColor = "#BFBFBF"
|
||||||
|
, position = Top
|
13
xmobar.spec
13
xmobar.spec
@ -8,7 +8,7 @@
|
|||||||
|
|
||||||
Name: xmobar
|
Name: xmobar
|
||||||
Version: 0.13
|
Version: 0.13
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A minimalistic text-based status bar
|
Summary: A minimalistic text-based status bar
|
||||||
|
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -20,11 +20,10 @@ Source1: xmobar.desktop
|
|||||||
# https://github.com/jaor/xmobar/issues/#issue/6
|
# https://github.com/jaor/xmobar/issues/#issue/6
|
||||||
Source2: xmonadpropwrite.hs
|
Source2: xmonadpropwrite.hs
|
||||||
# fedora ghc archs:
|
# fedora ghc archs:
|
||||||
ExclusiveArch: %{ix86} x86_64 ppc alpha sparcv9
|
ExclusiveArch: %{ix86} x86_64 ppc alpha sparcv9 ppc64
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: ghc
|
|
||||||
BuildRequires: ghc-devel
|
BuildRequires: ghc-devel
|
||||||
BuildRequires: ghc-rpm-macros >= 0.7.3
|
BuildRequires: ghc-rpm-macros
|
||||||
BuildRequires: ghc-X11-devel >= 1.3.0
|
BuildRequires: ghc-X11-devel >= 1.3.0
|
||||||
BuildRequires: ghc-X11-xft-devel
|
BuildRequires: ghc-X11-xft-devel
|
||||||
BuildRequires: ghc-mtl-devel
|
BuildRequires: ghc-mtl-devel
|
||||||
@ -38,6 +37,7 @@ BuildRequires: ghc-libmpd-devel
|
|||||||
%if %{with iwlib}
|
%if %{with iwlib}
|
||||||
BuildRequires: wireless-tools-devel
|
BuildRequires: wireless-tools-devel
|
||||||
%endif
|
%endif
|
||||||
|
Patch1: xmobar-0.13-default-fonts.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Inspired by the Ion3 status bar, it supports similar features, like dynamic
|
Inspired by the Ion3 status bar, it supports similar features, like dynamic
|
||||||
@ -46,6 +46,7 @@ color management, output templates, and extensibility through plugins.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .orig
|
||||||
mkdir scripts
|
mkdir scripts
|
||||||
cp %{SOURCE2} scripts/xmonadpropwrite.hs
|
cp %{SOURCE2} scripts/xmonadpropwrite.hs
|
||||||
|
|
||||||
@ -78,6 +79,10 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 3 2011 Jens Petersen <petersen@redhat.com> - 0.13-2
|
||||||
|
- use xft:mono-12 font by default using patch from Pavel Zhukov (#708633)
|
||||||
|
- add ppc64
|
||||||
|
|
||||||
* Mon Mar 28 2011 Ben Boeckel <mathstuf@gmail.com> - 0.13-1
|
* Mon Mar 28 2011 Ben Boeckel <mathstuf@gmail.com> - 0.13-1
|
||||||
- Update to 0.13
|
- Update to 0.13
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user