update to 0.16
This commit is contained in:
parent
468b9fb3e9
commit
64635944b2
@ -6,26 +6,17 @@
|
||||
, borderColor = "black"
|
||||
, border = TopB
|
||||
, bgColor = "black"
|
||||
--- a/src/XUtil.hsc 2011-05-28 18:03:01.226823112 +0400
|
||||
+++ b/src/XUtil.hsc 2011-05-28 18:03:16.017823085 +0400
|
||||
@@ -99,7 +99,7 @@
|
||||
addFinalizer f (freeFont d f)
|
||||
return f
|
||||
where getIt = loadQueryFont d s
|
||||
- fallBack = const $ loadQueryFont d "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||
+ fallBack = const $ loadQueryFont d "-misc-fixed-*-*-*-*-13-*-*-*-*-*-*-*"
|
||||
--- xmobar-0.16/src/XUtil.hsc~ 2012-12-03 08:47:56.000000000 +0900
|
||||
+++ xmobar-0.16/src/XUtil.hsc 2013-01-19 19:12:52.273165837 +0900
|
||||
@@ -92,7 +92,7 @@
|
||||
#endif
|
||||
|
||||
miscFixedFont :: String
|
||||
-miscFixedFont = "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||
+miscFixedFont = "-misc-fixed-*-*-*-*-13-*-*-*-*-*-*-*"
|
||||
|
||||
-- | Given a fontname returns the font structure. If the font name is
|
||||
-- not valid the default font will be loaded and returned.
|
||||
@@ -110,7 +110,7 @@
|
||||
addFinalizer f (freeFontSet d f)
|
||||
return f
|
||||
where getIt = createFontSet d s
|
||||
- fallBack = const $ createFontSet d "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||
+ fallBack = const $ createFontSet d "-misc-fixed-*-*-*-*-13-*-*-*-*-*-*-*"
|
||||
|
||||
#ifdef XFT
|
||||
initXftFont :: Display -> String -> IO XftFont
|
||||
--- a/src/Config.hs 2011-05-28 18:03:39.371822760 +0400
|
||||
+++ b/src/Config.hs 2011-05-28 18:04:52.909823071 +0400
|
||||
@@ -83,7 +83,7 @@
|
@ -1,10 +1,6 @@
|
||||
--- xmobar-0.15/xmobar.cabal~ 2012-10-29 17:05:03.537038157 +0900
|
||||
+++ xmobar-0.15/xmobar.cabal 2012-11-18 12:28:28.698660089 +0900
|
||||
@@ -28,10 +28,11 @@
|
||||
|
||||
flag small_base
|
||||
description: Choose the new smaller, split-up base package.
|
||||
+ default: True
|
||||
@@ -31,7 +32,7 @@
|
||||
|
||||
flag with_xft
|
||||
description: Use Xft to render text. UTF-8 support included.
|
||||
|
18
xmobar.spec
18
xmobar.spec
@ -2,8 +2,8 @@
|
||||
# https://fedoraproject.org/wiki/PackagingDrafts/Haskell
|
||||
|
||||
Name: xmobar
|
||||
Version: 0.15
|
||||
Release: 4%{?dist}
|
||||
Version: 0.16
|
||||
Release: 1%{?dist}
|
||||
Summary: A minimalistic text-based status bar
|
||||
|
||||
License: BSD
|
||||
@ -11,7 +11,7 @@ URL: http://hackage.haskell.org/package/%{name}
|
||||
Source0: http://hackage.haskell.org/packages/archive/%{name}/%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: xmobar.desktop
|
||||
Patch0: xmobar-flags.patch
|
||||
Patch1: xmobar-0.13-default-fonts.patch
|
||||
Patch1: xmobar-default-fonts.patch
|
||||
|
||||
BuildRequires: ghc-Cabal-devel
|
||||
BuildRequires: ghc-rpm-macros
|
||||
@ -32,11 +32,11 @@ BuildRequires: ghc-stm-devel
|
||||
BuildRequires: ghc-time-devel
|
||||
BuildRequires: ghc-unix-devel
|
||||
BuildRequires: ghc-utf8-string-devel
|
||||
BuildRequires: libXrandr-devel%{?_isa}
|
||||
BuildRequires: wireless-tools-devel%{?_isa}
|
||||
# End cabal-rpm deps
|
||||
BuildRequires: desktop-file-utils
|
||||
#BuildRequires: ghc-alsa-mixer-devel
|
||||
BuildRequires: wireless-tools-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
|
||||
%description
|
||||
Inspired by the Ion3 status bar, it supports similar features, like dynamic
|
||||
@ -48,9 +48,6 @@ color management, output templates, and extensibility through plugins.
|
||||
%patch0 -p1 -b .orig
|
||||
%patch1 -p1 -b .fonts
|
||||
|
||||
cabal-tweak-dep-ver mtl "== 2.0.*" ">= 2.0"
|
||||
cabal-tweak-dep-ver stm "== 2.3.*" ">= 2.3"
|
||||
|
||||
|
||||
%build
|
||||
%ghc_bin_build
|
||||
@ -68,13 +65,16 @@ install --mode=0755 -p samples/xmonadpropwrite %{buildroot}%{_bindir}/xmonadprop
|
||||
|
||||
|
||||
%files
|
||||
%doc LICENSE readme.md news.md samples/xmobar.config
|
||||
%doc license readme.md news.md samples/xmobar.config
|
||||
%attr(755,root,root) %{_bindir}/%{name}
|
||||
%attr(755,root,root) %{_bindir}/xmonadpropwrite
|
||||
%{_datadir}/applications/xmobar.desktop
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jan 19 2013 Jens Petersen <petersen@redhat.com> - 0.16-1
|
||||
- update to 0.16
|
||||
|
||||
* Sat Nov 17 2012 Jens Petersen <petersen@redhat.com> - 0.15-4
|
||||
- update with cabal-rpm
|
||||
- set flags with patch for cabal-rpm
|
||||
|
Loading…
x
Reference in New Issue
Block a user