update xmobar-0.13-default-fonts.patch and remove xmobar-0.14-MPD-ghc74-Show.patch
This commit is contained in:
parent
5471e08de6
commit
1f9f62ab4e
@ -3,9 +3,9 @@
|
||||
@@ -1,4 +1,4 @@
|
||||
-Config { font = "-misc-fixed-*-*-*-*-10-*-*-*-*-*-*-*"
|
||||
+Config { font = "xft:mono-12"
|
||||
, borderColor = "black"
|
||||
, border = TopB
|
||||
, bgColor = "black"
|
||||
, fgColor = "grey"
|
||||
, position = Top
|
||||
--- a/src/XUtil.hsc 2011-05-28 18:03:01.226823112 +0400
|
||||
+++ b/src/XUtil.hsc 2011-05-28 18:03:16.017823085 +0400
|
||||
@@ -99,7 +99,7 @@
|
||||
|
@ -1,10 +0,0 @@
|
||||
diff -u xmobar-0.14/src/Plugins/Monitors/MPD.hs\~ xmobar-0.14/src/Plugins/Monitors/MPD.hs
|
||||
--- xmobar-0.14/src/Plugins/Monitors/MPD.hs~ 2011-12-11 02:41:54.000000000 +0900
|
||||
+++ xmobar-0.14/src/Plugins/Monitors/MPD.hs 2012-03-21 11:30:50.420759773 +0900
|
||||
@@ -102,5 +102,5 @@
|
||||
where minutes = t `div` 60
|
||||
seconds = t `mod` 60
|
||||
|
||||
-int2str :: (Num a, Ord a) => a -> String
|
||||
+int2str :: (Show a, Num a, Ord a) => a -> String
|
||||
int2str x = if x < 10 then '0':sx else sx where sx = show x
|
10
xmobar.spec
10
xmobar.spec
@ -8,8 +8,8 @@
|
||||
%bcond_with alsa
|
||||
|
||||
Name: xmobar
|
||||
Version: 0.14
|
||||
Release: 4%{?dist}
|
||||
Version: 0.15
|
||||
Release: 1%{?dist}
|
||||
Summary: A minimalistic text-based status bar
|
||||
|
||||
Group: User Interface/X
|
||||
@ -23,7 +23,6 @@ BuildRequires: ghc-rpm-macros
|
||||
# END cabal2spec
|
||||
Source1: xmobar.desktop
|
||||
Patch1: xmobar-0.13-default-fonts.patch
|
||||
Patch2: xmobar-0.14-MPD-ghc74-Show.patch
|
||||
|
||||
%if %{with alsa}
|
||||
BuildRequires: ghc-alsa-mixer-devel
|
||||
@ -63,7 +62,6 @@ color management, output templates, and extensibility through plugins.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .fonts
|
||||
%patch2 -p1 -b .show
|
||||
|
||||
|
||||
%build
|
||||
@ -90,6 +88,10 @@ install --mode=0755 -p samples/xmonadpropwrite %{buildroot}%{_bindir}/xmonadprop
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 11 2012 Jens Petersen <petersen@redhat.com> - 0.15-1
|
||||
- update to 0.15
|
||||
- xmobar-0.14-MPD-ghc74-Show.patch no longer needed
|
||||
|
||||
* Wed Mar 21 2012 Jens Petersen <petersen@redhat.com> - 0.14-4
|
||||
- fix MPD build on ghc-7.4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user