* Sun Dec 17 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.1.3-2
- Don't run autotools during build. * Mon Dec 04 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.1.3-1 - version 1.1.3 - patch2 applied upstream - Disable CACA support by default, needs newer than what's in FE ATM. - Split extras plugins in a separate package - Enable JACK support (in extras subpackage) - Enable DirectFB support (in extras subpackage) * Sat Nov 11 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.1.2-18 - Make shn files available to amarok. References: http://xine.cvs.sourceforge.net/xine/xine-lib/src/demuxers/demux_shn.c?r1=1.1.2.2&r2=1.2 https://launchpad.net/distros/ubuntu/+source/xine-lib/+bug/63130
This commit is contained in:
parent
16802e7600
commit
fe292c0faa
@ -1 +1,2 @@
|
|||||||
xine-lib-1.1.2.tar.bz2
|
xine-lib-1.1.3-pruned.tar.bz2
|
||||||
|
xine-lib-1.1.3-autotools.patch.bz2
|
||||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
|||||||
d1afb34d2335f8c9ded4d9a2b741251e xine-lib-1.1.2.tar.bz2
|
eff682745f198e1881773509f12c70c3 xine-lib-1.1.3-pruned.tar.bz2
|
||||||
|
a58fce450d9288224caa413ad8bc1f8d xine-lib-1.1.3-autotools.patch.bz2
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
--- m4/optimizations.m4.orig 2005-11-27 01:20:08.000000000 +0100
|
|
||||||
+++ m4/optimizations.m4 2005-11-27 01:22:56.000000000 +0100
|
|
||||||
@@ -161,10 +161,6 @@
|
|
||||||
;;
|
|
||||||
|
|
||||||
esac
|
|
||||||
- if test x"$archopt_val" != x; then
|
|
||||||
- CFLAGS="$sarchopt=$archopt_val $CFLAGS"
|
|
||||||
- DEBUG_CFLAGS="$sarchopt=$archopt_val $DEBUG_CFLAGS"
|
|
||||||
- fi
|
|
||||||
fi
|
|
||||||
else
|
|
||||||
dnl we have the Intel compiler
|
|
22
xine-lib-1.1.3-optflags.patch
Normal file
22
xine-lib-1.1.3-optflags.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- xine-lib-1.1.3/m4/optimizations.m4~ 2006-06-17 18:20:56.000000000 +0300
|
||||||
|
+++ xine-lib-1.1.3/m4/optimizations.m4 2006-12-17 11:49:44.000000000 +0200
|
||||||
|
@@ -107,7 +107,7 @@
|
||||||
|
|
||||||
|
DEBUG_CFLAGS="-O $DEBUG_CFLAGS"
|
||||||
|
|
||||||
|
- if test x"$sarchopt" != "xno"; then
|
||||||
|
+ if false ; then
|
||||||
|
archopt_val=
|
||||||
|
|
||||||
|
case "$host_or_hostalias" in
|
||||||
|
--- xine-lib-1.1.3/configure~ 2006-12-03 21:41:27.000000000 +0200
|
||||||
|
+++ xine-lib-1.1.3/configure 2006-12-17 11:50:07.000000000 +0200
|
||||||
|
@@ -46971,7 +46971,7 @@
|
||||||
|
|
||||||
|
DEBUG_CFLAGS="-O $DEBUG_CFLAGS"
|
||||||
|
|
||||||
|
- if test x"$sarchopt" != "xno"; then
|
||||||
|
+ if false ; then
|
||||||
|
archopt_val=
|
||||||
|
|
||||||
|
case "$host_or_hostalias" in
|
@ -6,8 +6,9 @@ if [ -z "$1" -o $# -ne 1 ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
version=$1
|
version=$1
|
||||||
tarball="xine-lib-$version.tar.bz2"
|
tarball="xine-lib-$version.tar.gz"
|
||||||
dir="xine-lib-$version"
|
dir="xine-lib-$version"
|
||||||
|
modtarball="xine-lib-$version-pruned.tar.bz2"
|
||||||
|
|
||||||
|
|
||||||
if [ ! -f $tarball ]; then
|
if [ ! -f $tarball ]; then
|
||||||
@ -17,7 +18,7 @@ fi
|
|||||||
|
|
||||||
echo "Uncompressing $tarball..."
|
echo "Uncompressing $tarball..."
|
||||||
rm -rf $dir
|
rm -rf $dir
|
||||||
tar -xjf $tarball
|
tar -xzf $tarball
|
||||||
cd $dir
|
cd $dir
|
||||||
|
|
||||||
# Main libraries
|
# Main libraries
|
||||||
@ -58,8 +59,6 @@ sed -i -e 's/planar//g;s/deinterlace//g' src/post/Makefile.am # fails to build
|
|||||||
# All clean !
|
# All clean !
|
||||||
|
|
||||||
cd ..
|
cd ..
|
||||||
echo "Generating $tarball..."
|
echo "Generating $modtarball..."
|
||||||
rm -f $tarball.orig
|
tar -cjf $modtarball $dir
|
||||||
mv $tarball $tarball.orig
|
|
||||||
tar -cjf $tarball $dir
|
|
||||||
rm -rf $dir
|
rm -rf $dir
|
||||||
|
145
xine-lib.spec
145
xine-lib.spec
@ -1,54 +1,64 @@
|
|||||||
# TODO, sometime, maybe:
|
# TODO, sometime, maybe:
|
||||||
# - libstk: http://www.libstk.net/
|
# - libstk: http://www.libstk.net/
|
||||||
# - polypaudio
|
# - pulseaudio
|
||||||
|
|
||||||
%define codecdir %{_libdir}/codecs
|
%define codecdir %{_libdir}/codecs
|
||||||
#%define vdrver 0.7.9
|
|
||||||
|
|
||||||
Summary: Xine library
|
Summary: Xine library
|
||||||
Name: xine-lib
|
Name: xine-lib
|
||||||
Version: 1.1.2
|
Version: 1.1.3
|
||||||
Release: 17%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://xinehq.de/
|
URL: http://xinehq.de/
|
||||||
# The tarball is generated from the upstream tarball using
|
# The tarball is generated from the upstream tarball using
|
||||||
# the script in SOURCE1. It prunes potentially patented code
|
# the script in SOURCE1. It prunes potentially patented code
|
||||||
Source0: http://dl.sourceforge.net/xine/xine-lib-1.1.2.tar.bz2
|
#Source0: http://dl.sourceforge.net/xine/xine-lib-%{version}.tar.gz
|
||||||
Source1: xine-lib-cleanup-sources.sh
|
Source0: %{name}-%{version}-pruned.tar.bz2
|
||||||
Patch1: xine-lib-1.1.1-configure-no-mcpu-march.patch
|
Source1: %{name}-cleanup-sources.sh
|
||||||
Patch6: xine-lib-1.1.1-deepbind-939.patch
|
# To recreate the autotools patch: install build deps, extract source0,
|
||||||
Patch7: xine-lib-1.1.1-multilib-devel.patch
|
# remove run_configure "$@" from autogen.sh, copy the dir to -patched,
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
# run autogen.sh (doesn't work with automake 1.10 as of 1.1.3 so use 1.9),
|
||||||
|
# remove autom4te.cache, then diff the dirs. Apply rest of the patches during
|
||||||
|
# build so that autotools do not need to be run again.
|
||||||
|
Patch0: %{name}-1.1.3-autotools.patch.bz2
|
||||||
|
Patch1: %{name}-1.1.3-optflags.patch
|
||||||
|
Patch6: %{name}-1.1.1-deepbind-939.patch
|
||||||
|
Patch7: %{name}-1.1.1-multilib-devel.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
# X11
|
# X11
|
||||||
BuildRequires: libX11-devel libXv-devel libXinerama-devel libXvMC-devel libGLU-devel
|
BuildRequires: libX11-devel libXv-devel libXinerama-devel libXvMC-devel libGLU-devel
|
||||||
# Video
|
# Video
|
||||||
BuildRequires: freetype-devel SDL-devel libtheora-devel libmng-devel
|
BuildRequires: freetype-devel SDL-devel libtheora-devel libmng-devel
|
||||||
BuildRequires: aalib-devel >= 1.4 libcaca-devel
|
BuildRequires: aalib-devel >= 1.4
|
||||||
|
%if 0%{?_with_caca:1}
|
||||||
|
BuildRequires: libcaca-devel >= 0.99
|
||||||
|
%endif
|
||||||
|
%if 0%{!?_without_directfb:1}
|
||||||
|
BuildRequires: directfb-devel
|
||||||
|
%endif
|
||||||
|
%if 0%{!?_without_imagemagick:1}
|
||||||
|
BuildRequires: ImageMagick-devel >= 6.2.4.6-1
|
||||||
|
%endif
|
||||||
# Audio
|
# Audio
|
||||||
BuildRequires: libogg-devel libvorbis-devel flac-devel libmodplug-devel
|
BuildRequires: libogg-devel libvorbis-devel flac-devel libmodplug-devel
|
||||||
BuildRequires: esound-devel speex-devel arts-devel alsa-lib-devel >= 0.9.0
|
BuildRequires: esound-devel speex-devel arts-devel alsa-lib-devel >= 0.9.0
|
||||||
|
BuildRequires: jack-audio-connection-kit-devel
|
||||||
# CDs
|
# CDs
|
||||||
BuildRequires: libcdio-devel
|
BuildRequires: libcdio-devel
|
||||||
# Other
|
# Other
|
||||||
BuildRequires: pkgconfig gnome-vfs2-devel gtk2-devel
|
BuildRequires: pkgconfig gnome-vfs2-devel gtk2-devel samba-common
|
||||||
BuildRequires: libtool >= 1.4.0 /usr/bin/automake-1.9 samba-common
|
|
||||||
|
|
||||||
%if 0%{?_with_directfb:1}
|
|
||||||
BuildRequires: directfb-devel
|
|
||||||
%endif
|
|
||||||
%if 0%{!?_without_imagemagick:1}
|
|
||||||
BuildRequires: ImageMagick-devel >= 6.2.4.6-1
|
|
||||||
%endif
|
|
||||||
#Provides: %{name}(vdr) = %{vdrver}
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Xine library development files
|
Summary: Xine library development files
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: pkgconfig zlib-devel
|
Requires: pkgconfig zlib-devel
|
||||||
#Requires: %{name}(vdr) = %{vdrver}
|
|
||||||
#Provides: %{name}-devel(vdr) = %{vdrver}
|
%package extras
|
||||||
|
Summary: Additional plugins for xine-lib
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -58,48 +68,69 @@ disk drives, and displays multimedia streamed over the Internet. It
|
|||||||
interprets many of the most common multimedia formats available - and some
|
interprets many of the most common multimedia formats available - and some
|
||||||
of the most uncommon formats, too. Non-default rpmbuild options:
|
of the most uncommon formats, too. Non-default rpmbuild options:
|
||||||
--without imagemagick: Disable ImageMagick support
|
--without imagemagick: Disable ImageMagick support
|
||||||
--with directfb: Enable DirectFB support
|
--without directfb: Disable DirectFB support
|
||||||
|
--with caca: Enable CACA support
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package contains development files for xine-lib.
|
This package contains development files for xine-lib.
|
||||||
|
|
||||||
|
%description extras
|
||||||
|
This package contains extra plugins for xine-lib:
|
||||||
|
- aRts
|
||||||
|
- EsounD
|
||||||
|
- JACK
|
||||||
|
- GDK-Pixbuf
|
||||||
|
- GNOME VFS
|
||||||
|
- SMB
|
||||||
|
- SDL
|
||||||
|
- AA-lib
|
||||||
|
%if 0%{?_with_caca:1}
|
||||||
|
- Libcaca
|
||||||
|
%endif
|
||||||
|
%if 0%{!?_without_imagemagick:1}
|
||||||
|
- Image decoding
|
||||||
|
%endif
|
||||||
|
%if 0%{!?_without_directfb:1}
|
||||||
|
- DirectFB output
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p0 -b .nomcpu
|
%patch0 -p1 -b .autotools
|
||||||
###cp -p debian/changelog ChangeLog.vdr
|
cp -p m4/optimizations.m4 m4/optimizations.m4.stamp
|
||||||
|
%patch1 -p1 -b .optflags
|
||||||
|
touch -r m4/optimizations.m4.stamp m4/optimizations.m4
|
||||||
# Patch6 needed at least when compiling with external ffmpeg, #939.
|
# Patch6 needed at least when compiling with external ffmpeg, #939.
|
||||||
%patch6 -p1 -b .deepbind
|
%patch6 -p1 -b .deepbind
|
||||||
%patch7 -p0 -b .multilib-devel
|
%patch7 -p0 -b .multilib-devel
|
||||||
|
|
||||||
find . -name "*.[hc]" | xargs chmod -c -x
|
find . -name "*.[hc]" | xargs chmod -c -x
|
||||||
|
|
||||||
aclocal-1.9 -I m4
|
|
||||||
libtoolize --force
|
|
||||||
autoheader
|
|
||||||
automake-1.9 --gnu --add-missing
|
|
||||||
autoconf
|
|
||||||
|
|
||||||
# Avoid standard rpaths on lib64 archs:
|
# Avoid standard rpaths on lib64 archs:
|
||||||
sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure
|
sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
FFMPEG_CPPFLAGS=" "; FFMPEG_LIBS=" "; export FFMPEG_CPPFLAGS FFMPEG_LIBS
|
export FFMPEG_CFLAGS=" " FFMPEG_LIBS=" "
|
||||||
|
export FFMPEG_POSTPROC_CFLAGS=" " FFMPEG_POSTPROC_LIBS=" "
|
||||||
|
export SDL_CFLAGS="$(sdl-config --cflags)" SDL_LIBS="$(sdl-config --libs)"
|
||||||
%configure --disable-dependency-tracking \
|
%configure --disable-dependency-tracking \
|
||||||
--with-xv-path=%{_libdir} \
|
--with-xv-path=%{_libdir} \
|
||||||
--with-w32-path=%{codecdir} \
|
--with-w32-path=%{codecdir} \
|
||||||
--with-external-ffmpeg \
|
--with-external-ffmpeg \
|
||||||
--enable-ipv6 \
|
--enable-ipv6 \
|
||||||
%if 0%{?_with_directfb:1}
|
%if 0%{!?_without_directfb:1}
|
||||||
--enable-directfb \
|
--enable-directfb \
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?_without_imagemagick:1}
|
%if 0%{?_without_imagemagick:1}
|
||||||
--disable-imagemagick \
|
--without-imagemagick \
|
||||||
|
%endif
|
||||||
|
%if 0%{!?_with_caca:1}
|
||||||
|
--without-caca \
|
||||||
%endif
|
%endif
|
||||||
--disable-rte \
|
|
||||||
--disable-libfame \
|
--disable-libfame \
|
||||||
--disable-ffmpegtest \
|
|
||||||
--disable-faad \
|
--disable-faad \
|
||||||
--disable-mad \
|
--disable-mad \
|
||||||
--disable-asf \
|
--disable-asf \
|
||||||
@ -146,7 +177,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_libdir}/xine/plugins/%{version}/
|
%dir %{_libdir}/xine/plugins/%{version}/
|
||||||
# I list all the plugins because I don't want a non-free plugin
|
# I list all the plugins because I don't want a non-free plugin
|
||||||
# to sneak into a future version
|
# to sneak into a future version
|
||||||
# these plugins do not have legal problems according to the SuSE RPM
|
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_alsa.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_alsa.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_oss.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_oss.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_none.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_none.so
|
||||||
@ -154,6 +184,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_file.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_file.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_none.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_none.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_opengl.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_opengl.so
|
||||||
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_syncfb.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xshm.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xshm.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xv.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xv.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_dvb.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_dvb.so
|
||||||
@ -163,12 +194,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_net.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_net.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_pnm.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_pnm.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_cdda.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_cdda.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_smb.so
|
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_stdin_fifo.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_stdin_fifo.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_rtsp.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_rtsp.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_pvr.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_pvr.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_rtp.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_rtp.so
|
||||||
#%{_libdir}/xine/plugins/%{version}/xineplug_inp_vdr.so
|
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_bitplane.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_decode_bitplane.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_rgb.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_decode_rgb.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_vorbis.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_decode_vorbis.so
|
||||||
@ -200,8 +229,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_slave.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_slave.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_flac.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_flac.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_sputext.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_decode_sputext.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_gdk_pixbuf.so
|
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_caca.so
|
|
||||||
%ifarch %ix86
|
%ifarch %ix86
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_vidix.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_vidix.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_qt.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_decode_qt.so
|
||||||
@ -213,13 +240,27 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
%{_libdir}/xine/plugins/%{version}/post/
|
%{_libdir}/xine/plugins/%{version}/post/
|
||||||
%{_libdir}/xine/plugins/%{version}/vidix/
|
%{_libdir}/xine/plugins/%{version}/vidix/
|
||||||
# Put it in a xine-lib-extras package one day ?
|
|
||||||
|
|
||||||
|
%files extras
|
||||||
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_arts.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_arts.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_esd.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_esd.so
|
||||||
|
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_jack.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_gnome_vfs.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_gnome_vfs.so
|
||||||
|
%{_libdir}/xine/plugins/%{version}/xineplug_inp_smb.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_sdl.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_sdl.so
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_aa.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_aa.so
|
||||||
|
%{_libdir}/xine/plugins/%{version}/xineplug_decode_gdk_pixbuf.so
|
||||||
|
%if 0%{?_with_caca:1}
|
||||||
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_caca.so
|
||||||
|
%endif
|
||||||
|
%if 0%{!?_without_imagemagick:1}
|
||||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_image.so
|
%{_libdir}/xine/plugins/%{version}/xineplug_decode_image.so
|
||||||
|
%endif
|
||||||
|
%if 0%{!?_without_directfb:1}
|
||||||
|
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_directfb.so
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -233,9 +274,25 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/libxine.pc
|
%{_libdir}/pkgconfig/libxine.pc
|
||||||
%{_mandir}/man1/xine-config.1*
|
%{_mandir}/man1/xine-config.1*
|
||||||
|
|
||||||
# --------------------------------------------------------------------
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 17 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.1.3-2
|
||||||
|
- Don't run autotools during build.
|
||||||
|
|
||||||
|
* Mon Dec 04 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.1.3-1
|
||||||
|
- version 1.1.3
|
||||||
|
- patch2 applied upstream
|
||||||
|
- Disable CACA support by default, needs newer than what's in FE ATM.
|
||||||
|
- Split extras plugins in a separate package
|
||||||
|
- Enable JACK support (in extras subpackage)
|
||||||
|
- Enable DirectFB support (in extras subpackage)
|
||||||
|
|
||||||
|
* Sat Nov 11 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.1.2-18
|
||||||
|
- Make shn files available to amarok. References:
|
||||||
|
http://xine.cvs.sourceforge.net/xine/xine-lib/src/demuxers/demux_shn.c?r1=1.1.2.2&r2=1.2
|
||||||
|
https://launchpad.net/distros/ubuntu/+source/xine-lib/+bug/63130
|
||||||
|
|
||||||
* Wed Oct 18 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.1.2-17
|
* Wed Oct 18 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.1.2-17
|
||||||
- cleanup docs
|
- cleanup docs
|
||||||
- remove mms
|
- remove mms
|
||||||
|
Loading…
Reference in New Issue
Block a user