Sync with F-8

This commit is contained in:
Ville Skyttä 2008-01-20 19:07:46 +00:00
parent f8aac472c0
commit fd87c53b26
2 changed files with 25 additions and 1 deletions

View File

@ -0,0 +1,19 @@
http://thread.gmane.org/gmane.comp.video.xine.devel/17682
diff -up xine-lib-1.1.9.1/src/xine-engine/audio_out.c~ xine-lib-1.1.9.1/src/xine-engine/audio_out.c
--- xine-lib-1.1.9.1/src/xine-engine/audio_out.c~ 2008-01-01 15:30:09.000000000 +0200
+++ xine-lib-1.1.9.1/src/xine-engine/audio_out.c 2008-01-20 11:46:40.000000000 +0200
@@ -1612,11 +1612,13 @@ static void ao_close(xine_audio_port_t *
xprintf (this->xine, XINE_VERBOSITY_DEBUG, "audio_out: no streams left, closing driver\n");
if (this->audio_loop_running) {
+#if 0
if (this->clock->speed == XINE_SPEED_PAUSE ||
(this->clock->speed != XINE_FINE_SPEED_NORMAL && !this->slow_fast_audio)) {
/* discard buffers, otherwise we'll wait forever */
ao_set_property(this_gen, AO_PROP_DISCARD_BUFFERS, 1);
}
+#endif
/* make sure there are no more buffers on queue */
fifo_wait_empty(this->out_fifo);
}

View File

@ -33,7 +33,7 @@
Summary: Xine library
Name: xine-lib
Version: 1.1.9.1
Release: 1%{?dist}
Release: 2%{?dist}
License: GPLv2+
Group: System Environment/Libraries
URL: http://xinehq.de/
@ -46,6 +46,7 @@ Source2: %{name}-mk-autotools-patch.sh
# autotools patch created with source2
Patch0: %{name}-%{version}-autotools.patch.bz2
Patch1: %{name}-1.1.4-optflags.patch
Patch2: %{name}-1.1.9.1-aoclose-429182.patch
Patch6: %{name}-1.1.1-deepbind-939.patch
Patch7: %{name}-1.1.5-multilib-devel.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -161,6 +162,7 @@ touch -r configure.ac aclocal.m4
touch -r m4/optimizations.m4 m4/optimizations.m4.stamp
%patch1 -p1 -b .optflags
touch -r m4/optimizations.m4.stamp m4/optimizations.m4
%patch2 -p1 -b .aoclose
# Patch6 needed at least when compiling with external ffmpeg, #939.
%patch6 -p1 -b .deepbind
%patch7 -p0 -b .multilib-devel
@ -386,6 +388,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sun Jan 20 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.1.9.1-2
- Disable upstream "discard buffers on ao close" 1.1.9 changeset (#429182).
* Sat Jan 12 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.1.9.1-1
- 1.1.9.1 (security update).