* Sun Jan 27 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.1.10-1

- 1.1.10 (security update).
This commit is contained in:
Ville Skyttä 2008-01-26 23:21:08 +00:00
parent 8c6bd6c4bc
commit ad1f32bcf4
5 changed files with 9 additions and 72 deletions

View File

@ -1,2 +1,2 @@
xine-lib-1.1.9.1-pruned.tar.bz2 xine-lib-1.1.10-pruned.tar.bz2
xine-lib-1.1.9.1-autotools.patch.bz2 xine-lib-1.1.10-autotools.patch.bz2

View File

@ -1,2 +1,2 @@
012fbd83dec565a06697426620baf21e xine-lib-1.1.9.1-pruned.tar.bz2 38b23253ba2fff335bb41cf8d7e87afe xine-lib-1.1.10-pruned.tar.bz2
fae182d050b231fff79eddf335b9a618 xine-lib-1.1.9.1-autotools.patch.bz2 823ca0360094a627857a303e069f5439 xine-lib-1.1.10-autotools.patch.bz2

View File

@ -1,40 +0,0 @@
--- misc/xine-config.in~ 2007-04-05 01:18:00.000000000 +0300
+++ misc/xine-config.in 2007-04-11 01:32:44.000000000 +0300
@@ -2,8 +2,8 @@
#
#
-prefix=@XINE_CONFIG_PREFIX@
-exec_prefix=@exec_prefix@
+prefix=$(pkg-config libxine --variable=prefix)
+exec_prefix=$(pkg-config libxine --variable=exec_prefix)
exec_prefix_set=no
usage()
@@ -54,7 +54,7 @@
echo_exec_prefix=yes
;;
--version)
- echo @XINE_MAJOR@.@XINE_MINOR@.@XINE_SUB@
+ pkg-config libxine --modversion
;;
--acflags)
echo_acflags=yes
@@ -100,14 +100,14 @@
fi
if test "$echo_cflags" = "yes"; then
- echo -I@includedir@ @PTHREAD_CFLAGS@
+ pkg-config libxine --cflags
fi
if test "$echo_libs" = "yes"; then
- echo -L@libdir@ -lxine @ZLIB_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@ @LIBICONV@ @RT_LIBS@
+ pkg-config libxine --libs
fi
if test "$echo_plugindir" = "yes"; then
- echo "@XINE_PLUGINPATH@"
+ echo "$(pkg-config libxine --variable=libdir)/xine/plugins/$(pkg-config libxine --modversion)"
fi
if test "$echo_datadir" = "yes"; then
echo "@XINE_DATADIR@"

View File

@ -1,19 +0,0 @@
http://thread.gmane.org/gmane.comp.video.xine.devel/17682
diff -up xine-lib-1.1.9.1/src/xine-engine/audio_out.c~ xine-lib-1.1.9.1/src/xine-engine/audio_out.c
--- xine-lib-1.1.9.1/src/xine-engine/audio_out.c~ 2008-01-01 15:30:09.000000000 +0200
+++ xine-lib-1.1.9.1/src/xine-engine/audio_out.c 2008-01-20 11:46:40.000000000 +0200
@@ -1612,11 +1612,13 @@ static void ao_close(xine_audio_port_t *
xprintf (this->xine, XINE_VERBOSITY_DEBUG, "audio_out: no streams left, closing driver\n");
if (this->audio_loop_running) {
+#if 0
if (this->clock->speed == XINE_SPEED_PAUSE ||
(this->clock->speed != XINE_FINE_SPEED_NORMAL && !this->slow_fast_audio)) {
/* discard buffers, otherwise we'll wait forever */
ao_set_property(this_gen, AO_PROP_DISCARD_BUFFERS, 1);
}
+#endif
/* make sure there are no more buffers on queue */
fifo_wait_empty(this->out_fifo);
}

View File

@ -32,8 +32,8 @@
Summary: Xine library Summary: Xine library
Name: xine-lib Name: xine-lib
Version: 1.1.9.1 Version: 1.1.10
Release: 3%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://xinehq.de/ URL: http://xinehq.de/
@ -46,9 +46,7 @@ Source2: %{name}-mk-autotools-patch.sh
# autotools patch created with source2 # autotools patch created with source2
Patch0: %{name}-%{version}-autotools.patch.bz2 Patch0: %{name}-%{version}-autotools.patch.bz2
Patch1: %{name}-1.1.4-optflags.patch Patch1: %{name}-1.1.4-optflags.patch
Patch2: %{name}-1.1.9.1-aoclose-429182.patch
Patch6: %{name}-1.1.1-deepbind-939.patch Patch6: %{name}-1.1.1-deepbind-939.patch
Patch7: %{name}-1.1.5-multilib-devel.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# X11 # X11
BuildRequires: libX11-devel libXv-devel libXinerama-devel libXvMC-devel BuildRequires: libX11-devel libXv-devel libXinerama-devel libXvMC-devel
@ -162,17 +160,12 @@ touch -r configure.ac aclocal.m4
touch -r m4/optimizations.m4 m4/optimizations.m4.stamp touch -r m4/optimizations.m4 m4/optimizations.m4.stamp
%patch1 -p1 -b .optflags %patch1 -p1 -b .optflags
touch -r m4/optimizations.m4.stamp m4/optimizations.m4 touch -r m4/optimizations.m4.stamp m4/optimizations.m4
%patch2 -p1 -b .aoclose
# Patch6 needed at least when compiling with external ffmpeg, #939. # Patch6 needed at least when compiling with external ffmpeg, #939.
%patch6 -p1 -b .deepbind %patch6 -p1 -b .deepbind
%patch7 -p0 -b .multilib-devel
# Avoid standard rpaths on lib64 archs: # Avoid standard rpaths on lib64 archs:
sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure
# Quick and dirty fix for #429487, check if still needed in > 1.1.9.1:
sed -i -e 's/^\(Version:\s*\).*/\1%{version}/i' misc/libxine.pc.in
%build %build
export FFMPEG_CFLAGS=" " FFMPEG_LIBS=" " export FFMPEG_CFLAGS=" " FFMPEG_LIBS=" "
@ -391,6 +384,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Sun Jan 27 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.1.10-1
- 1.1.10 (security update).
* Mon Jan 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.1.9.1-3 * Mon Jan 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.1.9.1-3
- Fix version number in libxine.pc (#429487). - Fix version number in libxine.pc (#429487).