* Wed Jan 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.16-1
- xine-lib-1.1.16, plugin ABI 1.25 - --with-external-libdvdnav, include demuxers (#213597)
This commit is contained in:
parent
d04f6398a2
commit
81d11ef2fd
@ -1,2 +1,2 @@
|
||||
xine-lib-1.1.15-autotools.patch.bz2
|
||||
xine-lib-1.1.15-pruned.tar.bz2
|
||||
xine-lib-1.1.16-autotools.patch.bz2
|
||||
xine-lib-1.1.16-pruned.tar.bz2
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
ffd74ec893a5f1167c69987a68f436fd xine-lib-1.1.15-autotools.patch.bz2
|
||||
acdbdc024382afac111eb076304448ed xine-lib-1.1.15-pruned.tar.bz2
|
||||
5caed155987cd453b6e23b8720dfbd3d xine-lib-1.1.16-autotools.patch.bz2
|
||||
512f31d8414ef4654ca366c0dce37301 xine-lib-1.1.16-pruned.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up xine-lib-1.1.15/src/xine-engine/buffer.h.ansi xine-lib-1.1.15/src/xine-engine/buffer.h
|
||||
--- xine-lib-1.1.15/src/xine-engine/buffer.h.ansi 2008-07-16 16:01:56.000000000 -0500
|
||||
+++ xine-lib-1.1.15/src/xine-engine/buffer.h 2008-08-19 12:08:46.000000000 -0500
|
||||
@@ -676,7 +676,7 @@ void _x_bmiheader_le2me( xine_bmiheader
|
||||
/* convert xine_waveformatex struct from little endian */
|
||||
void _x_waveformatex_le2me( xine_waveformatex *wavex ) XINE_PROTECTED;
|
||||
|
||||
-static inline _x_is_fourcc(void *ptr, void *tag) {
|
||||
+static __inline _x_is_fourcc(void *ptr, void *tag) {
|
||||
return memcmp(ptr, tag, 4) == 0;
|
||||
}
|
||||
|
@ -56,11 +56,12 @@ for p in dvd vcd mms; do
|
||||
sed -i -e "/xineplug_inp_$p/d" src/input/Makefile.am
|
||||
done
|
||||
# Demuxers
|
||||
for p in mpeg mpeg_block mpeg_ts mpeg_elem mpeg_pes yuv4mpeg2; do
|
||||
echo "removing $p demuxer..."
|
||||
[ -f src/demuxers/demux_$p.c ] && rm -f src/demuxers/demux_$p.c
|
||||
sed -i -e "/xineplug_dmx_$p/d" src/demuxers/Makefile.am
|
||||
done
|
||||
# These are ok now ( http://bugzilla.redhat.com/213597 )
|
||||
#for p in mpeg mpeg_block mpeg_ts mpeg_elem mpeg_pes yuv4mpeg2; do
|
||||
# echo "removing $p demuxer..."
|
||||
# [ -f src/demuxers/demux_$p.c ] && rm -f src/demuxers/demux_$p.c
|
||||
# sed -i -e "/xineplug_dmx_$p/d" src/demuxers/Makefile.am
|
||||
#done
|
||||
# Postprocessors
|
||||
echo "removing planar and deinterlace postprocessors..."
|
||||
sed -i -e 's/deinterlace //g' src/post/Makefile.am # see comments in speedy.c
|
||||
|
@ -2,10 +2,9 @@
|
||||
# - libstk: http://www.libstk.net/ - probably not, see 1.1.5 ChangeLog
|
||||
# - drop the opengl video out plugin?
|
||||
# http://www.redhat.com/archives/fedora-legal-list/2007-August/msg00011.html
|
||||
# - external dvdnav - not compatible as of 1.1.11 and 4.1.1
|
||||
# - deprecate ESD support?
|
||||
|
||||
%define abiver 1.24
|
||||
%define abiver 1.25
|
||||
%define codecdir %{_libdir}/codecs
|
||||
|
||||
%ifarch %{ix86}
|
||||
@ -32,8 +31,8 @@
|
||||
|
||||
Summary: Xine library
|
||||
Name: xine-lib
|
||||
Version: 1.1.15
|
||||
Release: 4%{?dist}
|
||||
Version: 1.1.16
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://xinehq.de/
|
||||
@ -50,8 +49,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Patch1: %{name}-1.1.4-optflags.patch
|
||||
Patch6: %{name}-1.1.1-deepbind-939.patch
|
||||
## upstream patches
|
||||
# phonon-xine doesn't compile with xine-lib-1.1.15, http://bugs.kde.org/169365
|
||||
Patch100: xine-lib-1.1.15-ansi.patch
|
||||
|
||||
Provides: xine-lib(plugin-abi) = %{abiver}
|
||||
# X11
|
||||
@ -111,6 +108,7 @@ BuildRequires: libsmbclient-devel
|
||||
%else
|
||||
BuildRequires: samba-common
|
||||
%endif
|
||||
BuildRequires: libdvdnav-devel
|
||||
|
||||
%description
|
||||
This package contains the Xine library. Xine is a free multimedia player.
|
||||
@ -191,10 +189,8 @@ touch -r m4/optimizations.m4.stamp m4/optimizations.m4
|
||||
# Patch6 needed at least when compiling with external ffmpeg, #939.
|
||||
%patch6 -p1 -b .deepbind
|
||||
|
||||
%patch100 -p1 -b .ansi
|
||||
|
||||
# Avoid standard rpaths on lib64 archs:
|
||||
sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure
|
||||
# Avoid standard rpaths on lib64 archs: (autotools patch should handle this, no? -- Rex )
|
||||
#sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure
|
||||
|
||||
|
||||
%build
|
||||
@ -223,6 +219,7 @@ export SDL_CFLAGS="$(sdl-config --cflags)" SDL_LIBS="$(sdl-config --libs)"
|
||||
--with-external-ffmpeg \
|
||||
--with-xv-path=%{_libdir} \
|
||||
--with-libflac \
|
||||
--with-external-libdvdnav \
|
||||
--with-external-libmpcdec \
|
||||
%if 0%{?_without_imagemagick:1}
|
||||
--without-imagemagick \
|
||||
@ -418,6 +415,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.16-1
|
||||
- xine-lib-1.1.16, plugin ABI 1.25
|
||||
- --with-external-libdvdnav, include demuxers (#213597)
|
||||
|
||||
* Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.1.15-4
|
||||
- rebuild for pkgconfig deps
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user