* Wed Apr 11 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.5-1
- 1.1.5. - Include GSM 06.10 decoder (#228186). - Re-enable CACA support. * Sun Apr 8 2007 Ville Skyttä <ville.skytta at iki.fi> - Exclude vidix dir on systems that don't have vidix. - Specfile cleanups. * Mon Mar 26 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.4-4 - Add PulseAudio support (in -extras, #234035/Jost Diederichs). - Adjust Samba build dependencies to work for both <= and > FC6. - Add --with freetype and --with antialiasing build time options, default disabled, and an upstream patch for FreeType memory leak (#233194).
This commit is contained in:
parent
c001b55cac
commit
6f6ae7910b
@ -1,2 +1,2 @@
|
||||
xine-lib-1.1.4-pruned.tar.bz2
|
||||
xine-lib-1.1.4-autotools.patch.bz2
|
||||
xine-lib-1.1.5-pruned.tar.bz2
|
||||
xine-lib-1.1.5-autotools.patch.bz2
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
81faabf1e38abed44639dbe4c76719f9 xine-lib-1.1.4-pruned.tar.bz2
|
||||
a916758545ed73a369f40648c7bc449c xine-lib-1.1.4-autotools.patch.bz2
|
||||
f903a0426a812ea70200b7a528f67b00 xine-lib-1.1.5-pruned.tar.bz2
|
||||
f955ece2fba4dfbbf22fbb2a8376ae60 xine-lib-1.1.5-autotools.patch.bz2
|
||||
|
@ -1,16 +0,0 @@
|
||||
Index: src/libflac/decoder_flac.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/xine/xine-lib/src/libflac/decoder_flac.c,v
|
||||
retrieving revision 1.22
|
||||
diff -u -r1.22 decoder_flac.c
|
||||
--- src/libflac/decoder_flac.c 25 Dec 2006 19:22:00 -0000 1.22
|
||||
+++ src/libflac/decoder_flac.c 3 Jan 2007 19:58:07 -0000
|
||||
@@ -363,7 +363,7 @@
|
||||
|
||||
FLAC__stream_decoder_set_client_data (this->flac_decoder, this);
|
||||
|
||||
- if (FLAC__stream_decoder_init (this->flac_decoder) == FLAC__STREAM_DECODER_SEARCH_FOR_METADATA) {
|
||||
+ if (FLAC__stream_decoder_init (this->flac_decoder) != FLAC__STREAM_DECODER_SEARCH_FOR_METADATA) {
|
||||
free (this);
|
||||
return NULL;
|
||||
}
|
@ -1,40 +0,0 @@
|
||||
---------------------
|
||||
PatchSet 8656
|
||||
Date: 2007/03/10 02:41:34
|
||||
Author: dgp85
|
||||
Branch: HEAD
|
||||
Tag: (none)
|
||||
Log:
|
||||
* Security fixes:
|
||||
- Fix heap overflow in DMO loader. (CVE-2007-1246) [bug #1676925]
|
||||
Thanks to Kees Cook for reporting.
|
||||
|
||||
Members:
|
||||
ChangeLog:1.724->1.725
|
||||
src/libw32dll/DirectShow/DS_VideoDecoder.c:1.9->1.10
|
||||
src/libw32dll/dmo/DMO_VideoDecoder.c:1.4->1.5
|
||||
|
||||
Index: xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c
|
||||
diff -u xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c:1.9 xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c:1.10
|
||||
--- xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c:1.9 Wed Dec 24 16:55:36 2003
|
||||
+++ xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c Sat Mar 10 00:41:34 2007
|
||||
@@ -110,6 +110,7 @@
|
||||
|
||||
this->iv.m_bh = (BITMAPINFOHEADER*)malloc(bihs);
|
||||
memcpy(this->iv.m_bh, format, bihs);
|
||||
+ this->iv.m_bh->biSize = bihs;
|
||||
|
||||
this->iv.m_State = STOP;
|
||||
//this->iv.m_pFrame = 0;
|
||||
Index: xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c
|
||||
diff -u xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c:1.4 xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c:1.5
|
||||
--- xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c:1.4 Wed Dec 24 16:55:36 2003
|
||||
+++ xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c Sat Mar 10 00:41:34 2007
|
||||
@@ -118,6 +118,7 @@
|
||||
|
||||
this->iv.m_bh = (BITMAPINFOHEADER*)malloc(bihs);
|
||||
memcpy(this->iv.m_bh, format, bihs);
|
||||
+ this->iv.m_bh->biSize = bihs;
|
||||
|
||||
this->iv.m_State = STOP;
|
||||
//this->iv.m_pFrame = 0;
|
@ -1,5 +1,5 @@
|
||||
--- misc/xine-config.in~ 2005-09-05 20:02:57.000000000 +0300
|
||||
+++ misc/xine-config.in 2006-06-13 01:43:55.000000000 +0300
|
||||
--- misc/xine-config.in~ 2007-04-05 01:18:00.000000000 +0300
|
||||
+++ misc/xine-config.in 2007-04-11 01:32:44.000000000 +0300
|
||||
@@ -2,8 +2,8 @@
|
||||
#
|
||||
#
|
||||
@ -24,12 +24,12 @@
|
||||
fi
|
||||
|
||||
if test "$echo_cflags" = "yes"; then
|
||||
- echo -I@includedir@ @THREAD_CPPFLAGS@
|
||||
- echo -I@includedir@ @PTHREAD_CFLAGS@
|
||||
+ pkg-config libxine --cflags
|
||||
fi
|
||||
|
||||
if test "$echo_libs" = "yes"; then
|
||||
- echo -L@libdir@ -lxine @ZLIB_LIBS@ @NET_LIBS@ @THREAD_LIBS@ @LIBICONV@ @RT_LIBS@
|
||||
- echo -L@libdir@ -lxine @ZLIB_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@ @LIBICONV@ @RT_LIBS@
|
||||
+ pkg-config libxine --libs
|
||||
fi
|
||||
if test "$echo_plugindir" = "yes"; then
|
24
xine-lib-1.1.5-pthread-check.patch
Normal file
24
xine-lib-1.1.5-pthread-check.patch
Normal file
@ -0,0 +1,24 @@
|
||||
Upstream changeset 8743:defc4f072bde + additional fix in fakethread().
|
||||
|
||||
diff -r d1512848e87b -r defc4f072bde m4/pthreads.m4
|
||||
--- a/m4/pthreads.m4 Tue Apr 10 17:08:22 2007 +0100
|
||||
+++ b/m4/pthreads.m4 Wed Apr 11 17:32:13 2007 +0200
|
||||
@@ -36,11 +36,15 @@ AC_DEFUN([CC_PTHREAD_FLAGS], [
|
||||
[ac_save_CFLAGS="$CFLAGS"
|
||||
ac_save_LIBS="$LIBS"
|
||||
CFLAGS="$CFLAGS $cc_cv_werror $PTHREAD_CFLAGS"
|
||||
+
|
||||
LIBS="$LIBS $PTHREAD_LIBS"
|
||||
- AC_COMPILE_IFELSE(
|
||||
+ AC_LINK_IFELSE(
|
||||
[AC_LANG_PROGRAM(
|
||||
- [[#include <pthread.h>]],
|
||||
- [[pthread_create(NULL, NULL, NULL, NULL);]]
|
||||
+ [[#include <pthread.h>
|
||||
+ void *fakethread(void *arg) { return NULL; }
|
||||
+ pthread_t fakevariable;
|
||||
+ ]],
|
||||
+ [[pthread_create(&fakevariable, NULL, &fakethread, NULL);]]
|
||||
)],
|
||||
[cc_cv_pthreads=yes],
|
||||
[cc_cv_pthreads=no])
|
@ -6,7 +6,7 @@ if [ -z "$1" -o $# -ne 1 ]; then
|
||||
fi
|
||||
|
||||
version=$1
|
||||
tarball="xine-lib-$version.tar.gz"
|
||||
tarball="xine-lib-$version.tar.bz2"
|
||||
dir="xine-lib-$version"
|
||||
modtarball="xine-lib-$version-pruned.tar.bz2"
|
||||
|
||||
@ -18,11 +18,11 @@ fi
|
||||
|
||||
echo "Uncompressing $tarball..."
|
||||
rm -rf $dir
|
||||
tar -xzf $tarball
|
||||
tar -xjf $tarball
|
||||
cd $dir
|
||||
|
||||
# Main libraries
|
||||
for remove in libfaad libffmpeg libmad libmpeg2 dxr3 libspudec libxineadec libspucmml libspucc liba52 libdts; do
|
||||
for remove in libfaad libffmpeg libmad libmpeg2 dxr3 libspudec libspucmml libspucc liba52 libdts; do
|
||||
echo "removing src/$remove..."
|
||||
rm -rf src/$remove
|
||||
sed -i -e "/$remove/d" src/Makefile.am
|
||||
@ -53,8 +53,20 @@ for p in mpeg mpeg_block mpeg_ts mpeg_elem mpeg_pes yuv4mpeg2; do
|
||||
[ -f src/demuxers/demux_$p.c ] && rm -f src/demuxers/demux_$p.c
|
||||
sed -i -e "/xineplug_dmx_$p/d" src/demuxers/Makefile.am
|
||||
done
|
||||
# Postprocessors
|
||||
echo "removing planar and deinterlace postprocessors..."
|
||||
sed -i -e 's/planar//g;s/deinterlace//g' src/post/Makefile.am # fails to build
|
||||
sed -i -e 's/deinterlace //g' src/post/Makefile.am # see comments in speedy.c
|
||||
sed -i -e 's/planar //g' src/post/Makefile.am # requires libpostproc
|
||||
sed -i -e '/post\/\(deinterlace\|planar\)/d' configure.ac
|
||||
rm -rf src/post/{deinterlace,planar}
|
||||
# NSF decoder
|
||||
echo "removing NSF decoder..."
|
||||
rm -rf src/libxineadec/{nosefart,nsf.c}
|
||||
sed -i -e '/^xineplug_decode_nsf_la/,/^\s*$/d' \
|
||||
-e /xineplug_decode_nsf/d \
|
||||
-e 's/ nosefart//' \
|
||||
src/libxineadec/Makefile.am
|
||||
sed -i -e /nosefart/d configure.ac
|
||||
|
||||
# All clean !
|
||||
|
||||
|
@ -11,11 +11,19 @@ fi
|
||||
|
||||
version=$1
|
||||
|
||||
# missing dependency on autoconf >= (apparently) 2.61 in upstream autofoo files
|
||||
acversion="$(rpm -q --qf=%{VERSION} autoconf)"
|
||||
case $acversion in
|
||||
2.6*) ;;
|
||||
*) echo "ERROR: autoconf >= 2.61 required" ; exit 1 ;;
|
||||
esac
|
||||
|
||||
rm -rf xine-lib-$version xine-lib-$version-pruned
|
||||
tar jxf xine-lib-$version-pruned.tar.bz2
|
||||
cp -a xine-lib-$version xine-lib-$version-pruned
|
||||
|
||||
cd xine-lib-$version
|
||||
patch -p1 < ../xine-lib-$version-pthread-check.patch # XXX hopefully temporary
|
||||
./autogen.sh noconfig
|
||||
rm -rf autom4te.cache *~
|
||||
cd ..
|
||||
|
214
xine-lib.spec
214
xine-lib.spec
@ -1,14 +1,18 @@
|
||||
# TODO, sometime, maybe:
|
||||
# - libstk: http://www.libstk.net/
|
||||
# - pulseaudio
|
||||
# - --enable-antialiasing?
|
||||
# - libstk: http://www.libstk.net/ - probably not, see 1.1.5 ChangeLog
|
||||
# - xcb stuff when it's available
|
||||
|
||||
%define codecdir %{_libdir}/codecs
|
||||
%ifarch %{ix86}
|
||||
%define have_vidix 1
|
||||
%else
|
||||
%define have_vidix 0
|
||||
%endif
|
||||
|
||||
Summary: Xine library
|
||||
Name: xine-lib
|
||||
Version: 1.1.4
|
||||
Release: 3%{?dist}
|
||||
Version: 1.1.5
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Libraries
|
||||
URL: http://xinehq.de/
|
||||
@ -19,35 +23,39 @@ Source0: %{name}-%{version}-pruned.tar.bz2
|
||||
Source1: %{name}-cleanup-sources.sh
|
||||
Source2: %{name}-mk-autotools-patch.sh
|
||||
# autotools patch created with source2
|
||||
Patch0: %{name}-1.1.4-autotools.patch.bz2
|
||||
Patch0: %{name}-1.1.5-autotools.patch.bz2
|
||||
Patch1: %{name}-1.1.4-optflags.patch
|
||||
Patch2: %{name}-1.1.4-CVE-2007-1246.patch
|
||||
Patch3: %{name}-1.1.3-legacy-flac-init.patch
|
||||
# Patch2 applied while creating full autotools patch
|
||||
Patch2: %{name}-1.1.5-pthread-check.patch
|
||||
Patch6: %{name}-1.1.1-deepbind-939.patch
|
||||
Patch7: %{name}-1.1.1-multilib-devel.patch
|
||||
Patch7: %{name}-1.1.5-multilib-devel.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# X11
|
||||
BuildRequires: libX11-devel libXv-devel libXinerama-devel libXvMC-devel libGLU-devel
|
||||
# Video
|
||||
BuildRequires: freetype-devel SDL-devel libtheora-devel libmng-devel
|
||||
BuildRequires: SDL-devel libtheora-devel libmng-devel
|
||||
BuildRequires: aalib-devel >= 1.4
|
||||
%if 0%{?_with_caca:1}
|
||||
BuildRequires: libcaca-devel >= 0.99
|
||||
%endif
|
||||
%if 0%{!?_without_directfb:1}
|
||||
BuildRequires: directfb-devel
|
||||
%endif
|
||||
%if 0%{!?_without_imagemagick:1}
|
||||
BuildRequires: ImageMagick-devel >= 6.2.4.6-1
|
||||
%endif
|
||||
%if 0%{?_with_freetype:1}
|
||||
BuildRequires: fontconfig-devel
|
||||
%endif
|
||||
# Audio
|
||||
BuildRequires: libogg-devel libvorbis-devel flac-devel libmodplug-devel
|
||||
BuildRequires: esound-devel speex-devel arts-devel alsa-lib-devel >= 0.9.0
|
||||
BuildRequires: jack-audio-connection-kit-devel wavpack-devel libmpcdec-devel
|
||||
BuildRequires: pulseaudio-lib-devel
|
||||
# CDs
|
||||
BuildRequires: libcdio-devel
|
||||
# Other
|
||||
BuildRequires: pkgconfig gnome-vfs2-devel gtk2-devel samba-common
|
||||
BuildRequires: pkgconfig gnome-vfs2-devel gtk2-devel
|
||||
# samba-common in <= FC-6, libsmbclient-devel in FC7+
|
||||
BuildRequires: %{_includedir}/libsmbclient.h
|
||||
|
||||
%package devel
|
||||
Summary: Xine library development files
|
||||
@ -69,7 +77,8 @@ interprets many of the most common multimedia formats available - and some
|
||||
of the most uncommon formats, too. Non-default rpmbuild options:
|
||||
--without imagemagick: Disable ImageMagick support
|
||||
--without directfb: Disable DirectFB support
|
||||
--with caca: Enable CACA support
|
||||
--with freetype: Enable FreeType/Fontconfig support
|
||||
--with antialiasing: Enable font antialiasing (with FreeType/FontConfig)
|
||||
|
||||
%description devel
|
||||
This package contains development files for xine-lib.
|
||||
@ -79,14 +88,13 @@ This package contains extra plugins for xine-lib:
|
||||
- aRts
|
||||
- EsounD
|
||||
- JACK
|
||||
- Pulseaudio
|
||||
- GDK-Pixbuf
|
||||
- GNOME VFS
|
||||
- SMB
|
||||
- SDL
|
||||
- AA-lib
|
||||
%if 0%{?_with_caca:1}
|
||||
- Libcaca
|
||||
%endif
|
||||
%if 0%{!?_without_imagemagick:1}
|
||||
- Image decoding
|
||||
%endif
|
||||
@ -102,15 +110,11 @@ This package contains extra plugins for xine-lib:
|
||||
touch -r configure.ac aclocal.m4
|
||||
touch -r m4/optimizations.m4 m4/optimizations.m4.stamp
|
||||
%patch1 -p1 -b .optflags
|
||||
%patch2 -p1 -b .CVE-2007-1246
|
||||
touch -r m4/optimizations.m4.stamp m4/optimizations.m4
|
||||
%patch3 -p0 -b .legacy-flac-init
|
||||
# Patch6 needed at least when compiling with external ffmpeg, #939.
|
||||
%patch6 -p1 -b .deepbind
|
||||
%patch7 -p0 -b .multilib-devel
|
||||
|
||||
find . -name "*.[hc]" | xargs chmod -c -x
|
||||
|
||||
# Avoid standard rpaths on lib64 archs:
|
||||
sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure
|
||||
|
||||
@ -133,8 +137,12 @@ export SDL_CFLAGS="$(sdl-config --cflags)" SDL_LIBS="$(sdl-config --libs)"
|
||||
%if 0%{?_without_imagemagick:1}
|
||||
--without-imagemagick \
|
||||
%endif
|
||||
%if 0%{!?_with_caca:1}
|
||||
--without-caca \
|
||||
%if 0%{?_with_freetype:1}
|
||||
--with-freetype \
|
||||
--with-fontconfig \
|
||||
%if 0%{?_with_antialiasing:1}
|
||||
--enable-antialiasing \
|
||||
%endif
|
||||
%endif
|
||||
--disable-libfame \
|
||||
--disable-faad \
|
||||
@ -174,7 +182,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files -f libxine1.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING CREDITS ChangeLog* README TODO
|
||||
%doc AUTHORS COPYING COPYING.LIB CREDITS ChangeLog* README TODO
|
||||
%doc __docs/README.* __docs/faq.*
|
||||
%dir %{codecdir}
|
||||
%{_datadir}/xine
|
||||
@ -183,72 +191,95 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_libdir}/xine/
|
||||
%dir %{_libdir}/xine/plugins/
|
||||
%dir %{_libdir}/xine/plugins/%{version}/
|
||||
# I list all the plugins because I don't want a non-free plugin
|
||||
# to sneak into a future version
|
||||
%{_libdir}/xine/plugins/%{version}/mime.types
|
||||
# Listing every plugin separately for better control over binary packages
|
||||
# containing exactly the plugins we want, nothing accidentally snuck in
|
||||
# nor dropped.
|
||||
%dir %{_libdir}/xine/plugins/%{version}/post/
|
||||
%{_libdir}/xine/plugins/%{version}/post/xineplug_post_audio_filters.so
|
||||
%{_libdir}/xine/plugins/%{version}/post/xineplug_post_goom.so
|
||||
%{_libdir}/xine/plugins/%{version}/post/xineplug_post_mosaico.so
|
||||
%{_libdir}/xine/plugins/%{version}/post/xineplug_post_switch.so
|
||||
%{_libdir}/xine/plugins/%{version}/post/xineplug_post_visualizations.so
|
||||
%if %{have_vidix}
|
||||
%dir %{_libdir}/xine/plugins/%{version}/vidix/
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/cyberblade_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/mach64_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/mga_crtc2_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/mga_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/nvidia_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/pm2_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/pm3_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/radeon_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/rage128_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/savage_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/sis_vid.so
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/unichrome_vid.so
|
||||
%endif
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_alsa.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_oss.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_none.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_fb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_file.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_none.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_opengl.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_syncfb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xshm.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_none.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_oss.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_bitplane.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_gsm610.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_lpcm.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_mpc.so
|
||||
%ifarch %ix86
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_qt.so
|
||||
%endif
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_real.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_rgb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_speex.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_spudvb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_sputext.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_theora.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_vorbis.so
|
||||
%ifarch %ix86
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_w32dll.so
|
||||
%endif
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_yuv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_audio.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_avi.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_fli.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_flv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_games.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_iff.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_image.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_matroska.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_mng.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_nsv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_ogg.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_pva.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_qt.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_rawdv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_real.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_slave.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_sputext.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_yuv_frames.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_flac.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_cdda.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_dvb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_v4l.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_file.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_http.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_net.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_pnm.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_cdda.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_stdin_fifo.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_rtsp.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_pvr.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_rtp.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_bitplane.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_rgb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_vorbis.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_yuv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_lpcm.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_real.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_real_audio.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_speex.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_theora.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_spudvb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_mpc.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_sputext.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_yuv_frames.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_real.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_audio.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_iff.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_avi.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_flv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_image.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_matroska.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_ogg.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_fli.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_nsv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_mng.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_pva.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_qt.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_rawdv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_sputext.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_games.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_dmx_slave.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_flac.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_wavpack.so
|
||||
%ifarch %ix86
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_rtsp.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_stdin_fifo.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_v4l.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_fb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_none.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_opengl.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_syncfb.so
|
||||
%if %{have_vidix}
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_vidix.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_qt.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_w32dll.so
|
||||
%endif
|
||||
%ifnarch ppc64 s390 s390x
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xxmc.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xshm.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xv.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xvmc.so
|
||||
%endif
|
||||
%{_libdir}/xine/plugins/%{version}/post/
|
||||
%{_libdir}/xine/plugins/%{version}/vidix/
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xxmc.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_wavpack.so
|
||||
|
||||
|
||||
%files extras
|
||||
@ -256,20 +287,19 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_arts.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_esd.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_jack.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_gnome_vfs.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_smb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_sdl.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_aa.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_pulseaudio.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_gdk_pixbuf.so
|
||||
%if 0%{?_with_caca:1}
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_caca.so
|
||||
%endif
|
||||
%if 0%{!?_without_imagemagick:1}
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_image.so
|
||||
%endif
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_gnome_vfs.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_smb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_aa.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_caca.so
|
||||
%if 0%{!?_without_directfb:1}
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_directfb.so
|
||||
%endif
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_sdl.so
|
||||
|
||||
|
||||
%files devel
|
||||
@ -284,8 +314,22 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man1/xine-config.1*
|
||||
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 11 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.5-1
|
||||
- 1.1.5.
|
||||
- Include GSM 06.10 decoder (#228186).
|
||||
- Re-enable CACA support.
|
||||
|
||||
* Sun Apr 8 2007 Ville Skyttä <ville.skytta at iki.fi>
|
||||
- Exclude vidix dir on systems that don't have vidix.
|
||||
- Specfile cleanups.
|
||||
|
||||
* Mon Mar 26 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.4-4
|
||||
- Add PulseAudio support (in -extras, #234035/Jost Diederichs).
|
||||
- Adjust Samba build dependencies to work for both <= and > FC6.
|
||||
- Add --with freetype and --with antialiasing build time options,
|
||||
default disabled, and an upstream patch for FreeType memory leak (#233194).
|
||||
|
||||
* Sat Mar 10 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.4-3
|
||||
- Apply upstream fix for CVE-2007-1246.
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user