* Wed Apr 11 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.5-1
- 1.1.5. - Include GSM 06.10 decoder (#228186). - Re-enable CACA support.
This commit is contained in:
parent
8a1dd4f6d7
commit
3d651b1200
@ -1,2 +1,2 @@
|
||||
xine-lib-1.1.4-pruned.tar.bz2
|
||||
xine-lib-1.1.4-autotools.patch.bz2
|
||||
xine-lib-1.1.5-pruned.tar.bz2
|
||||
xine-lib-1.1.5-autotools.patch.bz2
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
81faabf1e38abed44639dbe4c76719f9 xine-lib-1.1.4-pruned.tar.bz2
|
||||
a916758545ed73a369f40648c7bc449c xine-lib-1.1.4-autotools.patch.bz2
|
||||
f903a0426a812ea70200b7a528f67b00 xine-lib-1.1.5-pruned.tar.bz2
|
||||
f955ece2fba4dfbbf22fbb2a8376ae60 xine-lib-1.1.5-autotools.patch.bz2
|
||||
|
@ -1,16 +0,0 @@
|
||||
Index: src/libflac/decoder_flac.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/xine/xine-lib/src/libflac/decoder_flac.c,v
|
||||
retrieving revision 1.22
|
||||
diff -u -r1.22 decoder_flac.c
|
||||
--- src/libflac/decoder_flac.c 25 Dec 2006 19:22:00 -0000 1.22
|
||||
+++ src/libflac/decoder_flac.c 3 Jan 2007 19:58:07 -0000
|
||||
@@ -363,7 +363,7 @@
|
||||
|
||||
FLAC__stream_decoder_set_client_data (this->flac_decoder, this);
|
||||
|
||||
- if (FLAC__stream_decoder_init (this->flac_decoder) == FLAC__STREAM_DECODER_SEARCH_FOR_METADATA) {
|
||||
+ if (FLAC__stream_decoder_init (this->flac_decoder) != FLAC__STREAM_DECODER_SEARCH_FOR_METADATA) {
|
||||
free (this);
|
||||
return NULL;
|
||||
}
|
@ -1,40 +0,0 @@
|
||||
---------------------
|
||||
PatchSet 8656
|
||||
Date: 2007/03/10 02:41:34
|
||||
Author: dgp85
|
||||
Branch: HEAD
|
||||
Tag: (none)
|
||||
Log:
|
||||
* Security fixes:
|
||||
- Fix heap overflow in DMO loader. (CVE-2007-1246) [bug #1676925]
|
||||
Thanks to Kees Cook for reporting.
|
||||
|
||||
Members:
|
||||
ChangeLog:1.724->1.725
|
||||
src/libw32dll/DirectShow/DS_VideoDecoder.c:1.9->1.10
|
||||
src/libw32dll/dmo/DMO_VideoDecoder.c:1.4->1.5
|
||||
|
||||
Index: xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c
|
||||
diff -u xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c:1.9 xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c:1.10
|
||||
--- xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c:1.9 Wed Dec 24 16:55:36 2003
|
||||
+++ xine-lib/src/libw32dll/DirectShow/DS_VideoDecoder.c Sat Mar 10 00:41:34 2007
|
||||
@@ -110,6 +110,7 @@
|
||||
|
||||
this->iv.m_bh = (BITMAPINFOHEADER*)malloc(bihs);
|
||||
memcpy(this->iv.m_bh, format, bihs);
|
||||
+ this->iv.m_bh->biSize = bihs;
|
||||
|
||||
this->iv.m_State = STOP;
|
||||
//this->iv.m_pFrame = 0;
|
||||
Index: xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c
|
||||
diff -u xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c:1.4 xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c:1.5
|
||||
--- xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c:1.4 Wed Dec 24 16:55:36 2003
|
||||
+++ xine-lib/src/libw32dll/dmo/DMO_VideoDecoder.c Sat Mar 10 00:41:34 2007
|
||||
@@ -118,6 +118,7 @@
|
||||
|
||||
this->iv.m_bh = (BITMAPINFOHEADER*)malloc(bihs);
|
||||
memcpy(this->iv.m_bh, format, bihs);
|
||||
+ this->iv.m_bh->biSize = bihs;
|
||||
|
||||
this->iv.m_State = STOP;
|
||||
//this->iv.m_pFrame = 0;
|
@ -1,20 +0,0 @@
|
||||
--- src/xine-engine/osd.c 2007/02/20 00:34:58 1.84
|
||||
+++ src/xine-engine/osd.c 2007/03/03 22:59:37 1.86
|
||||
@@ -1481,7 +1481,16 @@
|
||||
while( osd ) {
|
||||
if ( osd == osd_to_close ) {
|
||||
free( osd->area );
|
||||
- if( osd->ft2 ) free( osd->ft2 );
|
||||
+
|
||||
+#ifdef HAVE_FT2
|
||||
+ if( osd->ft2 ) {
|
||||
+ if ( osd->ft2->library )
|
||||
+ FT_Done_FreeType(osd->ft2->library);
|
||||
+
|
||||
+ free( osd->ft2 );
|
||||
+ }
|
||||
+#endif
|
||||
+
|
||||
osd_free_encoding(osd);
|
||||
|
||||
if( last )
|
@ -1,5 +1,5 @@
|
||||
--- misc/xine-config.in~ 2005-09-05 20:02:57.000000000 +0300
|
||||
+++ misc/xine-config.in 2006-06-13 01:43:55.000000000 +0300
|
||||
--- misc/xine-config.in~ 2007-04-05 01:18:00.000000000 +0300
|
||||
+++ misc/xine-config.in 2007-04-11 01:32:44.000000000 +0300
|
||||
@@ -2,8 +2,8 @@
|
||||
#
|
||||
#
|
||||
@ -24,12 +24,12 @@
|
||||
fi
|
||||
|
||||
if test "$echo_cflags" = "yes"; then
|
||||
- echo -I@includedir@ @THREAD_CPPFLAGS@
|
||||
- echo -I@includedir@ @PTHREAD_CFLAGS@
|
||||
+ pkg-config libxine --cflags
|
||||
fi
|
||||
|
||||
if test "$echo_libs" = "yes"; then
|
||||
- echo -L@libdir@ -lxine @ZLIB_LIBS@ @NET_LIBS@ @THREAD_LIBS@ @LIBICONV@ @RT_LIBS@
|
||||
- echo -L@libdir@ -lxine @ZLIB_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@ @LIBICONV@ @RT_LIBS@
|
||||
+ pkg-config libxine --libs
|
||||
fi
|
||||
if test "$echo_plugindir" = "yes"; then
|
24
xine-lib-1.1.5-pthread-check.patch
Normal file
24
xine-lib-1.1.5-pthread-check.patch
Normal file
@ -0,0 +1,24 @@
|
||||
Upstream changeset 8743:defc4f072bde + additional fix in fakethread().
|
||||
|
||||
diff -r d1512848e87b -r defc4f072bde m4/pthreads.m4
|
||||
--- a/m4/pthreads.m4 Tue Apr 10 17:08:22 2007 +0100
|
||||
+++ b/m4/pthreads.m4 Wed Apr 11 17:32:13 2007 +0200
|
||||
@@ -36,11 +36,15 @@ AC_DEFUN([CC_PTHREAD_FLAGS], [
|
||||
[ac_save_CFLAGS="$CFLAGS"
|
||||
ac_save_LIBS="$LIBS"
|
||||
CFLAGS="$CFLAGS $cc_cv_werror $PTHREAD_CFLAGS"
|
||||
+
|
||||
LIBS="$LIBS $PTHREAD_LIBS"
|
||||
- AC_COMPILE_IFELSE(
|
||||
+ AC_LINK_IFELSE(
|
||||
[AC_LANG_PROGRAM(
|
||||
- [[#include <pthread.h>]],
|
||||
- [[pthread_create(NULL, NULL, NULL, NULL);]]
|
||||
+ [[#include <pthread.h>
|
||||
+ void *fakethread(void *arg) { return NULL; }
|
||||
+ pthread_t fakevariable;
|
||||
+ ]],
|
||||
+ [[pthread_create(&fakevariable, NULL, &fakethread, NULL);]]
|
||||
)],
|
||||
[cc_cv_pthreads=yes],
|
||||
[cc_cv_pthreads=no])
|
@ -22,7 +22,7 @@ tar -xjf $tarball
|
||||
cd $dir
|
||||
|
||||
# Main libraries
|
||||
for remove in libfaad libffmpeg libmad libmpeg2 dxr3 libspudec libxineadec libspucmml libspucc liba52 libdts; do
|
||||
for remove in libfaad libffmpeg libmad libmpeg2 dxr3 libspudec libspucmml libspucc liba52 libdts; do
|
||||
echo "removing src/$remove..."
|
||||
rm -rf src/$remove
|
||||
sed -i -e "/$remove/d" src/Makefile.am
|
||||
@ -53,8 +53,20 @@ for p in mpeg mpeg_block mpeg_ts mpeg_elem mpeg_pes yuv4mpeg2; do
|
||||
[ -f src/demuxers/demux_$p.c ] && rm -f src/demuxers/demux_$p.c
|
||||
sed -i -e "/xineplug_dmx_$p/d" src/demuxers/Makefile.am
|
||||
done
|
||||
# Postprocessors
|
||||
echo "removing planar and deinterlace postprocessors..."
|
||||
sed -i -e 's/planar//g;s/deinterlace//g' src/post/Makefile.am # fails to build
|
||||
sed -i -e 's/deinterlace //g' src/post/Makefile.am # see comments in speedy.c
|
||||
sed -i -e 's/planar //g' src/post/Makefile.am # requires libpostproc
|
||||
sed -i -e '/post\/\(deinterlace\|planar\)/d' configure.ac
|
||||
rm -rf src/post/{deinterlace,planar}
|
||||
# NSF decoder
|
||||
echo "removing NSF decoder..."
|
||||
rm -rf src/libxineadec/{nosefart,nsf.c}
|
||||
sed -i -e '/^xineplug_decode_nsf_la/,/^\s*$/d' \
|
||||
-e /xineplug_decode_nsf/d \
|
||||
-e 's/ nosefart//' \
|
||||
src/libxineadec/Makefile.am
|
||||
sed -i -e /nosefart/d configure.ac
|
||||
|
||||
# All clean !
|
||||
|
||||
|
@ -11,11 +11,19 @@ fi
|
||||
|
||||
version=$1
|
||||
|
||||
# missing dependency on autoconf >= (apparently) 2.61 in upstream autofoo files
|
||||
acversion="$(rpm -q --qf=%{VERSION} autoconf)"
|
||||
case $acversion in
|
||||
2.6*) ;;
|
||||
*) echo "ERROR: autoconf >= 2.61 required" ; exit 1 ;;
|
||||
esac
|
||||
|
||||
rm -rf xine-lib-$version xine-lib-$version-pruned
|
||||
tar jxf xine-lib-$version-pruned.tar.bz2
|
||||
cp -a xine-lib-$version xine-lib-$version-pruned
|
||||
|
||||
cd xine-lib-$version
|
||||
patch -p1 < ../xine-lib-$version-pthread-check.patch # XXX hopefully temporary
|
||||
./autogen.sh noconfig
|
||||
rm -rf autom4te.cache *~
|
||||
cd ..
|
||||
|
@ -1,5 +1,6 @@
|
||||
# TODO, sometime, maybe:
|
||||
# - libstk: http://www.libstk.net/
|
||||
# - libstk: http://www.libstk.net/ - probably not, see 1.1.5 ChangeLog
|
||||
# - xcb stuff when it's available
|
||||
|
||||
%define codecdir %{_libdir}/codecs
|
||||
%ifarch %{ix86}
|
||||
@ -10,8 +11,8 @@
|
||||
|
||||
Summary: Xine library
|
||||
Name: xine-lib
|
||||
Version: 1.1.4
|
||||
Release: 4%{?dist}
|
||||
Version: 1.1.5
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Libraries
|
||||
URL: http://xinehq.de/
|
||||
@ -22,22 +23,19 @@ Source0: %{name}-%{version}-pruned.tar.bz2
|
||||
Source1: %{name}-cleanup-sources.sh
|
||||
Source2: %{name}-mk-autotools-patch.sh
|
||||
# autotools patch created with source2
|
||||
Patch0: %{name}-1.1.4-autotools.patch.bz2
|
||||
Patch0: %{name}-1.1.5-autotools.patch.bz2
|
||||
Patch1: %{name}-1.1.4-optflags.patch
|
||||
Patch2: %{name}-1.1.4-CVE-2007-1246.patch
|
||||
Patch3: %{name}-1.1.3-legacy-flac-init.patch
|
||||
Patch4: %{name}-1.1.4-ftfree.patch
|
||||
# Patch2 applied while creating full autotools patch
|
||||
Patch2: %{name}-1.1.5-pthread-check.patch
|
||||
Patch6: %{name}-1.1.1-deepbind-939.patch
|
||||
Patch7: %{name}-1.1.1-multilib-devel.patch
|
||||
Patch7: %{name}-1.1.5-multilib-devel.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# X11
|
||||
BuildRequires: libX11-devel libXv-devel libXinerama-devel libXvMC-devel libGLU-devel
|
||||
# Video
|
||||
BuildRequires: SDL-devel libtheora-devel libmng-devel
|
||||
BuildRequires: aalib-devel >= 1.4
|
||||
%if 0%{?_with_caca:1}
|
||||
BuildRequires: libcaca-devel >= 0.99
|
||||
%endif
|
||||
%if 0%{!?_without_directfb:1}
|
||||
BuildRequires: directfb-devel
|
||||
%endif
|
||||
@ -79,7 +77,6 @@ interprets many of the most common multimedia formats available - and some
|
||||
of the most uncommon formats, too. Non-default rpmbuild options:
|
||||
--without imagemagick: Disable ImageMagick support
|
||||
--without directfb: Disable DirectFB support
|
||||
--with caca: Enable CACA support
|
||||
--with freetype: Enable FreeType/Fontconfig support
|
||||
--with antialiasing: Enable font antialiasing (with FreeType/FontConfig)
|
||||
|
||||
@ -97,9 +94,7 @@ This package contains extra plugins for xine-lib:
|
||||
- SMB
|
||||
- SDL
|
||||
- AA-lib
|
||||
%if 0%{?_with_caca:1}
|
||||
- Libcaca
|
||||
%endif
|
||||
%if 0%{!?_without_imagemagick:1}
|
||||
- Image decoding
|
||||
%endif
|
||||
@ -115,16 +110,11 @@ This package contains extra plugins for xine-lib:
|
||||
touch -r configure.ac aclocal.m4
|
||||
touch -r m4/optimizations.m4 m4/optimizations.m4.stamp
|
||||
%patch1 -p1 -b .optflags
|
||||
%patch2 -p1 -b .CVE-2007-1246
|
||||
touch -r m4/optimizations.m4.stamp m4/optimizations.m4
|
||||
%patch3 -p0 -b .legacy-flac-init
|
||||
%patch4 -p0 -b .ftfree
|
||||
# Patch6 needed at least when compiling with external ffmpeg, #939.
|
||||
%patch6 -p1 -b .deepbind
|
||||
%patch7 -p0 -b .multilib-devel
|
||||
|
||||
find . -name "*.[hc]" | xargs chmod -c -x
|
||||
|
||||
# Avoid standard rpaths on lib64 archs:
|
||||
sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure
|
||||
|
||||
@ -147,9 +137,6 @@ export SDL_CFLAGS="$(sdl-config --cflags)" SDL_LIBS="$(sdl-config --libs)"
|
||||
%if 0%{?_without_imagemagick:1}
|
||||
--without-imagemagick \
|
||||
%endif
|
||||
%if 0%{!?_with_caca:1}
|
||||
--without-caca \
|
||||
%endif
|
||||
%if 0%{?_with_freetype:1}
|
||||
--with-freetype \
|
||||
--with-fontconfig \
|
||||
@ -195,7 +182,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files -f libxine1.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING CREDITS ChangeLog* README TODO
|
||||
%doc AUTHORS COPYING COPYING.LIB CREDITS ChangeLog* README TODO
|
||||
%doc __docs/README.* __docs/faq.*
|
||||
%dir %{codecdir}
|
||||
%{_datadir}/xine
|
||||
@ -204,6 +191,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_libdir}/xine/
|
||||
%dir %{_libdir}/xine/plugins/
|
||||
%dir %{_libdir}/xine/plugins/%{version}/
|
||||
%{_libdir}/xine/plugins/%{version}/mime.types
|
||||
# Listing every plugin separately for better control over binary packages
|
||||
# containing exactly the plugins we want, nothing accidentally snuck in
|
||||
# nor dropped.
|
||||
@ -233,13 +221,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_none.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_ao_out_oss.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_bitplane.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_gsm610.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_lpcm.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_mpc.so
|
||||
%ifarch %ix86
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_qt.so
|
||||
%endif
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_real.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_real_audio.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_rgb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_speex.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_decode_spudvb.so
|
||||
@ -307,9 +295,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_gnome_vfs.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_inp_smb.so
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_aa.so
|
||||
%if 0%{?_with_caca:1}
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_caca.so
|
||||
%endif
|
||||
%if 0%{!?_without_directfb:1}
|
||||
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_directfb.so
|
||||
%endif
|
||||
@ -329,6 +315,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 11 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.5-1
|
||||
- 1.1.5.
|
||||
- Include GSM 06.10 decoder (#228186).
|
||||
- Re-enable CACA support.
|
||||
|
||||
* Sun Apr 8 2007 Ville Skyttä <ville.skytta at iki.fi>
|
||||
- Exclude vidix dir on systems that don't have vidix.
|
||||
- Specfile cleanups.
|
||||
|
Loading…
Reference in New Issue
Block a user