* Thu Aug 30 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.8-1

- 1.1.8, "open" patch applied upstream.
- Build XCB plugins by default for Fedora 8+ only.
This commit is contained in:
Ville Skyttä 2007-09-01 09:19:38 +00:00
parent 9a9a9d19dc
commit 24a2b8df9f
4 changed files with 24 additions and 111 deletions

View File

@ -1,2 +1,2 @@
xine-lib-1.1.7-pruned.tar.bz2
xine-lib-1.1.7-autotools.patch.bz2
xine-lib-1.1.8-pruned.tar.bz2
xine-lib-1.1.8-autotools.patch.bz2

View File

@ -1,2 +1,2 @@
8f0714de28dab403288bbccf1a8c30c2 xine-lib-1.1.7-pruned.tar.bz2
6b7f1d168b8b367a8c7709db687c60f6 xine-lib-1.1.7-autotools.patch.bz2
6cbfae9d31fc138c7cb3c3d178e1286d xine-lib-1.1.8-pruned.tar.bz2
b4a7c7a9af428b26667402d6dc180107 xine-lib-1.1.8-autotools.patch.bz2

View File

@ -1,101 +0,0 @@
--- xine-lib-1.1.7/src/libxinevdec/image.c~ 2007-04-15 20:42:16.000000000 +0300
+++ xine-lib-1.1.7/src/libxinevdec/image.c 2007-08-14 00:40:05.000000000 +0300
@@ -81,7 +81,7 @@ static void image_decode_data (video_dec
if (!this->video_open) {
lprintf("opening video\n");
- this->stream->video_out->open(this->stream->video_out, this->stream);
+ (this->stream->video_out->open)(this->stream->video_out, this->stream);
this->video_open = 1;
}
--- xine-lib-1.1.7/src/libxinevdec/gdkpixbuf.c~ 2007-04-15 20:42:16.000000000 +0300
+++ xine-lib-1.1.7/src/libxinevdec/gdkpixbuf.c 2007-08-14 00:45:36.000000000 +0300
@@ -74,7 +74,7 @@ static void image_decode_data (video_dec
if (!this->video_open) {
lprintf("opening video\n");
- this->stream->video_out->open(this->stream->video_out, this->stream);
+ (this->stream->video_out->open)(this->stream->video_out, this->stream);
this->video_open = 1;
}
--- xine-lib-1.1.7/src/libxineadec/xine_lpcm_decoder.c~ 2007-04-17 04:00:50.000000000 +0300
+++ xine-lib-1.1.7/src/libxineadec/xine_lpcm_decoder.c 2007-08-14 00:50:49.000000000 +0300
@@ -134,12 +134,12 @@ static void lpcm_decode_data (audio_deco
/* force 24-bit samples into 16 bits for now */
if (this->bits_per_sample == 24)
- this->output_open = this->stream->audio_out->open (this->stream->audio_out, this->stream,
+ this->output_open = (this->stream->audio_out->open) (this->stream->audio_out, this->stream,
16,
this->rate,
this->ao_cap_mode) ;
else
- this->output_open = this->stream->audio_out->open (this->stream->audio_out, this->stream,
+ this->output_open = (this->stream->audio_out->open) (this->stream->audio_out, this->stream,
this->bits_per_sample,
this->rate,
this->ao_cap_mode) ;
--- xine-lib-1.1.7/src/xine-engine/audio_out.c~ 2007-06-05 00:37:38.000000000 +0300
+++ xine-lib-1.1.7/src/xine-engine/audio_out.c 2007-08-14 00:34:30.000000000 +0300
@@ -1401,7 +1401,7 @@ static int ao_change_settings(aos_t *thi
_("stereo not supported by driver, converting to mono.\n"));
}
- output_sample_rate=this->driver->open(this->driver,bits,(this->force_rate ? this->force_rate : rate),mode);
+ output_sample_rate=(this->driver->open)(this->driver,bits,(this->force_rate ? this->force_rate : rate),mode);
} else
output_sample_rate = this->input.rate;
--- xine-lib-1.1.7/src/xine-engine/xine.c~ 2007-05-06 17:20:54.000000000 +0300
+++ xine-lib-1.1.7/src/xine-engine/xine.c 2007-08-14 00:26:30.000000000 +0300
@@ -462,7 +462,7 @@ static int stream_rewire_audio(xine_post
if (stream->audio_out->status(stream->audio_out, stream, &bits, &rate, &mode)) {
/* register our stream at the new output port */
- new_port->open(new_port, stream, bits, rate, mode);
+ (new_port->open)(new_port, stream, bits, rate, mode);
stream->audio_out->close(stream->audio_out, stream);
}
stream->audio_out = new_port;
@@ -486,7 +486,7 @@ static int stream_rewire_video(xine_post
if (stream->video_out->status(stream->video_out, stream, &width, &height, &img_duration)) {
/* register our stream at the new output port */
- new_port->open(new_port, stream);
+ (new_port->open)(new_port, stream);
stream->video_out->close(stream->video_out, stream);
}
stream->video_out = new_port;
@@ -773,7 +773,7 @@ static int open_internal (xine_stream_t
_x_meta_info_set_utf8(stream, XINE_META_INFO_INPUT_PLUGIN,
(stream->input_plugin->input_class->get_identifier (stream->input_plugin->input_class)));
- res = stream->input_plugin->open(stream->input_plugin);
+ res = (stream->input_plugin->open)(stream->input_plugin);
switch(res) {
case 1: /* Open successfull */
free(input_source);
--- xine-lib-1.1.7/src/libreal/xine_real_audio_decoder.c~ 2007-04-17 04:00:50.000000000 +0300
+++ xine-lib-1.1.7/src/libreal/xine_real_audio_decoder.c 2007-08-14 01:00:32.000000000 +0300
@@ -339,7 +339,7 @@ static int init_codec (realdec_decoder_t
return 0;
}
- this->stream->audio_out->open(this->stream->audio_out,
+ (this->stream->audio_out->open)(this->stream->audio_out,
this->stream,
bits_per_sample,
samples_per_sec,
--- xine-lib-1.1.7/src/libreal/xine_real_video_decoder.c~ 2007-04-17 04:00:50.000000000 +0300
+++ xine-lib-1.1.7/src/libreal/xine_real_video_decoder.c 2007-08-14 00:54:52.000000000 +0300
@@ -268,7 +268,7 @@ static int init_codec (realdec_decoder_t
this->rvyuv_custom_message (&cmsg_data, this->context);
}
- this->stream->video_out->open(this->stream->video_out, this->stream);
+ (this->stream->video_out->open)(this->stream->video_out, this->stream);
this->frame_size = this->width * this->height;
this->frame_buffer = xine_xmalloc (this->width * this->height * 3 / 2);

View File

@ -13,11 +13,16 @@
%else
%define have_vidix 0
%endif
%if 0%{?fedora} >= 8
%define with_xcb 1
%else
%define with_xcb 0
%endif
Summary: Xine library
Name: xine-lib
Version: 1.1.7
Release: 3%{?dist}
Version: 1.1.8
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Libraries
URL: http://xinehq.de/
@ -30,13 +35,15 @@ Source2: %{name}-mk-autotools-patch.sh
# autotools patch created with source2
Patch0: %{name}-%{version}-autotools.patch.bz2
Patch1: %{name}-1.1.4-optflags.patch
Patch2: %{name}-1.1.7-open.patch
Patch6: %{name}-1.1.1-deepbind-939.patch
Patch7: %{name}-1.1.5-multilib-devel.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# X11
BuildRequires: libX11-devel libXv-devel libXinerama-devel libXvMC-devel
BuildRequires: libGLU-devel libxcb-devel
BuildRequires: libGLU-devel
%if %{with_xcb}
BuildRequires: libxcb-devel
%endif
# Video
BuildRequires: SDL-devel libtheora-devel libmng-devel
BuildRequires: aalib-devel >= 1.4
@ -114,7 +121,9 @@ This package contains extra plugins for xine-lib:
%if 0%{!?_without_directfb:1}
- DirectFB output
%endif
%if %{with_xcb}
- XCB output
%endif
%prep
@ -124,7 +133,6 @@ touch -r configure.ac aclocal.m4
touch -r m4/optimizations.m4 m4/optimizations.m4.stamp
%patch1 -p1 -b .optflags
touch -r m4/optimizations.m4.stamp m4/optimizations.m4
%patch2 -p1 -b .open
# Patch6 needed at least when compiling with external ffmpeg, #939.
%patch6 -p1 -b .deepbind
%patch7 -p0 -b .multilib-devel
@ -321,8 +329,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xdirectfb.so
%endif
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_sdl.so
%if %{with_xcb}
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xcbshm.so
%{_libdir}/xine/plugins/%{version}/xineplug_vo_out_xcbxv.so
%endif
%files devel
@ -338,6 +348,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Aug 30 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.1.8-1
- 1.1.8, "open" patch applied upstream.
- Build XCB plugins by default for Fedora 8+ only.
* Sat Aug 25 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.1.7-3
- Split the aRts plugin into its own subpackage