* Fri May 15 2009 Eric Sandeen <sandeen@redhat.com> 3.0.1-3

- Fix and re-enable readline
This commit is contained in:
Eric Sandeen 2009-05-16 01:48:32 +00:00
parent 88976ab108
commit 7aab75c830
2 changed files with 65 additions and 2 deletions

View File

@ -0,0 +1,55 @@
[PATCH] xfsprogs: fix readline/editline for xfs_io and xfs_quota
It looks like libxcmd wasn't ever being built with -DENABLE_READLINE
even when it was asked for by configure --enable-readline=yes
so xfs_io & xfs_quota didn't get the functionality.
This seems to fix it up for me (fixes editline too while we're
at it).
Signed-off-by: Eric Sandeen <sandeen@sandeen.net>
---
Index: xfsprogs-3.0.1/libxcmd/Makefile
===================================================================
--- xfsprogs-3.0.1.orig/libxcmd/Makefile
+++ xfsprogs-3.0.1/libxcmd/Makefile
@@ -20,6 +20,14 @@ ifeq ($(HAVE_GETMNTINFO),yes)
LCFLAGS += -DHAVE_GETMNTINFO
endif
+ifeq ($(ENABLE_READLINE),yes)
+LCFLAGS += -DENABLE_READLINE
+endif
+
+ifeq ($(ENABLE_EDITLINE),yes)
+LCFLAGS += -DENABLE_EDITLINE
+endif
+
default: $(LTLIBRARY)
include $(BUILDRULES)
Index: xfsprogs-3.0.1/growfs/Makefile
===================================================================
--- xfsprogs-3.0.1.orig/growfs/Makefile
+++ xfsprogs-3.0.1/growfs/Makefile
@@ -10,6 +10,14 @@ LTCOMMAND = xfs_growfs
CFILES = xfs_growfs.c
LLDLIBS = $(LIBXFS) $(LIBXCMD) $(LIBUUID) $(LIBRT) $(LIBPTHREAD)
+ifeq ($(ENABLE_READLINE),yes)
+LLDLIBS += $(LIBREADLINE) $(LIBTERMCAP)
+endif
+
+ifeq ($(ENABLE_EDITLINE),yes)
+LLDLIBS += $(LIBEDITLINE) $(LIBTERMCAP)
+endif
+
LTDEPENDENCIES = $(LIBXFS) $(LIBXCMD)
LLDFLAGS = -static
LSRCFILES = xfs_info.sh

View File

@ -1,7 +1,7 @@
Summary: Utilities for managing the XFS filesystem
Name: xfsprogs
Version: 3.0.1
Release: 2%{?dist}
Release: 3%{?dist}
# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
# in source, with no mention of version.
# doc/COPYING file specifies what is GPL and what is LGPL
@ -18,6 +18,8 @@ Provides: xfs-cmds
Obsoletes: xfs-cmds <= %{version}
Conflicts: xfsdump < 3.0.1
Patch0: xfsprogs-3.0.1-readline.patch
%description
A set of commands to use the XFS filesystem, including mkfs.xfs.
@ -61,6 +63,8 @@ in building or running the xfstests QA suite.
%prep
%setup -q
%patch0 -p1
%build
export tagname=CC DEBUG=-DNDEBUG
# xfsprogs abuses libexecdir
@ -68,7 +72,8 @@ export tagname=CC DEBUG=-DNDEBUG
--sbindir=/sbin \
--libdir=/%{_lib} \
--libexecdir=%{_libdir} \
--bindir=%{_sbindir}
--bindir=%{_sbindir} \
--enable-readline=yes
make %{?_smp_mflags}
@ -185,6 +190,9 @@ rm -rf $RPM_BUILD_ROOT
%{_includedir}/xfs/xfs_types.h
%changelog
* Fri May 15 2009 Eric Sandeen <sandeen@redhat.com> 3.0.1-3
- Fix and re-enable readline
* Tue May 05 2009 Eric Sandeen <sandeen@redhat.com> 3.0.1-2
- Conflict with xfsdump < 3.0.1 since files moved between them