Newer versions of ICU requires C++17
The patch is from https://bugs.gentoo.org/934471 Alternative would be to compile without ICU. Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
12a0a5d16d
commit
f6b10ab243
15
xalan-c-1.12-icu-75.patch
Normal file
15
xalan-c-1.12-icu-75.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
>= ICU 75 needs C++17, see https://bugs.gentoo.org/934471.
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -32,9 +32,9 @@ if (POLICY CMP0067)
|
||||||
|
cmake_policy(SET CMP0067 NEW)
|
||||||
|
endif(POLICY CMP0067)
|
||||||
|
|
||||||
|
-# Try C++14, then fall back to C++11 and C++98. Used for feature tests
|
||||||
|
+# Try C++17, then fall back to C++14, then C++11, and C++98. Used for feature tests
|
||||||
|
# for optional features.
|
||||||
|
-set(CMAKE_CXX_STANDARD 14)
|
||||||
|
+set(CMAKE_CXX_STANDARD 17)
|
||||||
|
|
||||||
|
# Use folders (for IDE project grouping)
|
||||||
|
set_property(GLOBAL PROPERTY USE_FOLDERS ON)
|
@ -8,7 +8,7 @@ Version: 1.12.0
|
|||||||
# …but we do not do so because we want to make sure we detect any soversion
|
# …but we do not do so because we want to make sure we detect any soversion
|
||||||
# update.
|
# update.
|
||||||
%global so_version 112
|
%global so_version 112
|
||||||
Release: %autorelease
|
Release: %autorelease -e 0.riscv64
|
||||||
Summary: Xalan XSLT processor for C/C++
|
Summary: Xalan XSLT processor for C/C++
|
||||||
|
|
||||||
# The entire source is Apache-2.0, except cmake/RunTest.cmake, which is
|
# The entire source is Apache-2.0, except cmake/RunTest.cmake, which is
|
||||||
@ -26,6 +26,10 @@ Source2: %{releaseurl}/KEYS
|
|||||||
# Man page hand-written for Fedora in groff_man(7) format based on Xalan -?
|
# Man page hand-written for Fedora in groff_man(7) format based on Xalan -?
|
||||||
Source3: Xalan.1
|
Source3: Xalan.1
|
||||||
|
|
||||||
|
# https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=919d935a4f5068b50598db0ac2beae8460d8f667
|
||||||
|
# https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-libs/xalan-c/files/xalan-c-1.12-icu-75.patch
|
||||||
|
Patch: xalan-c-1.12-icu-75.patch
|
||||||
|
|
||||||
BuildRequires: gnupg2
|
BuildRequires: gnupg2
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
# Either make or ninja is supported.
|
# Either make or ninja is supported.
|
||||||
|
Loading…
Reference in New Issue
Block a user