Merge remote-tracking branch 'up/main' into main-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2024-03-07 17:27:11 +02:00
commit b96dc767fa
Signed by: davidlt
GPG Key ID: 7A5F42FAF91FACC3
4 changed files with 106 additions and 3 deletions

View File

@ -0,0 +1,30 @@
From 1622a5c9c2f123ef27fc3a52938162a68892e725 Mon Sep 17 00:00:00 2001
From: Scott Talbert <swt@techie.net>
Date: Thu, 1 Feb 2024 20:36:50 -0500
Subject: [PATCH] Fix WebView tests with WebKitGTK 2.43+
It seems that WebKitGTK is now failing to navigate to about: URLs unless
they are about:blank or about:srcdoc, so use about:srcdoc as the
alternate URL to fix the WebView tests.
Ref: https://github.com/WebKit/WebKit/commit/3c3163e71f647db507949ecebad35d0f2ffb33f3
---
tests/controls/webtest.cpp | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/tests/controls/webtest.cpp b/tests/controls/webtest.cpp
index c7055d895f07..3f1ad5e0ca06 100644
--- a/tests/controls/webtest.cpp
+++ b/tests/controls/webtest.cpp
@@ -45,7 +45,11 @@ class WebViewTestCase
}
else
#endif
+#if wxUSE_WEBVIEW_WEBKIT2
+ m_alternateHistoryURL = "about:srcdoc";
+#else
m_alternateHistoryURL = "about:";
+#endif
}
~WebViewTestCase()

View File

@ -0,0 +1,36 @@
From 00dff6e3bce72cc444c0602e13cf346a3340746b Mon Sep 17 00:00:00 2001
From: Vadim Zeitlin <vadim@wxwidgets.org>
Date: Wed, 27 Dec 2023 16:08:37 +0100
Subject: [PATCH] Stop using $EGREP in configure.ac unnecessarily
We don't have DISABLED_UTILS or DISABLED_DEMOS variables, so it's
useless to exclude them from the makefiles list -- just stop doing it.
This fixes a problem with using EGREP without preceding AC_PROG_EGREP
with autoconf 2.72, as EGREP is not defined any longer with this
version.
See #24168.
---
configure | 5 +----
configure.ac | 7 +------
2 files changed, 2 insertions(+), 10 deletions(-)
diff --git a/configure.ac b/configure.ac
index 606333376711..c608f9f4cfdf 100644
--- a/configure.in
+++ b/configure.in
@@ -8048,12 +8048,7 @@ for subdir in $SUBDIRS; do
done
else
dnl assume that everything compiles for utils &c
- dnl any that shouldn't be built can be added to
- dnl DISABLED_UTILS, DISABLED_DEMOS
- disabled_var=DISABLED_`echo $subdir | tr '[[a-z]]' '[[A-Z]]'`
- eval "disabled=\$$disabled_var"
- disabled=/`echo X $disabled | sed 's@ @/|/@g'`/
- makefiles=`(cd $srcdir ; find $subdir -name Makefile.in) | $EGREP -v "$disabled"`
+ makefiles=`(cd $srcdir ; find $subdir -name Makefile.in)`
fi
else
dnl we build wxBase only

View File

@ -0,0 +1,14 @@
diff --git a/tests/allheaders.cpp b/tests/allheaders.cpp
index ae0957dd78..e1a462435c 100644
--- a/tests/allheaders.cpp
+++ b/tests/allheaders.cpp
@@ -129,9 +129,6 @@
#endif // 4.7
#if CHECK_GCC_VERSION(9,1)
GCC_TURN_ON(deprecated-copy)
-#endif // 9.1
-#if CHECK_GCC_VERSION(9,1)
- GCC_TURN_ON(deprecated-copy-dtor)
#endif // 9.1
GCC_TURN_ON(disabled-optimization)
GCC_TURN_ON(double-promotion)

View File

@ -5,7 +5,7 @@
Name: wxGTK
Version: 3.2.4
Release: 1.0.riscv64%{?dist}
Release: 7.0.riscv64%{?dist}
Summary: GTK port of the wxWidgets GUI library
License: wxWidgets
URL: https://www.wxwidgets.org/
@ -16,6 +16,9 @@ Source10: wx-config
# remove abort when ABI check fails
# Backport from wxGTK
Patch0: %{name}-3.1.6-abicheck.patch
Patch1: tests-no-deprecated-copy-dtor.patch
Patch2: https://github.com/wxWidgets/wxWidgets/commit/1622a5c9c2f123ef27fc3a52938162a68892e725.patch
Patch3: fix-ftbfs-autoconf-2.72.patch
BuildRequires: make
BuildRequires: gcc-c++
@ -30,7 +33,7 @@ BuildRequires: expat-devel
BuildRequires: SDL2-devel
BuildRequires: libGLU-devel
BuildRequires: libSM-devel
BuildRequires: gstreamer1-plugins-base-devel
BuildRequires: gstreamer1-plugins-bad-free-devel
BuildRequires: gettext
BuildRequires: cppunit-devel
BuildRequires: libmspack-devel
@ -186,6 +189,7 @@ pushd %{gtk3dir}
--with-opengl \
--with-sdl \
--with-libmspack \
--with-liblzma \
--enable-intl \
--disable-rpath \
--disable-glcanvasegl \
@ -326,9 +330,28 @@ fi
%doc html
%changelog
* Mon Dec 04 2023 David Abdurachmanov <davidlt@rivosinc.com> - 3.2.4-1.0.riscv64
* Thu Mar 07 2024 David Abdurachmanov <davidlt@rivosinc.com> - 3.2.4-7.0.riscv64
- Rebuild for riscv64
* Wed Feb 21 2024 David Abdurachmanov <davidlt@rivosinc.com> - 3.2.4-7
- Skip failing tests on riscv64
* Fri Feb 16 2024 Scott Talbert <swt@techie.net> - 3.2.4-6
- Fix FTBFS with autoconf 2.72 (#2264449)
* Sun Feb 04 2024 Scott Talbert <swt@techie.net> - 3.2.4-5
- Enable wxLZMAInputStream (#2258458)
* Wed Jan 31 2024 Scott Talbert <swt@techie.net> - 3.2.4-4
- Fix FTBFS w/ GCC 14 (#2261535)
- Fix FTBFS w/ WebKitGTK 2.43
* Fri Jan 26 2024 Scott Talbert <swt@techie.net> - 3.2.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Dec 10 2023 Scott Talbert <swt@techie.net> - 3.2.4-2
- Rebuild wxMediaCtrl with gstplayer for Wayland support
* Thu Nov 16 2023 Scott Talbert <swt@techie.net> - 3.2.4-1
- Update to new upstream release 3.2.4