Update to new upstream release 3.2.2 (#2168466)

This commit is contained in:
Scott Talbert 2023-02-09 22:46:32 -05:00
parent 987564ddff
commit 7e16535e00
4 changed files with 7 additions and 58 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@
/wxWidgets-3.1.7.tar.bz2
/wxWidgets-3.2.0.tar.bz2
/wxWidgets-3.2.1.tar.bz2
/wxWidgets-3.2.2.tar.bz2

View File

@ -1 +1 @@
SHA512 (wxWidgets-3.2.1.tar.bz2) = d0294788891014672d8eb4501ae257598972407b53f38471e4f11dd20f517d0145d510c5bce006b09c5d63113fed844bdf6124b3c80453c1d37b402abc89202b
SHA512 (wxWidgets-3.2.2.tar.bz2) = c134fb595d0e73396cf8151eb5703363f7500033835f9073c6c26ee184cdd30c1f7e1602982c36fabcf05d6aef371b08bee2c2bfb7ce70e81b5d4452c85db2e6

View File

@ -1,54 +0,0 @@
Include <sys/inotify.h> in the inotify_init probe, to avoid
an implicit function declaration. Future compilers are likely
to reject implicit function declarations by default, making
the configure check invalid as written.
Fixed upstream via:
commit da4b42688a6cd5444eefb91bf40183d88203ffca
Author: Mojca Miklavec <mojca@macports.org>
Date: Sat Nov 5 13:22:25 2022 +0100
Fix implicit declaration configuration errors with Xcode 12
Some configure could fail with errors like the following:
conftest.c:56:33: error: implicitly declaring library function 'exit'
with type 'void (int) __attribute__((noreturn))'
[-Werror,-Wimplicit-function-declaration]
See https://trac.macports.org/ticket/61672
Closes #22946.
diff --git a/configure b/configure
index 54eb7a74f95d4dd2..232d202cc5da2345 100755
--- a/configure
+++ b/configure
@@ -37928,7 +37916,9 @@ if ${wx_cv_inotify_usable+:} false; then :
else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-int main() { return inotify_init(); }
+
+ #include <sys/inotify.h>
+ int main() { return inotify_init(); }
_ACEOF
if ac_fn_c_try_link "$LINENO"; then :
wx_cv_inotify_usable=yes
diff --git a/configure.in b/configure.in
index c76c528f6635bece..bf6a33b3c10dc27a 100644
--- a/configure.in
+++ b/configure.in
@@ -5622,7 +5622,9 @@ if test "$wxUSE_FSWATCHER" = "yes"; then
[whether inotify is usable],
wx_cv_inotify_usable,
AC_LINK_IFELSE(
- [AC_LANG_SOURCE([int main() { return inotify_init(); }])],
+ [AC_LANG_SOURCE([
+ #include <sys/inotify.h>
+ int main() { return inotify_init(); }])],
[wx_cv_inotify_usable=yes],
[wx_cv_inotify_usable=no]
)

View File

@ -4,8 +4,8 @@
%global sover 0
Name: wxGTK
Version: 3.2.1
Release: 5%{?dist}
Version: 3.2.2
Release: 1%{?dist}
Summary: GTK port of the wxWidgets GUI library
License: wxWidgets
URL: https://www.wxwidgets.org/
@ -16,7 +16,6 @@ Source10: wx-config
# remove abort when ABI check fails
# Backport from wxGTK
Patch0: %{name}-3.1.6-abicheck.patch
Patch1: wxGTK-configure-c99.patch
BuildRequires: make
BuildRequires: gcc-c++
@ -315,6 +314,9 @@ fi
%doc html
%changelog
* Fri Feb 10 2023 Scott Talbert <swt@techie.net> - 3.2.2-1
- Update to new upstream release 3.2.2 (#2168466)
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild