Update to 1.9.1.

Update compile patch to deal with qt5_use_modules no longer being available in
  rawhide/f29.
This commit is contained in:
Richard Shaw 2018-05-31 11:23:01 -05:00
parent 854f338c86
commit c067aca8db
2 changed files with 24 additions and 7 deletions

View File

@ -1,5 +1,3 @@
diff --git a/wsjtx/CMakeLists.txt b/wsjtx/CMakeLists.txt
index 03b5dca..35b2642 100644
--- a/wsjtx/CMakeLists.txt
+++ b/wsjtx/CMakeLists.txt
@@ -838,11 +838,11 @@ find_program(ETAGS etags)
@ -16,7 +14,7 @@ index 03b5dca..35b2642 100644
if (Boost_FOUND)
include_directories (${Boost_INCLUDE_DIRS})
endif ()
@@ -860,7 +860,7 @@ find_package (FFTW3 COMPONENTS double single threads REQUIRED)
@@ -860,7 +860,7 @@ find_package (FFTW3 COMPONENTS double si
#
# libhamlib setup
#
@ -25,7 +23,26 @@ index 03b5dca..35b2642 100644
find_package (hamlib 3 REQUIRED)
find_program (RIGCTL_EXE rigctl)
find_program (RIGCTLD_EXE rigctld)
@@ -1432,20 +1432,6 @@ install (TARGETS jt9 ft8code jt65code qra64code qra64sim jt9code jt4code
@@ -1343,7 +1343,8 @@ else ()
)
endif ()
endif ()
-qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
+find_package(Qt5SerialPort)
+target_link_libraries (wsjtx Qt5::SerialPort) # not sure why the interface link library syntax above doesn't work
# make a library for WSJT-X UDP servers
# add_library (wsjtx_udp SHARED ${UDP_library_CXXSRCS})
@@ -1364,7 +1365,7 @@ set_target_properties (wsjtx_udp-static
)
target_compile_definitions (wsjtx_udp-static PUBLIC UDP_STATIC_DEFINE)
#qt5_use_modules (wsjtx_udp Network)
-qt5_use_modules (wsjtx_udp-static Network Gui)
+target_link_libraries (wsjtx_udp-static Qt5::Network Qt5::Gui)
generate_export_header (wsjtx_udp-static BASE_NAME udp)
add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})
@@ -1432,20 +1433,6 @@ install (TARGETS jt9 ft8code jt65code qr
BUNDLE DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT runtime
)
@ -46,8 +63,6 @@ index 03b5dca..35b2642 100644
install (FILES
README
COPYING
diff --git a/wsjtx/HamlibTransceiver.hpp b/wsjtx/HamlibTransceiver.hpp
index c8c0f74..0136b98 100644
--- a/wsjtx/HamlibTransceiver.hpp
+++ b/wsjtx/HamlibTransceiver.hpp
@@ -10,6 +10,10 @@

View File

@ -7,7 +7,7 @@ Summary: Weak Signal communication by K1JT
License: GPLv3+
URL: http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
Source0: http://physics.princeton.edu/pulsar/k1jt/%{name}-%{version}%{?rctag:-%{rctag}}.tgz
Patch0: wsjtx-1.9.0.rc4-compile-fix.patch
Patch0: wsjtx-1.9.1-compile-fix.patch
BuildRequires: dos2unix, tar, cmake, gcc-c++, gcc-gfortran, qt5-devel
BuildRequires: desktop-file-utils, hamlib-devel, fftw-devel, libusbx-devel
BuildRequires: boost-devel, portaudio-devel, asciidoc, rubygem-asciidoctor
@ -98,6 +98,8 @@ install -p -m 0644 -t %{buildroot}%{_datadir}/doc/%{name} GUIcontrols.txt jt9.tx
%changelog
* Thu May 31 2018 Richard Shaw <hobbes1069@gmail.com> - 1.9.1-1
- Update to 1.9.1.
- Update compile patch to deal with qt5_use_modules no longer being available in
rawhide/f29.
* Tue May 29 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 1.9.0-1
- New version