New version
Updated gcc-8.0.1-compile-fix patch
This commit is contained in:
parent
9a1c675ab0
commit
b89b7b95ad
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (wsjtx-1.9.0-rc2.tgz) = eaa0ca6f06ef523630515eda723c1404a6cb01dfb6f7ac69f974eef1134c32589e82987433b7eb27b7a697b7d5ce51d16cdb732e9e9eb8edd431d6992dd3e455
|
||||
SHA512 (wsjtx-1.9.0-rc3.tgz) = 60ff36a1f33858965405e14f309d70519aa4aef5ec6d27761e1130cf7f4304d8a19c6057665f765d47e1471de796ee7f8cea9786eb6614a1ce174c1abf67825f
|
||||
|
@ -1,6 +1,6 @@
|
||||
From a156e03a9d08c83d2a8b61fff7a984f670c61e31 Mon Sep 17 00:00:00 2001
|
||||
From f9395bc607dfb8714b0f766dd99dcaa90569a756 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jaroslav=20=C5=A0karvada?= <jskarvad@redhat.com>
|
||||
Date: Fri, 16 Mar 2018 15:00:04 +0100
|
||||
Date: Wed, 21 Mar 2018 11:05:05 +0100
|
||||
Subject: [PATCH] Fixed compilation with gcc/gfortran-8.0.1
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
@ -66,7 +66,7 @@ index 14bc077..ea56b42 100644
|
||||
twkfreq.o downsam9.o symspec2.o ipcomm.o sleep_msec.o \
|
||||
stdmsg.o sec_midn.o usleep.o azdist.o geodist.o morse.o \
|
||||
diff --git a/wsjtx/lib/decoder.f90 b/wsjtx/lib/decoder.f90
|
||||
index 2035703..54ef31b 100644
|
||||
index ccabd54..b15a4fa 100644
|
||||
--- a/wsjtx/lib/decoder.f90
|
||||
+++ b/wsjtx/lib/decoder.f90
|
||||
@@ -3,6 +3,7 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
@ -119,16 +119,16 @@ index 2035703..54ef31b 100644
|
||||
call timer('decft8 ',1)
|
||||
if(nfox.gt.0) then
|
||||
n30min=minval(n30fox(1:nfox))
|
||||
@@ -99,7 +110,7 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
nfreqfox(j)=nfreqfox(i)
|
||||
@@ -100,7 +111,7 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
n30fox(j)=n
|
||||
m=n30max-n
|
||||
- call azdist(params%mygrid,g2fox(j),0.d0,nAz,nEl,nDmiles,nDkm, &
|
||||
+ call azdist(mygrid,g2fox(j),0.d0,nAz,nEl,nDmiles,nDkm, &
|
||||
nHotAz,nHotABetter)
|
||||
write(19,1004) c2fox(j),g2fox(j),nsnrfox(j),nfreqfox(j),nDkm,m
|
||||
1004 format(a12,1x,a4,i5,i6,i7,i3)
|
||||
@@ -151,8 +162,8 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
if(len(trim(g2fox(j))).eq.4) then
|
||||
- call azdist(params%mygrid,g2fox(j),0.d0,nAz,nEl,nDmiles,nDkm, &
|
||||
+ call azdist(mygrid,g2fox(j),0.d0,nAz,nEl,nDmiles,nDkm, &
|
||||
nHotAz,nHotABetter)
|
||||
else
|
||||
nDkm=9999
|
||||
@@ -155,8 +166,8 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
call my_jt4%decode(jt4_decoded,dd,jz,params%nutc,params%nfqso, &
|
||||
params%ntol,params%emedelay,params%dttol,logical(params%nagain), &
|
||||
params%ndepth,logical(params%nclearave),params%minsync, &
|
||||
@ -139,7 +139,7 @@ index 2035703..54ef31b 100644
|
||||
go to 800
|
||||
endif
|
||||
|
||||
@@ -184,8 +195,8 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
@@ -188,8 +199,8 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
nf1,nf2,params%nfqso,ntol65,params%nsubmode,params%minsync, &
|
||||
logical(params%nagain),params%n2pass,logical(params%nrobust), &
|
||||
ntrials,params%naggressive,params%ndepth,params%emedelay, &
|
||||
@ -150,7 +150,7 @@ index 2035703..54ef31b 100644
|
||||
logical(params%ljt65apon))
|
||||
call timer('jt65a ',1)
|
||||
|
||||
@@ -210,8 +221,8 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
@@ -214,8 +225,8 @@ subroutine multimode_decoder(ss,id2,params,nfsample)
|
||||
nf1,nf2,params%nfqso,ntol65,params%nsubmode,params%minsync, &
|
||||
logical(params%nagain),params%n2pass,logical(params%nrobust), &
|
||||
ntrials,params%naggressive,params%ndepth,params%emedelay, &
|
||||
@ -161,15 +161,22 @@ index 2035703..54ef31b 100644
|
||||
logical(params%ljt65apon))
|
||||
call timer('jt65a ',1)
|
||||
else
|
||||
@@ -489,10 +500,10 @@ contains
|
||||
@@ -493,7 +504,7 @@ contains
|
||||
c1=decoded0(1:i1-1)//' '
|
||||
c2=decoded0(i1+1:i2-1)
|
||||
g2=decoded0(i2+1:i3-1)
|
||||
- b0=c1.eq.params%mycall
|
||||
+ b0=c1.eq.mycall
|
||||
ctmp=decoded0(i1+1:i2-1)
|
||||
i6=index(ctmp,'/')
|
||||
if(c1(1:3).eq.'DE ' .or. i6.gt.0) then
|
||||
@@ -501,9 +512,9 @@ contains
|
||||
if(i6.ge.2 .and. i6.lt.len(trim(ctmp))/2) c2=ctmp(i6+1:)
|
||||
if(i6.ge.len(trim(ctmp))/2) c2=ctmp(:i6-1)
|
||||
endif
|
||||
- if(len(trim(c1)).ne.len(trim(params%mycall))) then
|
||||
- i4=index(trim(c1),trim(params%mycall))
|
||||
- i5=index(trim(params%mycall),trim(c1))
|
||||
+ b0=c1.eq.mycall
|
||||
+ if(len(trim(c1)).ne.len(trim(mycall))) then
|
||||
+ i4=index(trim(c1),trim(mycall))
|
||||
+ i5=index(trim(mycall),trim(c1))
|
10
wsjtx.spec
10
wsjtx.spec
@ -1,15 +1,15 @@
|
||||
%global rctag rc2
|
||||
%global rctag rc3
|
||||
|
||||
Name: wsjtx
|
||||
Version: 1.9.0
|
||||
Release: 0.1%{?rctag:.%{rctag}}%{?dist}
|
||||
Release: 0.2%{?rctag:.%{rctag}}%{?dist}
|
||||
Summary: Weak Signal communication by K1JT
|
||||
License: GPLv3+
|
||||
URL: http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
|
||||
Source0: http://physics.princeton.edu/pulsar/k1jt/%{name}-%{version}%{?rctag:-%{rctag}}.tgz
|
||||
Patch0: wsjtx-1.9.0.rc2-compile-fix.patch
|
||||
# Patch sent upstream
|
||||
Patch1: wsjtx-1.9.0.rc2-gcc-8.0.1-compile-fix.patch
|
||||
Patch1: wsjtx-1.9.0.rc3-gcc-8.0.1-compile-fix.patch
|
||||
BuildRequires: dos2unix, tar, cmake, gcc-c++, gcc-gfortran, qt5-devel
|
||||
BuildRequires: desktop-file-utils, hamlib-devel, fftw-devel, libusbx-devel
|
||||
BuildRequires: boost-devel, portaudio-devel, asciidoc, rubygem-asciidoctor
|
||||
@ -96,6 +96,10 @@ install -p -m 0644 -t %{buildroot}%{_datadir}/doc/%{name} GUIcontrols.txt jt9.tx
|
||||
%{_datadir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Wed Mar 21 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 1.9.0-0.2.rc3
|
||||
- New version
|
||||
- Updated gcc-8.0.1-compile-fix patch
|
||||
|
||||
* Fri Mar 16 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 1.9.0-0.1.rc2
|
||||
- New version
|
||||
- Fixed compilation with gcc-8.0.1
|
||||
|
Loading…
x
Reference in New Issue
Block a user