Updated patch.

This commit is contained in:
Richard Shaw 2019-02-25 13:19:15 -06:00
parent 4cb0f1d4cc
commit 73cb35b6a4
1 changed files with 12 additions and 5 deletions

View File

@ -1,6 +1,6 @@
--- a/wsjtx/CMakeLists.txt
+++ b/wsjtx/CMakeLists.txt
@@ -826,14 +826,12 @@ find_program(ETAGS etags)
@@ -822,14 +822,12 @@ find_program(ETAGS etags)
#
# Boost
#
@ -18,7 +18,7 @@
#
# OpenMP
@@ -848,7 +846,7 @@ find_package (FFTW3 COMPONENTS double si
@@ -844,7 +842,7 @@ find_package (FFTW3 COMPONENTS double si
#
# libhamlib setup
#
@ -27,7 +27,7 @@
find_package (hamlib 3 REQUIRED)
find_program (RIGCTL_EXE rigctl)
find_program (RIGCTLD_EXE rigctld)
@@ -1309,7 +1307,8 @@ else ()
@@ -1305,7 +1303,8 @@ else ()
)
endif ()
endif ()
@ -37,7 +37,7 @@
# make a library for WSJT-X UDP servers
# add_library (wsjtx_udp SHARED ${UDP_library_CXXSRCS})
@@ -1330,7 +1329,7 @@ set_target_properties (wsjtx_udp-static
@@ -1326,7 +1325,7 @@ set_target_properties (wsjtx_udp-static
)
target_compile_definitions (wsjtx_udp-static PUBLIC UDP_STATIC_DEFINE)
#qt5_use_modules (wsjtx_udp Network)
@ -46,7 +46,7 @@
generate_export_header (wsjtx_udp-static BASE_NAME udp)
add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})
@@ -1405,20 +1404,6 @@ install (TARGETS ft8code jt65code qra64c
@@ -1404,27 +1403,6 @@ install (TARGETS ft8code jt65code qra64c
)
endif(WSJT_BUILD_UTILS)
@ -63,6 +63,13 @@
- #COMPONENT runtime
- RENAME rigctld-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
- )
-
-install (PROGRAMS
- ${RIGCTLCOM_EXE}
- DESTINATION ${CMAKE_INSTALL_BINDIR}
- #COMPONENT runtime
- RENAME rigctlcom-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
- )
-
install (FILES
README