Update to version 1.1 from upstream

Remove conflicting wiggle-Fix-endian-checks.patch
This commit is contained in:
John W. Linville 2018-02-21 14:13:25 -05:00
parent 3dc54159a3
commit d87d837bf8
5 changed files with 20 additions and 55 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/wiggle-1.0.tar.gz
/wiggle-1.1.tar.gz

View File

@ -1 +1 @@
777d8d4c718220063511e82e16275d1b wiggle-1.0.tar.gz
SHA512 (wiggle-1.1.tar.gz) = d229d29065df1cd991d013f1dfe41a02471fe2881db98a2d9cbe15310642d42f1f0b5a70dd63a201af7e1d07b8dd53351a7e60afb323c7610efbc61ea714fe7d

View File

@ -1,41 +0,0 @@
From 3a1ab01be4af79136081f4977b3eaa6ff3eb0d3e Mon Sep 17 00:00:00 2001
From: Dimitri John Ledkov <dimitri.ledkov@canonical.com>
Date: Mon, 6 Jan 2014 03:57:03 +0000
Subject: [PATCH] Fix endian checks as per austin group definitions of endian.h
Debian-Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=733831
Reference: http://www.opengroup.org/austin/docs/austin_514.txt
Signed-off-by: NeilBrown <neilb@suse.de>
---
config.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/config.h b/config.h
index ecf3411..79a64b5 100644
--- a/config.h
+++ b/config.h
@@ -1,17 +1,17 @@
/* Includes and defines for ccan files */
-#if !defined(LITTLE_ENDIAN) && !defined(BIG_ENDIAN)
+#if !defined(BYTE_ORDER) && !defined(LITTLE_ENDIAN) && !defined(BIG_ENDIAN)
#if defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
#include <machine/endian.h>
#else
#include <endian.h>
#endif
#endif
-#ifdef LITTLE_ENDIAN
+#if BYTE_ORDER == LITTLE_ENDIAN
#define HAVE_LITTLE_ENDIAN 1
#define HAVE_BIG_ENDIAN 0
-#elif defined(BIG_ENDIAN)
+#elif BYTE_ORDER == BIG_ENDIAN
#define HAVE_LITTLE_ENDIAN 0
#define HAVE_BIG_ENDIAN 1
#else
--
2.1.4

View File

@ -1,16 +1,20 @@
diff -up wiggle-1.0/Makefile.build wiggle-1.0/Makefile
--- wiggle-1.0/Makefile.build 2013-08-23 02:02:27.000000000 -0400
+++ wiggle-1.0/Makefile 2014-07-11 09:58:25.131309316 -0400
@@ -3,7 +3,7 @@
#OptDbg=-O3
diff -up wiggle-1.1/Makefile.build wiggle-1.1/Makefile
--- wiggle-1.1/Makefile.build 2017-09-28 08:37:04.000000000 -0400
+++ wiggle-1.1/Makefile 2018-02-21 14:04:33.644637920 -0500
@@ -4,9 +4,10 @@
#OptDbg=-O3 -march=pentium2
OptDbg=-ggdb
-CFLAGS=$(OptDbg) -I. -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
ifndef CWFLAGS
-CWFLAGS=-Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter -Wno-missing-field-initializers
+#CWFLAGS=-Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter -Wno-missing-field-initializers
endif
-CFLAGS=$(OptDbg) -I. $(CWFLAGS)
+#CFLAGS=$(OptDbg) -I. $(CWFLAGS)
+CFLAGS+=-I.
PREFIX = /usr
# STRIP = -s
INSTALL = /usr/bin/install
@@ -14,7 +14,7 @@ MAN1DIR = $(MANDIR)/man1
@@ -18,7 +19,7 @@ MAN1DIR = $(MANDIR)/man1
MAN5DIR = $(MANDIR)/man5
LDLIBS = -lncurses

View File

@ -1,6 +1,6 @@
Name: wiggle
Version: 1.0
Release: 10%{?dist}
Version: 1.1
Release: 1%{?dist}
Summary: A tool for applying patches with conflicts
Group: Development/Tools
@ -8,7 +8,6 @@ License: GPLv2+
URL: http://neil.brown.name/wiggle/
Source0: http://neil.brown.name/wiggle/%{name}-%{version}.tar.gz
Patch0: wiggle-fix-build.patch
Patch1: wiggle-Fix-endian-checks.patch
BuildRequires: groff, time, ncurses-devel
@ -36,7 +35,6 @@ conflict.
%prep
%setup -q
%patch0 -p1 -b .build
%patch1 -p1 -b .endian
%build
export CFLAGS="$RPM_OPT_FLAGS"
@ -58,6 +56,10 @@ make install DESTDIR=$RPM_BUILD_ROOT
%changelog
* Wed Feb 21 2018 John W. Linville <linville@redhat.com> - 1.1-1
- Update to version 1.1 from upstream
- Remove conflicting wiggle-Fix-endian-checks.patch
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0-10
- Escape macros in %%changelog