Weston 1.2.0

This commit is contained in:
Richard Hughes 2013-07-15 13:12:10 +01:00
parent abc244150d
commit 99210b2ed4
4 changed files with 6 additions and 60 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/weston-1.0.6.tar.xz
/weston-1.1.0.tar.xz
/weston-20130515.tar.bz2
/weston-1.2.0.tar.xz

View File

@ -1 +1 @@
3d83b295e0f8757a37b0bb8702de38a7 weston-20130515.tar.bz2
86f8c9e865923e138ce44ee41d951500 weston-1.2.0.tar.xz

View File

@ -1,51 +0,0 @@
diff --git a/src/cms-colord.c b/src/cms-colord.c
index 33f23b2..6056407 100644
--- a/src/cms-colord.c
+++ b/src/cms-colord.c
@@ -127,6 +127,7 @@ static void
update_device_with_profile_in_idle(struct cms_output *ocms)
{
gboolean signal_write = FALSE;
+ ssize_t rc;
struct cms_colord *cms = ocms->cms;
colord_idle_cancel_for_output(cms, ocms->o);
@@ -139,7 +140,9 @@ update_device_with_profile_in_idle(struct cms_output *ocms)
/* signal we've got updates to do */
if (signal_write) {
gchar tmp = '\0';
- write(cms->writefd, &tmp, 1);
+ rc = write(cms->writefd, &tmp, 1);
+ if (rc == 0)
+ weston_log("colord: failed to write to pending fd");
}
}
@@ -365,6 +368,7 @@ colord_dispatch_all_pending(int fd, uint32_t mask, void *data)
{
gchar tmp;
GList *l;
+ ssize_t rc;
struct cms_colord *cms = data;
struct cms_output *ocms;
@@ -387,7 +391,9 @@ colord_dispatch_all_pending(int fd, uint32_t mask, void *data)
g_mutex_unlock(&cms->pending_mutex);
/* done */
- read(cms->readfd, &tmp, 1);
+ rc = read(cms->readfd, &tmp, 1);
+ if (rc == 0)
+ weston_log("colord: failed to read from pending fd");
return 1;
}
@@ -478,7 +484,7 @@ colord_cms_output_destroy(gpointer data)
WL_EXPORT int
module_init(struct weston_compositor *ec,
- int *argc, char *argv[], const char *config_file)
+ int *argc, char *argv[])
{
gboolean ret;
GError *error = NULL;

View File

@ -1,8 +1,8 @@
%define gitdate 20130515
#define gitdate 20130515
Name: weston
Version: 1.1.90
Release: 0.1%{?alphatag}%{?dist}
Version: 1.2.0
Release: 1%{?alphatag}%{?dist}
Summary: Reference compositor for Wayland
Group: User Interface/X
License: BSD and CC-BY-SA
@ -17,9 +17,6 @@ Source1: make-git-snapshot.sh
# git diff-tree -p 1.0.6..origin/1.0 > weston-$(git describe origin/1.0).patch
#Patch0: weston-1.0.5-11-g9a576c3.patch
# Sent upstream
Patch1: weston-fixes.patch
BuildRequires: autoconf
BuildRequires: cairo-devel >= 1.10.0
BuildRequires: glib2-devel
@ -33,7 +30,7 @@ BuildRequires: libudev-devel
%endif
BuildRequires: libunwind-devel
BuildRequires: libwayland-client-devel
BuildRequires: libwayland-server-devel >= 1.1.90
BuildRequires: libwayland-server-devel >= 1.2.0
BuildRequires: libwayland-cursor-devel
BuildRequires: libxcb-devel
BuildRequires: libXcursor-devel
@ -65,7 +62,6 @@ Common headers for weston
%prep
%setup -q -n %{name}-%{?gitdate:%{gitdate}}%{!?gitdate:%{version}}
#%patch0 -p1 -b .git
%patch1 -p1 -b .fixes
%build
# temporary force to pick up configure.ac changes