websocketpp-0.7.0 (#1375610)

This commit is contained in:
Rex Dieter 2016-09-15 13:32:46 -05:00
parent b9ac7a5ffb
commit b047accdcc
6 changed files with 24 additions and 20 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/0.4.0.tar.gz
/websocketpp-0.7.0.tar.gz

View File

@ -1 +1 @@
21ed2beaaf2fe3f76783e4b3bbaa8206 0.4.0.tar.gz
5027c20cde76fdaef83a74acfcf98e23 websocketpp-0.7.0.tar.gz

View File

@ -1,12 +0,0 @@
diff -up websocketpp-0.4.0/CMakeLists.txt.noarch websocketpp-0.4.0/CMakeLists.txt
--- websocketpp-0.4.0/CMakeLists.txt.noarch 2014-11-04 06:35:10.000000000 -0600
+++ websocketpp-0.4.0/CMakeLists.txt 2014-11-13 14:23:02.306865323 -0600
@@ -17,7 +17,7 @@ set(INSTALL_INCLUDE_DIR include CACHE PA
if (WIN32 AND NOT CYGWIN)
set (DEF_INSTALL_CMAKE_DIR cmake)
else ()
- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
+ set (DEF_INSTALL_CMAKE_DIR share/cmake/websocketpp)
endif ()
set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")

View File

@ -0,0 +1,12 @@
diff -up websocketpp-0.7.0/CMakeLists.txt.cmake_noarch websocketpp-0.7.0/CMakeLists.txt
--- websocketpp-0.7.0/CMakeLists.txt.cmake_noarch 2016-02-22 07:30:10.000000000 -0600
+++ websocketpp-0.7.0/CMakeLists.txt 2016-09-15 13:05:59.012179625 -0500
@@ -19,7 +19,7 @@ set(INSTALL_INCLUDE_DIR include CACHE PA
if (WIN32 AND NOT CYGWIN)
set (DEF_INSTALL_CMAKE_DIR cmake)
else ()
- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
+ set (DEF_INSTALL_CMAKE_DIR share/cmake/websocketpp)
endif ()
set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")

View File

@ -4,6 +4,6 @@ includedir=${prefix}/include
Name: websocketpp
Description: WebSocket API
Version: 0.4.0
Version: 0.7.0
URL: http://www.zaphoyd.com/websocketpp/
Cflags: -I${includedir}/

View File

@ -1,17 +1,17 @@
Name: websocketpp
Summary: C++ WebSocket Protocol Library
Version: 0.4.0
Release: 9%{?dist}
Version: 0.7.0
Release: 0.1%{?dist}
License: BSD
Url: http://www.zaphoyd.com/websocketpp
Source0: https://github.com/zaphoyd/websocketpp/archive/%{version}.tar.gz
Source0: https://github.com/zaphoyd/websocketpp/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
Source1: websocketpp.pc
BuildArch: noarch
# put cmake files in share/cmake instead of lib/cmake
Patch1: websocketpp-0.4.0-cmake_noarch.patch
Patch1: websocketpp-0.7.0-cmake_noarch.patch
BuildRequires: boost-devel
BuildRequires: cmake
@ -34,8 +34,9 @@ WebSocket client and server functionality into C++ programs. It uses
interchangeable network transport modules including one based on C++
iostreams and one based on Boost Asio.
%prep
%setup -q -n %{name}-%{version}
%autosetup
%patch1 -p1 -b .cmake_noarch
@ -61,6 +62,9 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%changelog
* Thu Sep 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 0.7.0-0.1
- websocketpp-0.7.0 (#1375610)
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild