Disable check for same 32/64bit-ness

in websocketpp-configVersion.cmake
This commit is contained in:
Wolfgang Stöggl 2018-10-31 15:12:55 +01:00
parent bacc9021ff
commit 1e1bda9802
2 changed files with 14 additions and 4 deletions

View File

@ -1,7 +1,11 @@
--- a/CMakeLists.txt 2018-07-16 14:40:53.000000000 +0200 --- a/CMakeLists.txt 2018-10-31 13:58:03.000000000 +0100
+++ b/CMakeLists.txt 2018-07-26 16:41:28.356321007 +0200 +++ b/CMakeLists.txt 2018-10-31 14:21:06.251424022 +0100
@@ -268,7 +268,7 @@ @@ -266,9 +266,11 @@
INSTALL_DESTINATION "${INSTALL_CMAKE_DIR}"
NO_CHECK_REQUIRED_COMPONENTS_MACRO
) )
+# disable check for same 32/64bit-ness in websocketpp-configVersion.cmake by setting CMAKE_SIZEOF_VOID_P
+set (CMAKE_SIZEOF_VOID_P "")
write_basic_package_version_file("${PROJECT_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/websocketpp-configVersion.cmake" write_basic_package_version_file("${PROJECT_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/websocketpp-configVersion.cmake"
VERSION ${WEBSOCKETPP_VERSION} VERSION ${WEBSOCKETPP_VERSION}
- COMPATIBILITY ExactVersion) - COMPATIBILITY ExactVersion)

View File

@ -2,7 +2,7 @@
Name: websocketpp Name: websocketpp
Summary: C++ WebSocket Protocol Library Summary: C++ WebSocket Protocol Library
Version: 0.8.1 Version: 0.8.1
Release: 1%{?dist} Release: 2%{?dist}
License: BSD License: BSD
Url: https://www.zaphoyd.com/websocketpp Url: https://www.zaphoyd.com/websocketpp
@ -17,11 +17,13 @@ Patch1: websocketpp-0.7.0-cmake_noarch.patch
# https://cmake.org/cmake/help/v3.0/module/CMakePackageConfigHelpers.html # https://cmake.org/cmake/help/v3.0/module/CMakePackageConfigHelpers.html
# Fixes build failure of tomahawk, which uses "find_package(websocketpp 0.2.99 REQUIRED)" # Fixes build failure of tomahawk, which uses "find_package(websocketpp 0.2.99 REQUIRED)"
# PR submitted upstream: https://github.com/zaphoyd/websocketpp/pull/740 # PR submitted upstream: https://github.com/zaphoyd/websocketpp/pull/740
# Disable check for same 32/64bit-ness in websocketpp-configVersion.cmake by setting CMAKE_SIZEOF_VOID_P
Patch2: websocketpp-0.8.1-cmake-configversion-compatibility-anynewerversion.patch Patch2: websocketpp-0.8.1-cmake-configversion-compatibility-anynewerversion.patch
# Disable the following tests, which fail occasionally: test_transport, test_transport_asio_timers # Disable the following tests, which fail occasionally: test_transport, test_transport_asio_timers
Patch3: websocketpp-0.7.0-disable-test_transport-test_transport_asio_timers.patch Patch3: websocketpp-0.7.0-disable-test_transport-test_transport_asio_timers.patch
BuildRequires: boost-devel BuildRequires: boost-devel
BuildRequires: cmake BuildRequires: cmake
BuildRequires: gcc-c++ BuildRequires: gcc-c++
@ -81,6 +83,10 @@ make test -C %{_target_platform}
%changelog %changelog
* Wed Oct 31 2018 Wolfgang Stöggl <c72578@yahoo.de> - 0.8.1-2
- Update websocketpp-0.8.1-cmake-configversion-compatibility-anynewerversion.patch
Disable check for same 32/64bit-ness in websocketpp-configVersion.cmake
* Thu Jul 26 2018 Wolfgang Stöggl <c72578@yahoo.de> - 0.8.1-1 * Thu Jul 26 2018 Wolfgang Stöggl <c72578@yahoo.de> - 0.8.1-1
- New upstream version - New upstream version
- Added websocketpp-0.8.1-cmake-configversion-compatibility-anynewerversion.patch - Added websocketpp-0.8.1-cmake-configversion-compatibility-anynewerversion.patch