This commit is contained in:
Rex Dieter 2014-11-18 06:36:49 -06:00
parent f7e7431398
commit 181d3e5d7b
5 changed files with 94 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/0.4.0.tar.gz

View File

@ -0,0 +1 @@
21ed2beaaf2fe3f76783e4b3bbaa8206 0.4.0.tar.gz

View File

@ -0,0 +1,12 @@
diff -up websocketpp-0.4.0/CMakeLists.txt.noarch websocketpp-0.4.0/CMakeLists.txt
--- websocketpp-0.4.0/CMakeLists.txt.noarch 2014-11-04 06:35:10.000000000 -0600
+++ websocketpp-0.4.0/CMakeLists.txt 2014-11-13 14:23:02.306865323 -0600
@@ -17,7 +17,7 @@ set(INSTALL_INCLUDE_DIR include CACHE PA
if (WIN32 AND NOT CYGWIN)
set (DEF_INSTALL_CMAKE_DIR cmake)
else ()
- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
+ set (DEF_INSTALL_CMAKE_DIR share/cmake/websocketpp)
endif ()
set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")

9
websocketpp.pc Normal file
View File

@ -0,0 +1,9 @@
prefix=/usr
exec_prefix=${prefix}
includedir=${prefix}/include
Name: websocketpp
Description: WebSocket API
Version: 0.4.0
URL: http://www.zaphoyd.com/websocketpp/
Cflags: -I${includedir}/

71
websocketpp.spec Normal file
View File

@ -0,0 +1,71 @@
Name: websocketpp
Summary: C++ WebSocket Protocol Library
Version: 0.4.0
Release: 2%{?dist}
License: BSD
Url: http://www.zaphoyd.com/websocketpp
Source0: https://github.com/zaphoyd/websocketpp/archive/%{version}.tar.gz
Source1: websocketpp.pc
BuildArch: noarch
# put cmake files in share/cmake instead of lib/cmake
Patch1: websocketpp-0.4.0-cmake_noarch.patch
BuildRequires: boost-devel
BuildRequires: cmake
BuildRequires: pkgconfig
%description
WebSocket++ is an open source (BSD license) header only C++ library
that impliments RFC6455 The WebSocket Protocol. It allows integrating
WebSocket client and server functionality into C++ programs. It uses
interchangeable network transport modules including one based on C++
iostreams and one based on Boost Asio.
%package devel
Summary: C++ WebSocket Protocol Library
Requires: boost-devel
%description devel
WebSocket++ is an open source (BSD license) header only C++ library
that impliments RFC6455 The WebSocket Protocol. It allows integrating
WebSocket client and server functionality into C++ programs. It uses
interchangeable network transport modules including one based on C++
iostreams and one based on Boost Asio.
%prep
%setup -q -n %{name}-%{version}
%patch1 -p1 -b .cmake_noarch
%build
mkdir %{_target_platform}
pushd %{_target_platform}
%cmake ..
make %{?_smp_mflags}
popd
%install
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%files devel
%doc COPYING changelog.md readme.md roadmap.md
%{_includedir}/websocketpp/
%dir %{_datadir}/cmake/
%{_datadir}/cmake/websocketpp/
%changelog
* Thu Nov 13 2014 Rex Dieter <rdieter@fedoraproject.org> 0.4.0-2
- use (upstreamable) cmake_noarch.patch instead of manually moving files around
* Wed Nov 05 2014 Rex Dieter <rdieter@fedoraproject.org> 0.4.0-1
- first try
* Mon Mar 17 2014 prusnak@opensuse.org
- created package (based on a Fedora package by Thomas Sailer)