Update to 2.37.90

This commit is contained in:
Michael Catanzaro 2022-08-20 13:22:40 -05:00
parent 8ea0b4518b
commit efa123cfe2
5 changed files with 8 additions and 71 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/webkitgtk-*.tar.xz
/webkitgtk-2.37.1.tar.xz.asc
/webkitgtk-2.37.90.tar.xz.asc

View File

@ -1,19 +0,0 @@
diff --git a/Source/WTF/wtf/PageBlock.h b/Source/WTF/wtf/PageBlock.h
index 9bb7fffcc1ae..3e1e24aa69f5 100644
--- a/Source/WTF/wtf/PageBlock.h
+++ b/Source/WTF/wtf/PageBlock.h
@@ -45,11 +45,11 @@ namespace WTF {
// On Linux, Power systems normally use 64 KiB pages.
//
// Use 64 KiB for any unknown CPUs to be conservative.
-#if OS(DARWIN) || PLATFORM(PLAYSTATION) || CPU(MIPS) || CPU(MIPS64) || (OS(LINUX) && CPU(ARM64))
+#if OS(DARWIN) || PLATFORM(PLAYSTATION) || CPU(MIPS) || CPU(MIPS64)
constexpr size_t CeilingOnPageSize = 16 * KB;
-#elif CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(UNKNOWN)
+#elif CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(UNKNOWN) || CPU(ARM64)
constexpr size_t CeilingOnPageSize = 64 * KB;
-#elif OS(WINDOWS) || CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(RISCV64)
+#elif OS(WINDOWS) || CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(RISCV64)
constexpr size_t CeilingOnPageSize = 4 * KB;
#else
#error Must set CeilingOnPageSize in PageBlock.h when adding a new CPU architecture!

View File

@ -1,27 +0,0 @@
From 40e49bb53218a986b4d6569f3fc2730cc4b71472 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Tue, 12 Jul 2022 16:56:56 -0700
Subject: [PATCH] Fix cloop build after 252338@main
https://bugs.webkit.org/show_bug.cgi?id=242579
Reviewed by Mark Lam.
* Source/JavaScriptCore/CMakeLists.txt:
Canonical link: https://commits.webkit.org/252400@main
---
Source/JavaScriptCore/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
index aef0678e66f3..f4ba2716faef 100644
--- a/Source/JavaScriptCore/CMakeLists.txt
+++ b/Source/JavaScriptCore/CMakeLists.txt
@@ -837,6 +837,7 @@ set(JavaScriptCore_PRIVATE_FRAMEWORK_HEADERS
inspector/remote/RemoteInspector.h
interpreter/AbstractPC.h
+ interpreter/CLoopStack.h
interpreter/CallFrame.h
interpreter/CallFrameInlines.h
interpreter/CalleeBits.h

View File

@ -1,2 +1,2 @@
SHA512 (webkitgtk-2.37.1.tar.xz) = 29935eed5e901780d6be02a7f1072f10e61ad96cecdc3495a71dc8ca00573fa9c485c909fcba928d818df6b901a265a077238ce5fa0cfcc657bdb991867facd8
SHA512 (webkitgtk-2.37.1.tar.xz.asc) = 5b58dd14f79abcacc3ffa3a9655d9067d6ea392203ab96567a2420bc2d1fff94ea1b9147ad128a321803b99cb6e05aecdd7db14b784a2df177a5afb30ec6b0d1
SHA512 (webkitgtk-2.37.90.tar.xz) = 7ed8945ca2036b9eb91ebf4cf021f37e04d4a0d3c710348639f246db234f8b6058938edf2d873c8b1d4ab60d840bd4684775d34b0b470b274f622d5ea6a9cbcd
SHA512 (webkitgtk-2.37.90.tar.xz.asc) = 3ff793a2580e320d83824ffb2126290f32693a5e11080206e9693d71dcaf16f5d5ee268cd0ad80e25123ba5628844ec47ff945dbf291ef9785feb5e4161f2869

View File

@ -16,7 +16,7 @@
%bcond_without docs
Name: webkitgtk
Version: 2.37.1
Version: 2.37.90
Release: %autorelease
Summary: GTK web content engine library
@ -29,15 +29,6 @@ Source1: https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz.asc
# $ gpg --export --export-options export-minimal D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3 5AA3BC334FD7E3369E7C77B291C559DBE4C9123B > webkitgtk-keys.gpg
Source2: webkitgtk-keys.gpg
%if 0%{?rhel}
# https://bugs.webkit.org/show_bug.cgi?id=217989
# https://bugs.webkit.org/show_bug.cgi?id=227905
Patch0: aarch64-page-size.patch
%endif
# https://bugs.webkit.org/show_bug.cgi?id=242579#c4
Patch1: fix-cloop-build.patch
BuildRequires: bison
BuildRequires: bubblewrap
BuildRequires: cmake
@ -297,6 +288,9 @@ files for developing applications that use JavaScript engine from webkit2gtk-4.0
# from redhat-rpm-config.
%global _dwz_max_die_limit_x86_64 250000000
# Require 8 GB of RAM per vCPU for debuginfo processing
%global _find_debuginfo_opts %limit_build -m 8192
# Remove debuginfo from 32-bit builds to reduce memory consumption:
# https://bugs.webkit.org/show_bug.cgi?id=140176
# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/I6IVNA52TXTBRQLKW45CJ5K4RA4WNGMI/
@ -305,17 +299,6 @@ files for developing applications that use JavaScript engine from webkit2gtk-4.0
%global optflags %(echo %{optflags} | sed 's/-g /-g0 /')
%endif
# Require 8 GB of RAM per vCPU for debuginfo processing
%global _find_debuginfo_opts %limit_build -m 8192
# Warning: although RHEL 9 aarch64 now uses 4 KB page sizes, we still have to
# support 64 KB page sizes until the *builders* use RHEL 9. This means we still
# have to disable JIT and bmalloc, even though this disables important heap
# security features. We can't simply disable them only during this build,
# because gobject-introspection will crash when building anything that depends
# on WebKitGTK, because it calls each object's get_type() function, which will
# initialize bmalloc and JIT.
%define _vpath_builddir %{_vendor}-%{_target_os}-build/webkit2gtk-5.0
%cmake \
-GNinja \
@ -349,8 +332,7 @@ files for developing applications that use JavaScript engine from webkit2gtk-4.0
%endif
%if 0%{?rhel}
%ifarch aarch64
-DENABLE_JIT=OFF \
-DUSE_SYSTEM_MALLOC=ON \
-DUSE_64KB_PAGE_BLOCK=ON \
%endif
%endif
%{nil}