- Update to 1.2.0
This commit is contained in:
parent
208d9b7bc0
commit
8a719524a2
2
Makefile
2
Makefile
@ -1,5 +1,5 @@
|
||||
# Makefile for source rpm: webkitgtk
|
||||
# $Id: Makefile,v 1.1 2009/04/10 22:11:33 kevin Exp $
|
||||
# $Id: Makefile,v 1.2 2009/11/25 22:43:12 notting Exp $
|
||||
NAME := webkitgtk
|
||||
SPECFILE = $(firstword $(wildcard *.spec))
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
47301fb7120421ac38bf714db8f5d428 webkit-1.1.15.4.tar.gz
|
||||
b2bfcbc4bbf1d0a51f848cb54c21ee66 webkit-1.2.0.tar.gz
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- webkit-1.1.14/WebCore/plugins/PluginDatabase.cpp.orig 2009-09-14 17:48:44.000000000 +0100
|
||||
+++ webkit-1.1.14/WebCore/plugins/PluginDatabase.cpp 2009-09-14 17:50:28.000000000 +0100
|
||||
@@ -355,6 +355,9 @@ Vector<String> PluginDatabase::defaultPl
|
||||
paths.append("/usr/lib/netscape/plugins-libc6");
|
||||
paths.append("/usr/lib64/netscape/plugins");
|
||||
--- webkit-1.1.17/WebCore/plugins/PluginDatabase.cpp.old 2009-12-01 15:22:10.000000000 +0000
|
||||
+++ webkit-1.1.17/WebCore/plugins/PluginDatabase.cpp 2009-12-01 15:22:21.000000000 +0000
|
||||
@@ -357,6 +357,9 @@ Vector<String> PluginDatabase::defaultPl
|
||||
paths.append("/usr/lib64/mozilla/plugins");
|
||||
paths.append("/usr/lib/nsbrowser/plugins");
|
||||
paths.append("/usr/lib64/nsbrowser/plugins");
|
||||
+ /* And for nspluginwrapper */
|
||||
+ paths.append("/usr/lib64/mozilla/plugins-wrapped");
|
||||
+ paths.append("/usr/lib/mozilla/plugins-wrapped");
|
||||
|
@ -1,124 +0,0 @@
|
||||
diff -up webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h.atomic-word webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h
|
||||
--- webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h.atomic-word 2009-10-01 21:06:02.000000000 +0200
|
||||
+++ webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h 2010-03-31 14:36:01.000000000 +0200
|
||||
@@ -297,12 +297,25 @@
|
||||
#define WTF_PLATFORM_SH4 1
|
||||
#endif
|
||||
|
||||
+/* PLATFORM(S390*) */
|
||||
+#if defined(__s390x__)
|
||||
+#define WTF_PLATFORM_S390X 1
|
||||
+#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
+#elif defined(__s390__) /*PLATFORM(S390) */
|
||||
+#define WTF_PLATFORM_S390 1
|
||||
+#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
+#endif
|
||||
+
|
||||
/* PLATFORM(SPARC64) */
|
||||
#if defined(__sparc__) && defined(__arch64__) || defined (__sparcv9)
|
||||
#define WTF_PLATFORM_SPARC64 1
|
||||
#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
+#elif defined(__sparc__) /*PLATFORM(SPARC) */
|
||||
+#define WTF_PLATFORM_SPARC 1
|
||||
+#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
#endif
|
||||
|
||||
+
|
||||
/* PLATFORM(WINCE) && PLATFORM(QT)
|
||||
We can not determine the endianess at compile time. For
|
||||
Qt for Windows CE the endianess is specified in the
|
||||
@@ -632,7 +645,7 @@
|
||||
#if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
|
||||
#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX))
|
||||
#define WTF_USE_JSVALUE64 1
|
||||
-#elif PLATFORM(ARM) || PLATFORM(PPC64)
|
||||
+#elif PLATFORM(ARM) || PLATFORM(PPC64) || PLATFORM(SPARC64) || PLATFORM(S390X)
|
||||
#define WTF_USE_JSVALUE32 1
|
||||
#elif PLATFORM(WIN_OS) && COMPILER(MINGW)
|
||||
/* Using JSVALUE32_64 causes padding/alignement issues for JITStubArg
|
||||
diff -up webkit-1.1.15.4/JavaScriptCore/wtf/Threading.h.atomic-word webkit-1.1.15.4/JavaScriptCore/wtf/Threading.h
|
||||
--- webkit-1.1.15.4/JavaScriptCore/wtf/Threading.h.atomic-word 2009-09-22 17:29:14.000000000 +0200
|
||||
+++ webkit-1.1.15.4/JavaScriptCore/wtf/Threading.h 2010-03-31 14:31:53.000000000 +0200
|
||||
@@ -215,30 +215,30 @@ private:
|
||||
#define WTF_USE_LOCKFREE_THREADSAFESHARED 1
|
||||
|
||||
#if COMPILER(MINGW) || COMPILER(MSVC7) || PLATFORM(WINCE)
|
||||
-inline int atomicIncrement(int* addend) { return InterlockedIncrement(reinterpret_cast<long*>(addend)); }
|
||||
-inline int atomicDecrement(int* addend) { return InterlockedDecrement(reinterpret_cast<long*>(addend)); }
|
||||
+inline _Atomic_word atomicIncrement(_Atomic_word* addend) { return InterlockedIncrement(reinterpret_cast<long*>(addend)); }
|
||||
+inline _Atomic_word atomicDecrement(_Atomic_word* addend) { return InterlockedDecrement(reinterpret_cast<long*>(addend)); }
|
||||
#else
|
||||
-inline int atomicIncrement(int volatile* addend) { return InterlockedIncrement(reinterpret_cast<long volatile*>(addend)); }
|
||||
-inline int atomicDecrement(int volatile* addend) { return InterlockedDecrement(reinterpret_cast<long volatile*>(addend)); }
|
||||
+inline _Atomic_word atomicIncrement(_Atomic_word volatile* addend) { return InterlockedIncrement(reinterpret_cast<long volatile*>(addend)); }
|
||||
+inline _Atomic_word atomicDecrement(_Atomic_word volatile* addend) { return InterlockedDecrement(reinterpret_cast<long volatile*>(addend)); }
|
||||
#endif
|
||||
|
||||
#elif PLATFORM(DARWIN)
|
||||
#define WTF_USE_LOCKFREE_THREADSAFESHARED 1
|
||||
|
||||
-inline int atomicIncrement(int volatile* addend) { return OSAtomicIncrement32Barrier(const_cast<int*>(addend)); }
|
||||
-inline int atomicDecrement(int volatile* addend) { return OSAtomicDecrement32Barrier(const_cast<int*>(addend)); }
|
||||
+inline _Atomic_word atomicIncrement(_Atomic_word volatile* addend) { return OSAtomicIncrement32Barrier(const_cast<int*>(addend)); }
|
||||
+inline _Atomic_word atomicDecrement(_Atomic_word volatile* addend) { return OSAtomicDecrement32Barrier(const_cast<int*>(addend)); }
|
||||
|
||||
-#elif COMPILER(GCC) && !PLATFORM(SPARC64) // sizeof(_Atomic_word) != sizeof(int) on sparc64 gcc
|
||||
+#elif COMPILER(GCC)
|
||||
#define WTF_USE_LOCKFREE_THREADSAFESHARED 1
|
||||
|
||||
-inline int atomicIncrement(int volatile* addend) { return __gnu_cxx::__exchange_and_add(addend, 1) + 1; }
|
||||
-inline int atomicDecrement(int volatile* addend) { return __gnu_cxx::__exchange_and_add(addend, -1) - 1; }
|
||||
+inline _Atomic_word atomicIncrement(_Atomic_word volatile* addend) { return __gnu_cxx::__exchange_and_add(addend, 1) + 1; }
|
||||
+inline _Atomic_word atomicDecrement(_Atomic_word volatile* addend) { return __gnu_cxx::__exchange_and_add(addend, -1) - 1; }
|
||||
|
||||
#endif
|
||||
|
||||
class ThreadSafeSharedBase : public Noncopyable {
|
||||
public:
|
||||
- ThreadSafeSharedBase(int initialRefCount = 1)
|
||||
+ ThreadSafeSharedBase(_Atomic_word initialRefCount = 1)
|
||||
: m_refCount(initialRefCount)
|
||||
{
|
||||
}
|
||||
@@ -258,12 +258,12 @@ public:
|
||||
return refCount() == 1;
|
||||
}
|
||||
|
||||
- int refCount() const
|
||||
+ _Atomic_word refCount() const
|
||||
{
|
||||
#if !USE(LOCKFREE_THREADSAFESHARED)
|
||||
MutexLocker locker(m_mutex);
|
||||
#endif
|
||||
- return static_cast<int const volatile &>(m_refCount);
|
||||
+ return static_cast<_Atomic_word const volatile &>(m_refCount);
|
||||
}
|
||||
|
||||
protected:
|
||||
@@ -274,7 +274,7 @@ protected:
|
||||
if (atomicDecrement(&m_refCount) <= 0)
|
||||
return true;
|
||||
#else
|
||||
- int refCount;
|
||||
+ _Atomic_word refCount;
|
||||
{
|
||||
MutexLocker locker(m_mutex);
|
||||
--m_refCount;
|
||||
@@ -290,7 +290,7 @@ private:
|
||||
template<class T>
|
||||
friend class CrossThreadRefCounted;
|
||||
|
||||
- int m_refCount;
|
||||
+ _Atomic_word m_refCount;
|
||||
#if !USE(LOCKFREE_THREADSAFESHARED)
|
||||
mutable Mutex m_mutex;
|
||||
#endif
|
||||
@@ -298,7 +298,7 @@ private:
|
||||
|
||||
template<class T> class ThreadSafeShared : public ThreadSafeSharedBase {
|
||||
public:
|
||||
- ThreadSafeShared(int initialRefCount = 1)
|
||||
+ ThreadSafeShared(_Atomic_word initialRefCount = 1)
|
||||
: ThreadSafeSharedBase(initialRefCount)
|
||||
{
|
||||
}
|
@ -1,27 +0,0 @@
|
||||
diff -up webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h.s390 webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h
|
||||
--- webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h.s390 2010-03-31 15:56:53.000000000 +0200
|
||||
+++ webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h 2010-03-31 15:57:32.000000000 +0200
|
||||
@@ -306,6 +306,14 @@
|
||||
#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
#endif
|
||||
|
||||
+/* PLATFORM(S390*) */
|
||||
+#if defined(__s390x__)
|
||||
+#define WTF_PLATFORM_S390X 1
|
||||
+#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
+#elif defined(__s390__) /*PLATFORM(S390) */
|
||||
+#define WTF_PLATFORM_S390 1
|
||||
+#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
+#endif
|
||||
|
||||
/* PLATFORM(WINCE) && PLATFORM(QT)
|
||||
We can not determine the endianess at compile time. For
|
||||
@@ -634,7 +642,7 @@
|
||||
#endif
|
||||
|
||||
#if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
|
||||
-#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX)) || PLATFORM(SPARC64)
|
||||
+#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX)) || PLATFORM(SPARC64) || PLATFORM(S390x)
|
||||
#define WTF_USE_JSVALUE64 1
|
||||
#elif PLATFORM(ARM) || PLATFORM(PPC64)
|
||||
#define WTF_USE_JSVALUE32 1
|
@ -1,25 +0,0 @@
|
||||
diff -up webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h.sparc webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h
|
||||
--- webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h.sparc 2009-10-01 15:06:02.000000000 -0400
|
||||
+++ webkit-1.1.15.4/JavaScriptCore/wtf/Platform.h 2010-03-22 13:27:50.011061289 -0400
|
||||
@@ -301,8 +301,12 @@
|
||||
#if defined(__sparc__) && defined(__arch64__) || defined (__sparcv9)
|
||||
#define WTF_PLATFORM_SPARC64 1
|
||||
#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
+#elif defined(__sparc__) /*PLATFORM(SPARC) */
|
||||
+#define WTF_PLATFORM_SPARC 1
|
||||
+#define WTF_PLATFORM_BIG_ENDIAN 1
|
||||
#endif
|
||||
|
||||
+
|
||||
/* PLATFORM(WINCE) && PLATFORM(QT)
|
||||
We can not determine the endianess at compile time. For
|
||||
Qt for Windows CE the endianess is specified in the
|
||||
@@ -630,7 +634,7 @@
|
||||
#endif
|
||||
|
||||
#if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
|
||||
-#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX))
|
||||
+#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX)) || PLATFORM(SPARC64)
|
||||
#define WTF_USE_JSVALUE64 1
|
||||
#elif PLATFORM(ARM) || PLATFORM(PPC64)
|
||||
#define WTF_USE_JSVALUE32 1
|
@ -34,8 +34,8 @@
|
||||
%bcond_with wml
|
||||
|
||||
Name: webkitgtk
|
||||
Version: 1.1.15.4
|
||||
Release: 3%{?dist}.1
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK+ Web content engine library
|
||||
|
||||
Provides: WebKit-gtk = %{version}-%{release}
|
||||
@ -47,10 +47,6 @@ URL: http://www.webkitgtk.org/
|
||||
|
||||
Source0: http://www.webkitgtk.org/webkit-%{version}.tar.gz
|
||||
|
||||
# Fix for sparc/sparc64
|
||||
# Derived from: https://bugs.webkit.org/show_bug.cgi?id=35429
|
||||
Patch0: webkit-1.1.15.4-sparc.patch
|
||||
|
||||
## See: https://bugzilla.redhat.com/show_bug.cgi?id=516057
|
||||
## FIXME: We forcibly disable the JIT compiler for the time being.
|
||||
## This is a temporary workaround which causes a slight performance hit on
|
||||
@ -59,10 +55,8 @@ Patch0: webkit-1.1.15.4-sparc.patch
|
||||
## bug. :)
|
||||
#Patch1: webkit-1.1.13-no-execmem.patch
|
||||
Patch2: webkit-1.1.14-nspluginwrapper.patch
|
||||
|
||||
Patch3: webkit-1.1.15.4-s390x.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# https://bugs.webkit.org/show_bug.cgi?id=36381
|
||||
Patch3: webkit-1.1.22-icu44.patch
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: chrpath
|
||||
@ -122,10 +116,9 @@ LICENSE, README, and AUTHORS files.
|
||||
|
||||
%prep
|
||||
%setup -qn "webkit-%{version}"
|
||||
%patch0 -p1 -b .sparc
|
||||
# %patch1 -p1 -b .no-execmem
|
||||
%patch2 -p1 -b .nspluginwrapper
|
||||
%patch3 -p1 -b .s390x
|
||||
%patch3 -p2 -b .icu44
|
||||
|
||||
%build
|
||||
CFLAGS="%optflags -DLIBSOUP_I_HAVE_READ_BUG_594377_AND_KNOW_SOUP_PASSWORD_MANAGER_MIGHT_GO_AWAY" %configure \
|
||||
@ -138,8 +131,11 @@ CFLAGS="%optflags -DLIBSOUP_I_HAVE_READ_BUG_594377_AND_KNOW_SOUP_PASSWORD_MANAGE
|
||||
%{?with_svg: --enable-svg-filters } \
|
||||
%{?with_wml: --enable-wml }
|
||||
|
||||
make %{?_smp_mflags}
|
||||
mkdir -p DerivedSources/
|
||||
|
||||
# Disabled because of https://bugs.webkit.org/show_bug.cgi?id=34846
|
||||
#make %{?_smp_mflags}
|
||||
make
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
@ -202,17 +198,29 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Mar 31 2010 Karsten Hopp <karsten@redhat.com> 1.1.15.4-3.1
|
||||
- add s390 patch
|
||||
* Sun Apr 11 2010 Matthias Clasen <mclasen@redhat.com> 1.2.0-1
|
||||
- Update to 1.2.0
|
||||
|
||||
* Tue Mar 23 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1.15.4-3
|
||||
- fixup sparc handling
|
||||
* Fri Apr 02 2010 Caolán McNamara <caolanm@redhat.com> 1.1.22-3
|
||||
- rebuild for icu 4.4
|
||||
|
||||
* Tue Feb 23 2010 Dennis Gilmore <dennis@ausil.us> - 1.1.15.4-2
|
||||
- update sparc64 attomic word patch
|
||||
* Tue Mar 23 2010 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.22-2
|
||||
- apply upstream fix for sparc
|
||||
|
||||
* Fri Dec 11 2009 Adam Miller <maxamillion@fedoraproject.org> - 1.1.15.4-1
|
||||
- Update to 1.1.15.4
|
||||
* Mon Feb 22 2010 Matthias Clasen <mclasen@redhat.com> 1.1.22-1
|
||||
- Update to 1.1.22
|
||||
|
||||
* Wed Feb 10 2010 Bastien Nocera <bnocera@redhat.com> 1.1.21-1
|
||||
- Update to 1.1.21
|
||||
|
||||
* Tue Jan 26 2010 Matthias Clasen <mclasen@redhat.com> 1.1.19-1
|
||||
- Update to 1.1.19
|
||||
|
||||
* Sun Jan 17 2010 Matthias Clasen <mclasen@redhat.com> 1.1.18-1
|
||||
- Update to 1.1.18
|
||||
|
||||
* Tue Dec 01 2009 Bastien Nocera <bnocera@redhat.com> 1.1.17-1
|
||||
- Update to 1.1.17
|
||||
|
||||
* Sat Oct 31 2009 Matthias Clasen <mclasen@redhat.com> - 1.1.15.3-1
|
||||
- Update to 1.1.15.3, more crash fixes and important media player fixes
|
||||
|
Loading…
Reference in New Issue
Block a user