Revive this package!
We'll use this package to build the latest version of WebKitGTK as many times in as many configurations as we need to.
This commit is contained in:
parent
23de11ba15
commit
833783752d
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/webkitgtk-*.tar.xz
|
/webkitgtk-*.tar.xz
|
||||||
|
/webkitgtk-2.37.1.tar.xz.asc
|
||||||
|
19
aarch64-page-size.patch
Normal file
19
aarch64-page-size.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
diff --git a/Source/WTF/wtf/PageBlock.h b/Source/WTF/wtf/PageBlock.h
|
||||||
|
index 9bb7fffcc1ae..3e1e24aa69f5 100644
|
||||||
|
--- a/Source/WTF/wtf/PageBlock.h
|
||||||
|
+++ b/Source/WTF/wtf/PageBlock.h
|
||||||
|
@@ -45,11 +45,11 @@ namespace WTF {
|
||||||
|
// On Linux, Power systems normally use 64 KiB pages.
|
||||||
|
//
|
||||||
|
// Use 64 KiB for any unknown CPUs to be conservative.
|
||||||
|
-#if OS(DARWIN) || PLATFORM(PLAYSTATION) || CPU(MIPS) || CPU(MIPS64) || (OS(LINUX) && CPU(ARM64))
|
||||||
|
+#if OS(DARWIN) || PLATFORM(PLAYSTATION) || CPU(MIPS) || CPU(MIPS64)
|
||||||
|
constexpr size_t CeilingOnPageSize = 16 * KB;
|
||||||
|
-#elif CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(UNKNOWN)
|
||||||
|
+#elif CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(UNKNOWN) || CPU(ARM64)
|
||||||
|
constexpr size_t CeilingOnPageSize = 64 * KB;
|
||||||
|
-#elif OS(WINDOWS) || CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(RISCV64)
|
||||||
|
+#elif OS(WINDOWS) || CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(RISCV64)
|
||||||
|
constexpr size_t CeilingOnPageSize = 4 * KB;
|
||||||
|
#else
|
||||||
|
#error Must set CeilingOnPageSize in PageBlock.h when adding a new CPU architecture!
|
2
changelog
Normal file
2
changelog
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
* Thu Aug 04 2022 Michael Catanzaro <mcatanzaro@redhat.com> - 2.37.1-12
|
||||||
|
- Initial import. This manual changelog entry hides the repo's long git history from rpm-autospec.
|
27
fix-cloop-build.patch
Normal file
27
fix-cloop-build.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 40e49bb53218a986b4d6569f3fc2730cc4b71472 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Catanzaro <mcatanzaro@redhat.com>
|
||||||
|
Date: Tue, 12 Jul 2022 16:56:56 -0700
|
||||||
|
Subject: [PATCH] Fix cloop build after 252338@main
|
||||||
|
https://bugs.webkit.org/show_bug.cgi?id=242579
|
||||||
|
|
||||||
|
Reviewed by Mark Lam.
|
||||||
|
|
||||||
|
* Source/JavaScriptCore/CMakeLists.txt:
|
||||||
|
|
||||||
|
Canonical link: https://commits.webkit.org/252400@main
|
||||||
|
---
|
||||||
|
Source/JavaScriptCore/CMakeLists.txt | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
|
||||||
|
index aef0678e66f3..f4ba2716faef 100644
|
||||||
|
--- a/Source/JavaScriptCore/CMakeLists.txt
|
||||||
|
+++ b/Source/JavaScriptCore/CMakeLists.txt
|
||||||
|
@@ -837,6 +837,7 @@ set(JavaScriptCore_PRIVATE_FRAMEWORK_HEADERS
|
||||||
|
inspector/remote/RemoteInspector.h
|
||||||
|
|
||||||
|
interpreter/AbstractPC.h
|
||||||
|
+ interpreter/CLoopStack.h
|
||||||
|
interpreter/CallFrame.h
|
||||||
|
interpreter/CallFrameInlines.h
|
||||||
|
interpreter/CalleeBits.h
|
4
rpminspect.yaml
Normal file
4
rpminspect.yaml
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
---
|
||||||
|
inspections:
|
||||||
|
changedfiles: off
|
||||||
|
filesize: off
|
3
sources
3
sources
@ -1 +1,2 @@
|
|||||||
24a25ccc30a7914ae50922aedf24b7bc webkitgtk-2.4.11.tar.xz
|
SHA512 (webkitgtk-2.37.1.tar.xz) = 29935eed5e901780d6be02a7f1072f10e61ad96cecdc3495a71dc8ca00573fa9c485c909fcba928d818df6b901a265a077238ce5fa0cfcc657bdb991867facd8
|
||||||
|
SHA512 (webkitgtk-2.37.1.tar.xz.asc) = 5b58dd14f79abcacc3ffa3a9655d9067d6ea392203ab96567a2420bc2d1fff94ea1b9147ad128a321803b99cb6e05aecdd7db14b784a2df177a5afb30ec6b0d1
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
From 050232bc122d6785fea01d39121c2f93e8dd16f1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Catanzaro <mcatanzaro@igalia.com>
|
|
||||||
Date: Thu, 26 Feb 2015 16:06:36 -0600
|
|
||||||
Subject: [PATCH] Allow branding the user agent
|
|
||||||
|
|
||||||
---
|
|
||||||
Source/WebCore/platform/gtk/UserAgentGtk.cpp | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Source/WebCore/platform/gtk/UserAgentGtk.cpp b/Source/WebCore/platform/gtk/UserAgentGtk.cpp
|
|
||||||
index 91641dc..727fbaf 100644
|
|
||||||
--- a/Source/WebCore/platform/gtk/UserAgentGtk.cpp
|
|
||||||
+++ b/Source/WebCore/platform/gtk/UserAgentGtk.cpp
|
|
||||||
@@ -84,7 +84,9 @@ static const char* cpuDescriptionForUAString()
|
|
||||||
|
|
||||||
static const char* platformForUAString()
|
|
||||||
{
|
|
||||||
-#if PLATFORM(X11)
|
|
||||||
+#if defined USER_AGENT_GTK_DISTRIBUTOR_NAME
|
|
||||||
+ return USER_AGENT_GTK_DISTRIBUTOR_NAME;
|
|
||||||
+#elif PLATFORM(X11)
|
|
||||||
return "X11";
|
|
||||||
#elif OS(WINDOWS)
|
|
||||||
return "";
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,26 +0,0 @@
|
|||||||
diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp
|
|
||||||
--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2015-05-20 03:03:24.000000000 -0600
|
|
||||||
+++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2016-02-07 11:30:42.392686308 -0700
|
|
||||||
@@ -85,8 +85,8 @@
|
|
||||||
guint32 eventTime = getEventTime(event);
|
|
||||||
|
|
||||||
if ((event->type == GDK_2BUTTON_PRESS || event->type == GDK_3BUTTON_PRESS)
|
|
||||||
- || ((abs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
|
|
||||||
- && (abs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
|
|
||||||
+ || ((fabs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
|
|
||||||
+ && (fabs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
|
|
||||||
&& (eventTime - m_previousClickTime < static_cast<guint>(doubleClickTime))
|
|
||||||
&& (buttonEvent->button == m_previousClickButton)))
|
|
||||||
m_currentClickCount++;
|
|
||||||
diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp
|
|
||||||
--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2015-05-20 03:03:24.000000000 -0600
|
|
||||||
+++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2016-02-07 11:49:36.384691005 -0700
|
|
||||||
@@ -659,7 +659,7 @@
|
|
||||||
if (!std::isfinite(time))
|
|
||||||
return String::fromUTF8(_("indefinite time"));
|
|
||||||
|
|
||||||
- int seconds = static_cast<int>(abs(time));
|
|
||||||
+ int seconds = static_cast<int>(fabs(time));
|
|
||||||
int days = seconds / (60 * 60 * 24);
|
|
||||||
int hours = seconds / (60 * 60);
|
|
||||||
int minutes = (seconds / 60) % 60;
|
|
BIN
webkitgtk-keys.gpg
Normal file
BIN
webkitgtk-keys.gpg
Normal file
Binary file not shown.
1334
webkitgtk.spec
1334
webkitgtk.spec
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user