Rebase 6420 patch

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2020-04-26 13:20:11 +03:00
parent 82401f4ca5
commit acef3e4498
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
1 changed files with 11 additions and 55 deletions

View File

@ -1,66 +1,22 @@
From 150cfd242e2959bf9a0cd0ef5b1614e9c7fa4580 Mon Sep 17 00:00:00 2001
From: Ben Boeckel <ben.boeckel@kitware.com>
Date: Tue, 28 Jan 2020 09:14:49 -0500
Subject: [PATCH 1/2] exodusII: update for a GCC10 fix
---
ThirdParty/exodusII/update.sh | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ThirdParty/exodusII/update.sh b/ThirdParty/exodusII/update.sh
index eb6aac2bd8..db2450250a 100755
--- a/ThirdParty/exodusII/update.sh
+++ b/ThirdParty/exodusII/update.sh
@@ -8,7 +8,7 @@ readonly name="exodusII"
readonly ownership="Seacas Upstream <kwrobot@kitware.com>"
readonly subtree="ThirdParty/$name/vtk$name"
readonly repo="https://gitlab.kitware.com/third-party/seacas.git"
-readonly tag="for/vtk-20191230-7.24f-v2019-12-18"
+readonly tag="for/vtk-20200128-7.24f-v2019-12-18"
readonly paths="
packages/seacas/libraries/exodus/CMakeLists.vtk.txt
packages/seacas/libraries/exodus/cmake/exodus_config.h.in
--
2.24.1
From a9079bdccbb2165583d6773a5ed848427e2a38a8 Mon Sep 17 00:00:00 2001
From: Seacas Upstream <kwrobot@kitware.com>
Date: Tue, 28 Jan 2020 09:13:38 -0500
Subject: [PATCH 2/2] exodusII 2020-01-28 (d97eb08d)
Code extracted from:
https://gitlab.kitware.com/third-party/seacas.git
at commit d97eb08d79e87c82facfae39bc75deb60c0a2d83 (for/vtk-20200128-7.24f-v2019-12-18).
---
src/ex_create_par.c | 2 +-
src/ex_open_par.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/ex_create_par.c b/src/ex_create_par.c
index 8d5d6734f0..ef439618da 100644
--- a/src/ex_create_par.c
+++ b/src/ex_create_par.c
@@ -216,5 +216,5 @@ int ex_create_par_int(const char *path, int cmode, int *comp_ws, int *io_ws, MPI
diff --git a/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c b/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c
index bf5bb447..1286074f 100644
--- a/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c
+++ b/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c
@@ -614,5 +614,5 @@ int ex_create_par_int(const char *path, int cmode, int *comp_ws, int *io_ws, MPI
* Prevent warning in some versions of ranlib(1) because the object
* file has no symbols.
*/
-const char exodus_unused_symbol_dummy_1;
+const char exodus_unused_symbol_dummy_ex_create_par;
#endif
diff --git a/src/ex_open_par.c b/src/ex_open_par.c
index b2faa22c29..9df4818767 100644
--- a/src/ex_open_par.c
+++ b/src/ex_open_par.c
@@ -459,5 +459,5 @@ int ex_open_par_int(const char *path, int mode, int *comp_ws, int *io_ws, float
diff --git a/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c b/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c
index f379fc34..1aaf8419 100644
--- a/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c
+++ b/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c
@@ -474,5 +474,5 @@ int ex_open_par_int(const char *path, int mode, int *comp_ws, int *io_ws, float
* Prevent warning in some versions of ranlib(1) because the object
* file has no symbols.
*/
-const char exodus_unused_symbol_dummy_1;
+const char exodus_unused_symbol_dummy_ex_open_par;
+const char exodus_unused_symbol_dummy_ex_create_par;
#endif
--
2.24.1