Add patch to fix compilation with mesa 10.4 (bug #1138466)

Conflicts:
	vtk.spec
This commit is contained in:
Orion Poplawski 2014-11-19 10:30:52 -07:00
parent 40aab55f2c
commit a52ac5b2fd
2 changed files with 19 additions and 1 deletions

13
vtk-glext.patch Normal file
View File

@ -0,0 +1,13 @@
diff -up VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h.glext VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h
--- VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h.glext 2014-01-22 08:55:41.000000000 -0700
+++ VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h 2014-11-19 10:27:12.349345199 -0700
@@ -19,7 +19,8 @@
#include "vtkConfigure.h"
// To prevent gl.h to include glext.h provided by the system
-#define GL_GLEXT_LEGACY
+// https://bugzilla.redhat.com/show_bug.cgi?id=1138466
+// #define GL_GLEXT_LEGACY
#if defined(__APPLE__) && (defined(VTK_USE_CARBON) || defined(VTK_USE_COCOA))
# include <OpenGL/gl.h> // Include OpenGL API.
#else

View File

@ -22,8 +22,11 @@ Patch0: vtk-6.1.0-system.patch
# Install some more needed cmake files to try to support paraview build
# http://www.vtk.org/Bug/view.php?id=14157
Patch1: vtk-install.patch
#Patch to vtk to use system netcdf library
# Patch to vtk to use system netcdf library
Patch2: vtk-6.1.0-netcdf.patch
# Fix compilation with mesa 10.4
# https://bugzilla.redhat.com/show_bug.cgi?id=1138466
Patch3: vtk-glext.patch
URL: http://vtk.org/
@ -175,6 +178,7 @@ programming languages.
%patch0 -p1 -b .system
%patch1 -p1 -b .install
%patch2 -p1 -b .netcdf
%patch3 -p1 -b .glext
# Remove included thirdparty sources just to be sure
# TODO - vtksqlite
for x in autobahn vtkexpat vtkfreetype vtkgl2ps vtkhdf5 vtkjpeg vtklibxml2 vtknetcdf vtkoggtheora vtkpng vtktiff twisted vtkzlib zope
@ -451,6 +455,7 @@ cp -pr --parents Wrapping/*/README* _docs/
%changelog
* Sun Dec 13 2015 Orion Poplawski <orion@cora.nwra.com> - 6.1.0-5
- Add patch to fix compilation with mesa 10.4 (bug #1291099)
- Increase java heap space for builds (bug #1115920)
- Add requires on blas-devel and lapack-devel to vtk-devel (bug #1105004)
- Add Requires: qtwebkit-devel and hdf5-devel to vtk-devel (bug #1080781)