Update to 7.1.1

This commit is contained in:
Orion Poplawski 2017-05-08 07:54:23 -06:00
parent 11256227e1
commit 9cadffa1fd
5 changed files with 25 additions and 34 deletions

2
.gitignore vendored
View File

@ -11,3 +11,5 @@ vtk-5.6.0.tar.gz
/VTKData-6.3.0.tar.gz
/VTK-7.1.0.tar.gz
/VTKData-7.1.0.tar.gz
/VTK-7.1.1.tar.gz
/VTKData-7.1.1.tar.gz

View File

@ -1,2 +1,2 @@
a7e814c1db503d896af72458c2d0228f VTK-7.1.0.tar.gz
551786cdcb59fada678ecf0475cfcf55 VTKData-7.1.0.tar.gz
SHA512 (VTK-7.1.1.tar.gz) = 34a068801fe45f98325e5334d2569fc9b15ed38620386f1b5b860c9735e5fb8510953b50a3340d3ef9795e22fecf798c25bf750215b2ff1ff1eb7a1ecd87b623
SHA512 (VTKData-7.1.1.tar.gz) = 9fb2d10ee87d4aaa57aa31941ba2753d844658fb39fe84808500690ca4f74b87fdd68a31f4680789b7e57bb1edd3de9163ca533e54a7121348de7eac6165b988

View File

@ -1,25 +0,0 @@
diff -up VTK-7.1.0/Wrapping/Tools/vtkParsePreprocess.c.abi VTK-7.1.0/Wrapping/Tools/vtkParsePreprocess.c
--- VTK-7.1.0/Wrapping/Tools/vtkParsePreprocess.c.abi 2016-11-14 09:59:47.000000000 -0700
+++ VTK-7.1.0/Wrapping/Tools/vtkParsePreprocess.c 2016-12-01 16:12:45.793113151 -0700
@@ -2445,6 +2445,21 @@ void vtkParsePreprocess_AddStandardMacro
#ifdef __LITTLE_ENDIAN__
PREPROC_ADD_MACRO(info, __LITTLE_ENDIAN__);
#endif
+#ifdef __CHAR_UNSIGNED__
+ PREPROC_ADD_MACRO(info, __CHAR_UNSIGNED__);
+#endif
+#ifdef __SIZEOF_POINTER__
+ PREPROC_ADD_MACRO(info, __SIZEOF_POINTER__);
+#endif
+#ifdef _LP64
+ PREPROC_ADD_MACRO(info, _LP64);
+#endif
+#ifdef _ILP32
+ PREPROC_ADD_MACRO(info, _ILP32);
+#endif
+#ifdef __64BIT__
+ PREPROC_ADD_MACRO(info, __64BIT__);
+#endif
}
info->IsExternal = save_external;

12
vtk-format.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up VTK-7.1.1/Utilities/KWIML/vtkkwiml/test/CMakeLists.txt.format VTK-7.1.1/Utilities/KWIML/vtkkwiml/test/CMakeLists.txt
--- VTK-7.1.1/Utilities/KWIML/vtkkwiml/test/CMakeLists.txt.format 2017-03-20 09:26:17.000000000 -0600
+++ VTK-7.1.1/Utilities/KWIML/vtkkwiml/test/CMakeLists.txt 2017-05-07 14:10:46.231254800 -0600
@@ -10,7 +10,7 @@ endif()
# Suppress printf/scanf format warnings; we test if the sizes match.
foreach(lang C CXX)
if(KWIML_LANGUAGE_${lang} AND CMAKE_${lang}_COMPILER_ID STREQUAL "GNU")
- set(CMAKE_${lang}_FLAGS "${CMAKE_${lang}_FLAGS} -Wno-format")
+ set(CMAKE_${lang}_FLAGS "${CMAKE_${lang}_FLAGS} -Wno-format -Wno-format-security")
endif()
endforeach()

View File

@ -16,8 +16,8 @@
Summary: The Visualization Toolkit - A high level 3D visualization library
Name: vtk
Version: 7.1.0
Release: 6%{?dist}
Version: 7.1.1
Release: 1%{?dist}
# This is a variant BSD license, a cross between BSD and ZLIB.
# For all intents, it has the same rights and restrictions as BSD.
# http://fedoraproject.org/wiki/Licensing/BSD#VTKBSDVariant
@ -25,9 +25,8 @@ License: BSD
Source0: http://www.vtk.org/files/release/7.1/VTK-%{version}.tar.gz
Source1: http://www.vtk.org/files/release/7.1/VTKData-%{version}.tar.gz
Source2: xorg.conf
# Make sure wrapper abi is the same
# https://gitlab.kitware.com/vtk/vtk/issues/16919
Patch1: vtk-abi.patch
# Also set -Wno-format-security when setting -Wno-format
Patch0: vtk-format.patch
# Fix tcl library loading
# http://www.vtk.org/Bug/view.php?id=15279
Patch5: vtk-tcllib.patch
@ -448,7 +447,7 @@ programming languages.
%prep
%setup -q -b 1 -n VTK-%{version}
%patch1 -p1 -b .abi
%patch0 -p1 -b .format
%patch5 -p1 -b .tcllib
# Remove included thirdparty sources just to be sure
# TODO - alglib - http://www.vtk.org/Bug/view.php?id=15729
@ -479,7 +478,7 @@ export CFLAGS="%{optflags} -D_UNICODE -DHAVE_UINTPTR_T"
export CXXFLAGS="%{optflags} -D_UNICODE -DHAVE_UINTPTR_T"
%if %{with java}
export JAVA_HOME=/usr/lib/jvm/java
%ifarch s390x
%ifarch %{arm} s390x
# getting "java.lang.OutOfMemoryError: Java heap space" during the build
export JAVA_TOOL_OPTIONS=-Xmx2048m
%endif
@ -940,6 +939,9 @@ cat xorg.log
%changelog
* Mon May 8 2017 Orion Poplawski <orion@cora.nwra.com> - 7.1.1-1
- Update to 7.1.1
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.1.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild